Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 20600 (meta-gcc) - Compilation failure metabug
Summary: Compilation failure metabug
Status: RESOLVED CANTFIX
Alias: meta-gcc
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://gcc.gnu.org/bugs.html
Whiteboard:
Keywords:
: 10988 11968 14412 14864 15072 15410 15898 16233 16886 18920 19909 20716 20822 21375 21949 22420 22509 23001 24300 26769 26976 27508 29195 30054 33716 33808 36181 37142 39714 40524 43276 43677 47283 50418 50907 57221 58698 58969 59493 60411 61155 61671 61994 62174 63690 64560 64954 66477 68927 69089 74319 74913 75506 76524 77268 77860 77944 79178 79973 79974 80655 80905 Garfield 81597 82079 82307 82432 82829 83423 83457 83533 83986 85006 85711 87784 87856 88125 89086 89320 91237 92144 94591 95276 95391 96480 97583 98157 98392 98445 99342 100013 100159 101430 101547 101736 101750 101769 101933 102318 102390 103408 104684 104984 105350 105840 106632 106647 107050 107279 107750 107793 108490 108540 108563 108750 109539 109779 109821 111488 mplayer1.0 112467 113720 114590 114691 114773 115520 116841 117411 117430 117893 118154 119194 119424 119780 119920 122509 123871 124062 124935 126937 127130 127168 127514 127855 128013 128573 129243 129305 130318 130990 131790 132232 132568 135372 135593 136007 136190 136450 136754 136989 137360 138342 139183 139328 139461 139752 139829 140749 141297 141511 142137 142272 142529 142861 143153 143406 143501 144424 145623 145720 145916 146034 146141 146312 147510 147834 149070 149667 149780 149950 150418 150512 153029 153557 154141 154990 155110 155423 155611 155678 155817 155968 156333 156441 157363 158272 158644 158805 159709 164464 165503 167474 168350 170444 171059 173154 176430 179010 185352 185626 186250 189736 190169 190462 192461 193813 194998 196287 198521 198819 gcc-4.1.2 199728 200416 201729 204894 206080 208083 209131 212839 213230 216922 217320 218910 219878 229939 231218 232952 237325 259662 263624 322565 331909 332621 356869 377449 381061 385335 386347 390121 397327 399143 409279 424345 430644 431582 437818 451612 578926 584606 586032 603494 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-05-07 16:18 UTC by Paul de Vrieze (RETIRED)
Modified: 2017-07-16 09:41 UTC (History)
52 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:18:12 UTC
This is the compilation failure metabug. If your bugreport was marked a
duplicate of this one, it means the gentoo developers consider your problem to
be local to your setup. Look below for symptoms, causes and possible cures.

The compilation failure that cause a bug to be marked duplicate of this one can
be one of the following:
- internal compiler errors or gcc segfaults. These are caused by gcc. We are
  sorry, but we cannot do anything about those.

- Random segfaults during compilation. These are signalled by compilation
  failing at undetermined points. Often trying to recompile will succesfully
  compile the file it was complaining about, but will fail for another. This is
  in general a sign of hardware problems.

- Segfaults in auxiliary tools used in the compilation process. Some merges fail
  on segmentation faults in auxiliary tools. When those tools are stable
  themselves (bugs with the tools themselves should not be marked duplicate of
  this bug) the causes are often the same as for gcc problems.

There are multiple causes that can cause the above symptoms:
- Flaky hardware. This is showstopper number one. The cause can be either:
  - Insufficient power supply. To detect this try to unplug as many auxiliary
    devices (like cd-players, usb devices, etc.)  as possible and see whether
    the problem persists
  - Overclocked memory or CPU's can show random anomalous behaviour. Worse some
    hardware has these problems even at "factory speed". Lowering the clockspeed
    would be the solution to this problems
  - Overheated CPU's. CPU's have several calculation units which have a specific
    location on the chip. Compilation tends to intensively use a few of those
    units. This can cause heat problems within these units even when the overall
    chip temperature is within limits. If overheating is a problem a better cpu
    cooler often works. (Underclocking also works as heat increases with
    frequency)
  - Broken chipsets. There are some chipsets on motherboards which are broken.
    sometimes the os (read linux kernel) can work around some of these bugs,
    sometimes the only solution is a new motherboard.
- Overagressive compilation flags. There are many possible combinations of
  compilation flags. Some of them are problematic with some software by design,
  others contain bugs that are triggered by certain sources. In general the
  higher the optimization the more likely it is to hit a bug. If things work
  with CFLAGS="-O2 -mcpu=<yourcpu>" then this is your problem.
  Of particular note here is that there still are bugs in gcc-3.2.2's code
  generation with -march=pentium4. (If you have a pentium4 try to compile with
  CFLAGS="-march=pentium3 -mcpu=pentium4, if things work then, report it as in
  that case we can automatically filter -march=pentium4 for the package
  involved)
- Instable kernel. There is no guaranty for stability of the many kernels gentoo
  offers. Trying to use the vanilla kernel with conservative options can show
  whether you've hit a kernel bug. Especially kernel-preemption and low latency
  can cause problems with certain combinations of options (esp. hardware
  drivers)

Compilation flags should work. If you find a certain compilation flag that
doesn't work, look it up in the gcc manual (info gcc) and read whether it is
concidered safe to use in this case. In case it is considered safe you might
file a bug with the gcc developers.
Comment 1 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:22:41 UTC
Mark the bug as CANTFIX as we cannot resolve these problems. Additional comments, suggestions, possible causes and possible solutions are welcome as comments.
Comment 2 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:27:03 UTC
*** Bug 14412 has been marked as a duplicate of this bug. ***
Comment 3 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:28:07 UTC
*** Bug 14864 has been marked as a duplicate of this bug. ***
Comment 4 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:29:33 UTC
*** Bug 15072 has been marked as a duplicate of this bug. ***
Comment 5 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:30:29 UTC
*** Bug 15410 has been marked as a duplicate of this bug. ***
Comment 6 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:33:50 UTC
*** Bug 18920 has been marked as a duplicate of this bug. ***
Comment 7 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:42:02 UTC
*** Bug 10988 has been marked as a duplicate of this bug. ***
Comment 8 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:45:49 UTC
*** Bug 11968 has been marked as a duplicate of this bug. ***
Comment 9 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:48:24 UTC
*** Bug 15898 has been marked as a duplicate of this bug. ***
Comment 10 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:49:16 UTC
*** Bug 16233 has been marked as a duplicate of this bug. ***
Comment 11 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:53:13 UTC
*** Bug 16886 has been marked as a duplicate of this bug. ***
Comment 12 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-07 16:59:03 UTC
*** Bug 19909 has been marked as a duplicate of this bug. ***
Comment 13 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-16 15:13:35 UTC
*** Bug 20716 has been marked as a duplicate of this bug. ***
Comment 14 Robert Coie (RETIRED) gentoo-dev 2003-06-01 16:15:57 UTC
*** Bug 20822 has been marked as a duplicate of this bug. ***
Comment 15 Paul de Vrieze (RETIRED) gentoo-dev 2003-06-08 05:40:22 UTC
*** Bug 22420 has been marked as a duplicate of this bug. ***
Comment 16 Paul de Vrieze (RETIRED) gentoo-dev 2003-06-10 04:16:43 UTC
*** Bug 22509 has been marked as a duplicate of this bug. ***
Comment 17 Paul de Vrieze (RETIRED) gentoo-dev 2003-06-16 01:45:32 UTC
*** Bug 21375 has been marked as a duplicate of this bug. ***
Comment 18 Paul de Vrieze (RETIRED) gentoo-dev 2003-06-19 01:44:05 UTC
*** Bug 21949 has been marked as a duplicate of this bug. ***
Comment 19 Jon Portnoy (RETIRED) gentoo-dev 2003-07-11 17:25:16 UTC
*** Bug 24300 has been marked as a duplicate of this bug. ***
Comment 20 Brandon Hale (RETIRED) gentoo-dev 2003-08-30 20:47:58 UTC
*** Bug 26769 has been marked as a duplicate of this bug. ***
Comment 21 Paul de Vrieze (RETIRED) gentoo-dev 2003-09-23 08:20:57 UTC
*** Bug 29195 has been marked as a duplicate of this bug. ***
Comment 22 Caleb Tennis (RETIRED) gentoo-dev 2003-09-27 12:19:58 UTC
*** Bug 26976 has been marked as a duplicate of this bug. ***
Comment 23 Mr. Bones. (RETIRED) gentoo-dev 2003-10-02 00:52:30 UTC
Old Bug, should be marked. CANTFIX.
Comment 24 Donnie Berkholz (RETIRED) gentoo-dev 2003-10-07 13:43:57 UTC
*** Bug 23001 has been marked as a duplicate of this bug. ***
Comment 25 Marius Mauch (RETIRED) gentoo-dev 2003-11-19 09:25:37 UTC
*** Bug 33808 has been marked as a duplicate of this bug. ***
Comment 26 jack 2003-11-19 16:57:26 UTC
*** Bug 33716 has been marked as a duplicate of this bug. ***
Comment 27 Paul de Vrieze (RETIRED) gentoo-dev 2003-12-20 08:22:35 UTC
*** Bug 36181 has been marked as a duplicate of this bug. ***
Comment 28 Robert Coie (RETIRED) gentoo-dev 2003-12-20 15:02:02 UTC
*** Bug 30054 has been marked as a duplicate of this bug. ***
Comment 29 Wojciech Potentas 2003-12-20 16:09:50 UTC
 It can be fault of dirty hardware. It can be I think also a problem of raised voltage from power station. Normally in Poland there was 220 V and now it is 230. The power supply in computer (in Poland of course) is designed to take 220V. I thing higher volatage can rise the speed of linear rising of the signal in CPU clock and make the CPU frequency faster, then (cause the processor is running in funny frequency) hazards can occur (as said below). Good resolve should be a voltage converter. And fuck up the Polish politics for changing the
Voltage only for buying the power from Western Europe (we have enough power stations). 
Comment 30 Robert Coie (RETIRED) gentoo-dev 2003-12-23 15:07:57 UTC
*** Bug 27508 has been marked as a duplicate of this bug. ***
Comment 31 Paul de Vrieze (RETIRED) gentoo-dev 2004-01-29 01:12:43 UTC
*** Bug 39714 has been marked as a duplicate of this bug. ***
Comment 32 Wojciech Potentas 2004-01-29 03:39:54 UTC
 The time showed that my motherboard was broken.
Comment 33 Paul de Vrieze (RETIRED) gentoo-dev 2004-03-01 01:07:21 UTC
*** Bug 40524 has been marked as a duplicate of this bug. ***
Comment 34 Paul de Vrieze (RETIRED) gentoo-dev 2004-03-05 01:38:13 UTC
*** Bug 43677 has been marked as a duplicate of this bug. ***
Comment 35 Benjamin Judas (RETIRED) gentoo-dev 2004-05-10 21:28:38 UTC
*** Bug 50159 has been marked as a duplicate of this bug. ***
Comment 36 Benjamin Judas (RETIRED) gentoo-dev 2004-05-11 22:39:31 UTC
*** Bug 47283 has been marked as a duplicate of this bug. ***
Comment 37 Paul de Vrieze (RETIRED) gentoo-dev 2004-05-13 03:08:51 UTC
*** Bug 50907 has been marked as a duplicate of this bug. ***
Comment 38 Paul de Vrieze (RETIRED) gentoo-dev 2004-05-18 01:21:16 UTC
*** Bug 50418 has been marked as a duplicate of this bug. ***
Comment 39 Jon Portnoy (RETIRED) gentoo-dev 2004-07-28 11:55:29 UTC
*** Bug 57221 has been marked as a duplicate of this bug. ***
Comment 40 Chris White (RETIRED) gentoo-dev 2004-07-28 14:44:54 UTC
*** Bug 58698 has been marked as a duplicate of this bug. ***
Comment 41 Ciaran McCreesh 2004-07-31 06:51:45 UTC
*** Bug 43276 has been marked as a duplicate of this bug. ***
Comment 42 Carsten Lohrke (RETIRED) gentoo-dev 2004-08-21 10:21:57 UTC
*** Bug 61155 has been marked as a duplicate of this bug. ***
Comment 43 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-08-25 18:48:55 UTC
*** Bug 61671 has been marked as a duplicate of this bug. ***
Comment 44 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-08-27 23:46:52 UTC
*** Bug 61994 has been marked as a duplicate of this bug. ***
Comment 45 Chris White (RETIRED) gentoo-dev 2004-08-29 19:37:32 UTC
*** Bug 62174 has been marked as a duplicate of this bug. ***
Comment 46 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-09-11 12:40:33 UTC
*** Bug 63690 has been marked as a duplicate of this bug. ***
Comment 47 Ji-Young Kim 2004-09-22 17:15:26 UTC
*** Bug 64954 has been marked as a duplicate of this bug. ***
Comment 48 Donnie Berkholz (RETIRED) gentoo-dev 2004-09-30 13:59:10 UTC
*** Bug 37142 has been marked as a duplicate of this bug. ***
Comment 49 Chris White (RETIRED) gentoo-dev 2004-10-05 22:01:46 UTC
*** Bug 59493 has been marked as a duplicate of this bug. ***
Comment 50 Donnie Berkholz (RETIRED) gentoo-dev 2004-10-07 16:34:59 UTC
*** Bug 64560 has been marked as a duplicate of this bug. ***
Comment 51 Donnie Berkholz (RETIRED) gentoo-dev 2004-10-07 16:54:35 UTC
*** Bug 66477 has been marked as a duplicate of this bug. ***
Comment 52 Benjamin Judas (RETIRED) gentoo-dev 2004-10-07 21:51:32 UTC
*** Bug 66722 has been marked as a duplicate of this bug. ***
Comment 53 Benjamin Judas (RETIRED) gentoo-dev 2004-10-25 22:37:11 UTC
*** Bug 68927 has been marked as a duplicate of this bug. ***
Comment 54 Donnie Berkholz (RETIRED) gentoo-dev 2004-10-27 11:18:33 UTC
*** Bug 69089 has been marked as a duplicate of this bug. ***
Comment 55 Donnie Berkholz (RETIRED) gentoo-dev 2004-11-17 23:01:04 UTC
*** Bug 60411 has been marked as a duplicate of this bug. ***
Comment 56 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-12-13 19:57:18 UTC
*** Bug 74319 has been marked as a duplicate of this bug. ***
Comment 57 Benjamin Judas (RETIRED) gentoo-dev 2004-12-19 04:47:39 UTC
*** Bug 74913 has been marked as a duplicate of this bug. ***
Comment 58 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-12-24 00:14:05 UTC
*** Bug 75506 has been marked as a duplicate of this bug. ***
Comment 59 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-12-24 00:22:51 UTC
As an additional note to this bug, some packages exhibit these problems significently more often than others. The compile of MySQL-4* really stresses the hardware, and in particular two files in it are much worse than others:
sql_yacc.*, item_sum.*

The former is a very large and complex file generated from yacc source data, and both of them put the optimization in GCC to it's fully potential.
I've seen machines that pass memtest86, cpuburn and every other test I can throw at them, but fail if anything more than -O0 is used for compiling sql_yacc.o.
Comment 60 Ciaran McCreesh 2005-01-03 11:18:58 UTC
*** Bug 76524 has been marked as a duplicate of this bug. ***
Comment 61 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-09 15:45:57 UTC
*** Bug 77268 has been marked as a duplicate of this bug. ***
Comment 62 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-14 14:05:41 UTC
*** Bug 77944 has been marked as a duplicate of this bug. ***
Comment 63 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-23 15:36:04 UTC
*** Bug 79178 has been marked as a duplicate of this bug. ***
Comment 64 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-29 11:03:32 UTC
*** Bug 79974 has been marked as a duplicate of this bug. ***
Comment 65 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-29 11:03:42 UTC
*** Bug 79973 has been marked as a duplicate of this bug. ***
Comment 66 vykk3 2005-01-29 13:20:39 UTC
I discovered the cause of this problem for me.

The computer case sits on the floor with the cover off.  Upon inspection the HSF was clogged with dust and the thermal compound had pretty much disappeared from between the HSF and the CPU.

Cleaned the dust out and re-thermal compounded the HSF/CPU and everything has been fine ever since.

Not that this is an OLD K6/500 box that has been in operation for at least 5 years now.
Comment 67 Dan Armak (RETIRED) gentoo-dev 2005-02-01 03:49:37 UTC
*** Bug 77860 has been marked as a duplicate of this bug. ***
Comment 68 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-10 14:07:15 UTC
*** Bug 80938 has been marked as a duplicate of this bug. ***
Comment 69 Wojciech Potentas 2005-02-10 16:11:48 UTC
I had many problems with Intel machines beginning from Pentium 3 800Mhz 
ending at Pentium 75. Some compilations never succeded, especcialy >=gcc-3.3.1. 
My AMD processors done it fine (Duron 1600, even AMD K6-2 300), I thought it was
somenthing from Intel. But then I discovered both AMD's had at least 192MB of 
RAM. It was it, when I put some spap to my Pentium 75 (overclocked for 133)
machine wich has 64MB of RAM, to make his operational memory over 192MB he compiled
everything I wanted (even faster that I though it should). Pentium 3 have had only
128MB and I never could succesfully acomplish bootstrap.sh or emerge system (when 
starting from stage2). I hadn't have the possibility of checking if giving more
RAM will work, case the motherboard started to hang very often and when I was 
trying to clean the dust from it, I scratched the processors surface. but I 
thing it could work. (I think that corruption of motherboard was fault of 
voltage rise from 220V to 230V in Poland, when central and eastern european 
countries joined Europe Union)
 So check if you have enough memory to end the compilation.
Another thing is that, that CFLAGS and CXXFLAGS are weakly described in manual.
I proposing to use:
"-Os or -O2" for machines with small cache (under 128kb)
"-O2" for machines with cache about 256kb
"-O3" for machines with big cache - 512kb and more.
CFLAGS should be: "-march=<machine> -pipe -Wall -s -fomit-frame-pointer"
CXXFLAGS should be: "-march=<machine> -pipe -Wall -s -fno-rtti -fexceptions"
doing bootstrap.sh and emerge system processes.
When db4 will be compiled one can change "-fexceptions" to "-fno-exceptions"
I heard the code is then faster, but I din't saw the difference so I'm using 
-fexceptions, case there was no ebuild that wanten from me no-exceptions.
I  See how it works and you will know if it is good for you to change or not to 
change -fexceptions flag.
 When someting isn't compilling corectly sometimes -mpcu=<machine> flag will 
help (for example Flight Gear Flight Simulator doesn't still compile on march)
and sometimes you should disable -fno-rtti but bigger part of ebuilds will compile.
 And last thing. When using -march put names of your special instructions in USE 
flags, for example - when using -march=athlon-xp put: USE="[...] mmx mmx2 3dnow 
3dnowex 3dnow2 sse" then ebuild will know what should they compile in binary.
Thats all for now.
Comment 70 Paul de Vrieze (RETIRED) gentoo-dev 2005-02-11 02:19:25 UTC
Please please, do not use "-fno-rtti -fexceptions" Both these flags are application specific. They turn of standard c++ features. THIS WILL ONLY WORK if the application in question does not use those features. Applications that use them (i.e. use c++ as it is supposed to be used) will fail in all kinds of strange ways. Never do this globally, and only locally if you are the author of the software.

btw. If your motherboard gets corrupted because of the voltage switch this can only mean one thing: A power supply that is at or over the edge of it's operating parameters. The 10 volt diference is within the normal tollerance of power supplies. If however the power demand is allready higher than it can handle, things can break. Please remember in this that overclocking means you also use more power.
Comment 71 Wojciech Potentas 2005-02-11 06:41:31 UTC
 I overclocked the Pentium processor, Pentium 3 was untouched. I thought it is a fault of higher voltage case condensators on the motherboard were bulbed.
 About flags: I'm using them both, most of sotfware compiles, maybe "-fno-rtti" isn't needed, but db4 will compile only with "-fexceptions" turned on, of course. When I was writing that comment I forgot, you can change the settings localy for selected package in /etc/portage/package.use, sorry for that. 
Maybe this should be done automatically somewhere - to make the boostrap.sh and emerge system processes easier?
Comment 72 Paul de Vrieze (RETIRED) gentoo-dev 2005-02-11 06:55:57 UTC
You can't cflags in /etc/portage/package.use, only through hacks in /etc/portage/bashrc. But they are NOT SAFE IN ANY CASE and not recommended.

About the power supply. Your motherboard does not run on 220/230 volts, but on a lower voltage (I believe, but don't pin me on it 12 volts). Depending on your power supply this is a clean dc current with little variance at 12 volts, or a less than clean supply around 12 volts. Good power converters have electronic circuits that stabilize the voltage. That makes them able to cope with the change in voltage between 220/230. Most power supplies are even designed for multiple voltages to make export easier. (My printer has a power supply that can handle input ranges from 110 volts to 230)
Comment 73 Jeremy Huddleston (RETIRED) gentoo-dev 2005-02-14 23:48:42 UTC
*** Bug 80655 has been marked as a duplicate of this bug. ***
Comment 74 Jeremy Huddleston (RETIRED) gentoo-dev 2005-02-14 23:49:38 UTC
*** Bug 81597 has been marked as a duplicate of this bug. ***
Comment 75 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-02-15 02:20:20 UTC
*** Bug 82079 has been marked as a duplicate of this bug. ***
Comment 76 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-02-17 11:20:23 UTC
*** Bug 82307 has been marked as a duplicate of this bug. ***
Comment 77 Gregorio Guidi (RETIRED) gentoo-dev 2005-02-18 09:43:53 UTC
*** Bug 82432 has been marked as a duplicate of this bug. ***
Comment 78 Carsten Lohrke (RETIRED) gentoo-dev 2005-02-21 09:48:22 UTC
*** Bug 82829 has been marked as a duplicate of this bug. ***
Comment 79 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-02-26 18:41:09 UTC
*** Bug 83423 has been marked as a duplicate of this bug. ***
Comment 80 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-27 15:07:41 UTC
*** Bug 83457 has been marked as a duplicate of this bug. ***
Comment 81 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-02-28 02:37:14 UTC
*** Bug 83533 has been marked as a duplicate of this bug. ***
Comment 82 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-03-03 12:35:29 UTC
*** Bug 83986 has been marked as a duplicate of this bug. ***
Comment 83 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-03-13 01:14:59 UTC
*** Bug 85006 has been marked as a duplicate of this bug. ***
Comment 84 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-03-17 19:09:16 UTC
*** Bug 85711 has been marked as a duplicate of this bug. ***
Comment 85 m4chine 2005-03-18 08:53:39 UTC
I run the ASUS 266-D with dual AMD MP 2800s and by default they run ~2ghz on 266mhz bus. Until reading this post, gcc was segfaulting inconsistently durring build. I then rebooted, went to my bios and dropped cpu speed to ~1.6ghz, gcc then built flawlessly.
Comment 86 Carsten Lohrke (RETIRED) gentoo-dev 2005-04-05 13:14:11 UTC
*** Bug 87856 has been marked as a duplicate of this bug. ***
Comment 87 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-04-06 05:41:12 UTC
*** Bug 88125 has been marked as a duplicate of this bug. ***
Comment 88 SpanKY gentoo-dev 2005-05-02 15:14:18 UTC
*** Bug 91237 has been marked as a duplicate of this bug. ***
Comment 89 SpanKY gentoo-dev 2005-05-30 18:21:08 UTC
*** Bug 58969 has been marked as a duplicate of this bug. ***
Comment 90 Gregorio Guidi (RETIRED) gentoo-dev 2005-05-31 02:09:16 UTC
*** Bug 94591 has been marked as a duplicate of this bug. ***
Comment 91 Martin Väth 2005-05-31 16:05:06 UTC
I think there are two things mixed in this bug which shouldn't be mixed: It is 
probably true that things like "internal error: Segmentation fault" or other 
illegal instructions are due to flaky hardware/bad memory/overclocking/heat 
problems etc. 
However, the other thing also included in this bug is the systematic filling 
of memory which eventually ends in "internal error: killed" - it is hard to 
imagine that a hardware problem can cause the kernel or some basic library to 
consider memory as reserved, and, moreover, to do this rather reproducible and 
without *ever* hitting some illegal instruction or exhibiting some other 
strange behaviour (and moreover, doing this same thing in x86 and amd64 modes 
and independent of temperature/clock rate and the compilation flags of the 
used kernel/gcc/other libraries (and with kernels/kernel configurations)). 
This sounds to me much more like a *software* bug in the kernel or gcc or some 
basic library which apparently (for some unknown reason) only shows up in some 
architectures. Unfortunately, I am running out of ideas of how to locate this 
bug. Any hints are appreciated (or also an explanation why this might be a 
hardware problem anyway). 
 
Comment 92 Jakub Moc (RETIRED) gentoo-dev 2005-06-07 15:40:59 UTC
*** Bug 95391 has been marked as a duplicate of this bug. ***
Comment 93 Gregorio Guidi (RETIRED) gentoo-dev 2005-06-20 04:47:29 UTC
*** Bug 96480 has been marked as a duplicate of this bug. ***
Comment 94 Jakub Moc (RETIRED) gentoo-dev 2005-07-01 12:45:03 UTC
*** Bug 97583 has been marked as a duplicate of this bug. ***
Comment 95 Gregorio Guidi (RETIRED) gentoo-dev 2005-07-06 15:13:19 UTC
*** Bug 98157 has been marked as a duplicate of this bug. ***
Comment 96 Donnie Berkholz (RETIRED) gentoo-dev 2005-07-24 12:37:15 UTC
*** Bug 100013 has been marked as a duplicate of this bug. ***
Comment 97 Jakub Moc (RETIRED) gentoo-dev 2005-07-25 00:19:10 UTC
*** Bug 100159 has been marked as a duplicate of this bug. ***
Comment 98 SpanKY gentoo-dev 2005-08-04 20:11:50 UTC
*** Bug 98392 has been marked as a duplicate of this bug. ***
Comment 99 Ciaran McCreesh 2005-08-05 07:15:14 UTC
*** Bug 101430 has been marked as a duplicate of this bug. ***
Comment 100 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-08-06 12:26:41 UTC
*** Bug 101547 has been marked as a duplicate of this bug. ***
Comment 101 Mark Loeser (RETIRED) gentoo-dev 2005-08-07 17:58:41 UTC
*** Bug 99342 has been marked as a duplicate of this bug. ***
Comment 102 Jakub Moc (RETIRED) gentoo-dev 2005-08-08 07:34:07 UTC
*** Bug 101750 has been marked as a duplicate of this bug. ***
Comment 103 Jakub Moc (RETIRED) gentoo-dev 2005-08-08 08:23:18 UTC
*** Bug 101736 has been marked as a duplicate of this bug. ***
Comment 104 Gregorio Guidi (RETIRED) gentoo-dev 2005-08-08 16:17:37 UTC
*** Bug 101769 has been marked as a duplicate of this bug. ***
Comment 105 Gregorio Guidi (RETIRED) gentoo-dev 2005-08-12 02:10:08 UTC
*** Bug 101933 has been marked as a duplicate of this bug. ***
Comment 106 Jakub Moc (RETIRED) gentoo-dev 2005-08-13 01:35:51 UTC
*** Bug 102318 has been marked as a duplicate of this bug. ***
Comment 107 SpanKY gentoo-dev 2005-08-13 17:50:03 UTC
*** Bug 102390 has been marked as a duplicate of this bug. ***
Comment 108 Jakub Moc (RETIRED) gentoo-dev 2005-08-23 00:44:00 UTC
*** Bug 103408 has been marked as a duplicate of this bug. ***
Comment 109 Carsten Lohrke (RETIRED) gentoo-dev 2005-09-03 05:23:43 UTC
*** Bug 104684 has been marked as a duplicate of this bug. ***
Comment 110 Jakub Moc (RETIRED) gentoo-dev 2005-09-06 04:16:54 UTC
*** Bug 104984 has been marked as a duplicate of this bug. ***
Comment 111 Jakub Moc (RETIRED) gentoo-dev 2005-09-06 04:25:11 UTC
*** Bug 104984 has been marked as a duplicate of this bug. ***
Comment 112 Jakub Moc (RETIRED) gentoo-dev 2005-09-06 07:24:16 UTC
*** Bug 105006 has been marked as a duplicate of this bug. ***
Comment 113 Jakub Moc (RETIRED) gentoo-dev 2005-09-09 05:59:04 UTC
*** Bug 105350 has been marked as a duplicate of this bug. ***
Comment 114 Donnie Berkholz (RETIRED) gentoo-dev 2005-09-15 14:57:47 UTC
*** Bug 105840 has been marked as a duplicate of this bug. ***
Comment 115 Jakub Moc (RETIRED) gentoo-dev 2005-09-19 23:49:01 UTC
*** Bug 106632 has been marked as a duplicate of this bug. ***
Comment 116 Jakub Moc (RETIRED) gentoo-dev 2005-09-20 00:07:08 UTC
*** Bug 106647 has been marked as a duplicate of this bug. ***
Comment 117 Joshua Baergen (RETIRED) gentoo-dev 2005-09-23 18:04:20 UTC
*** Bug 107050 has been marked as a duplicate of this bug. ***
Comment 118 Jakub Moc (RETIRED) gentoo-dev 2005-09-26 06:42:56 UTC
*** Bug 107279 has been marked as a duplicate of this bug. ***
Comment 119 Jakub Moc (RETIRED) gentoo-dev 2005-10-01 00:51:12 UTC
*** Bug 107750 has been marked as a duplicate of this bug. ***
Comment 120 Donnie Berkholz (RETIRED) gentoo-dev 2005-10-05 20:03:19 UTC
*** Bug 80905 has been marked as a duplicate of this bug. ***
Comment 121 Jakub Moc (RETIRED) gentoo-dev 2005-10-09 04:29:19 UTC
*** Bug 108563 has been marked as a duplicate of this bug. ***
Comment 122 Jakub Moc (RETIRED) gentoo-dev 2005-10-10 13:39:44 UTC
*** Bug 108750 has been marked as a duplicate of this bug. ***
Comment 123 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-17 05:02:16 UTC
*** Bug 108490 has been marked as a duplicate of this bug. ***
Comment 124 Gregorio Guidi (RETIRED) gentoo-dev 2005-10-17 05:47:26 UTC
*** Bug 109539 has been marked as a duplicate of this bug. ***
Comment 125 Carsten Lohrke (RETIRED) gentoo-dev 2005-10-19 11:26:40 UTC
*** Bug 107793 has been marked as a duplicate of this bug. ***
Comment 126 SpanKY gentoo-dev 2005-10-20 12:37:15 UTC
*** Bug 109821 has been marked as a duplicate of this bug. ***
Comment 127 Jakub Moc (RETIRED) gentoo-dev 2005-10-24 00:55:47 UTC
*** Bug 110283 has been marked as a duplicate of this bug. ***
Comment 128 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-11-03 16:32:24 UTC
*** Bug 98445 has been marked as a duplicate of this bug. ***
Comment 129 Carsten Lohrke (RETIRED) gentoo-dev 2005-11-05 05:04:59 UTC
*** Bug 111538 has been marked as a duplicate of this bug. ***
Comment 130 SpanKY gentoo-dev 2005-11-28 11:14:58 UTC
*** Bug 113720 has been marked as a duplicate of this bug. ***
Comment 131 SpanKY gentoo-dev 2005-12-05 16:52:44 UTC
*** Bug 112467 has been marked as a duplicate of this bug. ***
Comment 132 Mark Loeser (RETIRED) gentoo-dev 2005-12-06 05:59:12 UTC
*** Bug 114590 has been marked as a duplicate of this bug. ***
Comment 133 Jakub Moc (RETIRED) gentoo-dev 2005-12-07 00:21:09 UTC
*** Bug 114691 has been marked as a duplicate of this bug. ***
Comment 134 Donnie Berkholz (RETIRED) gentoo-dev 2005-12-07 12:06:45 UTC
*** Bug 114773 has been marked as a duplicate of this bug. ***
Comment 135 Mark Loeser (RETIRED) gentoo-dev 2005-12-11 20:42:58 UTC
*** Bug 89320 has been marked as a duplicate of this bug. ***
Comment 136 Mark Loeser (RETIRED) gentoo-dev 2005-12-11 20:50:13 UTC
*** Bug 103874 has been marked as a duplicate of this bug. ***
Comment 137 Mark Loeser (RETIRED) gentoo-dev 2005-12-12 06:59:49 UTC
*** Bug 92144 has been marked as a duplicate of this bug. ***
Comment 138 Mark Loeser (RETIRED) gentoo-dev 2005-12-12 07:30:37 UTC
*** Bug 109779 has been marked as a duplicate of this bug. ***
Comment 139 Francesco R. (RETIRED) gentoo-dev 2005-12-14 08:11:11 UTC
*** Bug 115520 has been marked as a duplicate of this bug. ***
Comment 140 Mark Loeser (RETIRED) gentoo-dev 2005-12-15 00:42:34 UTC
*** Bug 111488 has been marked as a duplicate of this bug. ***
Comment 141 Jakub Moc (RETIRED) gentoo-dev 2005-12-22 20:57:09 UTC
*** Bug 87784 has been marked as a duplicate of this bug. ***
Comment 142 Mark Loeser (RETIRED) gentoo-dev 2005-12-27 11:17:06 UTC
*** Bug 116841 has been marked as a duplicate of this bug. ***
Comment 143 Jakub Moc (RETIRED) gentoo-dev 2005-12-28 20:18:30 UTC
*** Bug 117045 has been marked as a duplicate of this bug. ***
Comment 144 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-01-02 03:16:42 UTC
*** Bug 117430 has been marked as a duplicate of this bug. ***
Comment 145 Jakub Moc (RETIRED) gentoo-dev 2006-01-02 07:25:20 UTC
*** Bug 117411 has been marked as a duplicate of this bug. ***
Comment 146 Jakub Moc (RETIRED) gentoo-dev 2006-01-05 07:01:30 UTC
*** Bug 117893 has been marked as a duplicate of this bug. ***
Comment 147 Jakub Moc (RETIRED) gentoo-dev 2006-01-07 04:24:39 UTC
*** Bug 118154 has been marked as a duplicate of this bug. ***
Comment 148 Jonh Smith 2006-01-07 04:49:15 UTC
removed me from CC
Comment 149 Mark Loeser (RETIRED) gentoo-dev 2006-01-15 16:27:54 UTC
*** Bug 108540 has been marked as a duplicate of this bug. ***
Comment 150 Jakub Moc (RETIRED) gentoo-dev 2006-01-16 08:27:22 UTC
*** Bug 119194 has been marked as a duplicate of this bug. ***
Comment 151 SpanKY gentoo-dev 2006-01-18 10:12:29 UTC
*** Bug 119424 has been marked as a duplicate of this bug. ***
Comment 152 Jakub Moc (RETIRED) gentoo-dev 2006-01-21 02:51:29 UTC
*** Bug 119780 has been marked as a duplicate of this bug. ***
Comment 153 Jakub Moc (RETIRED) gentoo-dev 2006-01-22 06:28:48 UTC
*** Bug 119920 has been marked as a duplicate of this bug. ***
Comment 154 Jakub Moc (RETIRED) gentoo-dev 2006-02-12 00:11:19 UTC
*** Bug 122509 has been marked as a duplicate of this bug. ***
Comment 155 Jakub Moc (RETIRED) gentoo-dev 2006-02-23 16:52:02 UTC
*** Bug 123871 has been marked as a duplicate of this bug. ***
Comment 156 molle.bestefich 2006-02-23 17:36:34 UTC
remove me from cc
Comment 157 Jakub Moc (RETIRED) gentoo-dev 2006-02-25 06:43:19 UTC
*** Bug 124062 has been marked as a duplicate of this bug. ***
Comment 158 Mark Loeser (RETIRED) gentoo-dev 2006-03-05 09:29:05 UTC
*** Bug 124935 has been marked as a duplicate of this bug. ***
Comment 159 Cyril Jaquier 2006-03-05 10:58:43 UTC
Remove me from CC list.
Comment 160 Francesco R. (RETIRED) gentoo-dev 2006-03-18 03:59:09 UTC
*** Bug 123871 has been marked as a duplicate of this bug. ***
Comment 161 Jakub Moc (RETIRED) gentoo-dev 2006-03-21 04:14:10 UTC
*** Bug 126937 has been marked as a duplicate of this bug. ***
Comment 162 Jakub Moc (RETIRED) gentoo-dev 2006-03-22 04:04:23 UTC
*** Bug 127168 has been marked as a duplicate of this bug. ***
Comment 163 Jakub Moc (RETIRED) gentoo-dev 2006-03-22 04:37:10 UTC
*** Bug 127130 has been marked as a duplicate of this bug. ***
Comment 164 Jakub Moc (RETIRED) gentoo-dev 2006-03-25 04:59:17 UTC
*** Bug 127514 has been marked as a duplicate of this bug. ***
Comment 165 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-03-29 10:24:45 UTC
*** Bug 128013 has been marked as a duplicate of this bug. ***
Comment 166 Jakub Moc (RETIRED) gentoo-dev 2006-04-02 15:07:20 UTC
*** Bug 128573 has been marked as a duplicate of this bug. ***
Comment 167 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-04-02 20:41:21 UTC
*** Bug 127855 has been marked as a duplicate of this bug. ***
Comment 168 Jakub Moc (RETIRED) gentoo-dev 2006-04-08 07:49:50 UTC
*** Bug 129243 has been marked as a duplicate of this bug. ***
Comment 169 Jakub Moc (RETIRED) gentoo-dev 2006-04-09 03:02:29 UTC
*** Bug 129305 has been marked as a duplicate of this bug. ***
Comment 170 sargun dhillon 2006-04-09 14:28:09 UTC
Runnning out of resources is another think which can cause this.
Things to check:
-Sufficent free memory
This can be calculated by the root directory of the program times about 3.
-File descriptors
Just make sure you don't have over 500-600 files being written to or read from
Comment 171 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-04-18 06:59:40 UTC
*** Bug 130318 has been marked as a duplicate of this bug. ***
Comment 172 Jakub Moc (RETIRED) gentoo-dev 2006-04-23 11:39:34 UTC
*** Bug 130990 has been marked as a duplicate of this bug. ***
Comment 173 Philippe Payant 2006-04-23 13:28:49 UTC
Other possible case: out of memory.  My swap was broken and the compilation ran out of memory (128MB RAM).  Swap fixed, problem solved.  Good luck to all.
Comment 174 David Watzke 2006-04-23 13:54:33 UTC
(In reply to comment #173)
> Other possible case: out of memory.  My swap was broken and the compilation ran out of memory (128MB RAM).  Swap fixed, problem solved.  Good luck to all.

Yeah, that's true.. Btw, 

- Random segfaults during compilation. These are signalled by compilation failing at undetermined points. Often trying to recompile will succesfully compile the file it was complaining about, but will fail for another. This is in general a sign of hardware problems.

// No, this is in general a sign of GCC 4.1 - problem ;-)
Comment 175 Jakub Moc (RETIRED) gentoo-dev 2006-04-30 06:27:22 UTC
*** Bug 131790 has been marked as a duplicate of this bug. ***
Comment 176 Jakub Moc (RETIRED) gentoo-dev 2006-05-04 04:52:19 UTC
*** Bug 132232 has been marked as a duplicate of this bug. ***
Comment 177 Andreas Proschofsky (RETIRED) gentoo-dev 2006-05-06 01:32:12 UTC
*** Bug 132412 has been marked as a duplicate of this bug. ***
Comment 178 Jakub Moc (RETIRED) gentoo-dev 2006-05-07 07:59:02 UTC
*** Bug 132568 has been marked as a duplicate of this bug. ***
Comment 179 Mark Loeser (RETIRED) gentoo-dev 2006-06-03 13:00:44 UTC
*** Bug 135372 has been marked as a duplicate of this bug. ***
Comment 180 Jakub Moc (RETIRED) gentoo-dev 2006-06-05 02:12:32 UTC
*** Bug 135593 has been marked as a duplicate of this bug. ***
Comment 181 Jakub Moc (RETIRED) gentoo-dev 2006-06-10 09:37:35 UTC
*** Bug 136190 has been marked as a duplicate of this bug. ***
Comment 182 Jakub Moc (RETIRED) gentoo-dev 2006-06-11 11:02:02 UTC
*** Bug 136450 has been marked as a duplicate of this bug. ***
Comment 183 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-06-13 04:59:00 UTC
*** Bug 136007 has been marked as a duplicate of this bug. ***
Comment 184 Jakub Moc (RETIRED) gentoo-dev 2006-06-14 13:59:00 UTC
*** Bug 136754 has been marked as a duplicate of this bug. ***
Comment 185 Jakub Moc (RETIRED) gentoo-dev 2006-06-16 09:52:56 UTC
*** Bug 136989 has been marked as a duplicate of this bug. ***
Comment 186 Jakub Moc (RETIRED) gentoo-dev 2006-06-20 05:08:58 UTC
*** Bug 137360 has been marked as a duplicate of this bug. ***
Comment 187 DrEaMeR86 2006-06-20 05:59:14 UTC
(In reply to comment #1)
> Mark the bug as CANTFIX as we cannot resolve these problems. Additional
> comments, suggestions, possible causes and possible solutions are welcome as
> comments.
> 
it has compiled now for me with any "use flag" and with -march=pentium4 instead of -march=prescott =)
Comment 188 Jakub Moc (RETIRED) gentoo-dev 2006-06-28 05:16:38 UTC
*** Bug 138342 has been marked as a duplicate of this bug. ***
Comment 189 Jakub Moc (RETIRED) gentoo-dev 2006-07-04 09:06:45 UTC
*** Bug 139183 has been marked as a duplicate of this bug. ***
Comment 190 Jakub Moc (RETIRED) gentoo-dev 2006-07-06 11:58:40 UTC
*** Bug 139461 has been marked as a duplicate of this bug. ***
Comment 191 Jakub Moc (RETIRED) gentoo-dev 2006-07-10 00:13:37 UTC
*** Bug 139829 has been marked as a duplicate of this bug. ***
Comment 192 Jakub Moc (RETIRED) gentoo-dev 2006-07-10 00:35:55 UTC
*** Bug 139752 has been marked as a duplicate of this bug. ***
Comment 193 Jakub Moc (RETIRED) gentoo-dev 2006-07-17 02:46:34 UTC
*** Bug 140749 has been marked as a duplicate of this bug. ***
Comment 194 Jakub Moc (RETIRED) gentoo-dev 2006-07-21 08:47:51 UTC
*** Bug 141297 has been marked as a duplicate of this bug. ***
Comment 195 Jakub Moc (RETIRED) gentoo-dev 2006-07-23 11:21:04 UTC
*** Bug 141511 has been marked as a duplicate of this bug. ***
Comment 196 Jakub Moc (RETIRED) gentoo-dev 2006-07-23 11:51:01 UTC
*** Bug 141511 has been marked as a duplicate of this bug. ***
Comment 197 Jakub Moc (RETIRED) gentoo-dev 2006-07-30 03:44:33 UTC
*** Bug 142137 has been marked as a duplicate of this bug. ***
Comment 198 Jakub Moc (RETIRED) gentoo-dev 2006-08-01 02:54:38 UTC
*** Bug 142272 has been marked as a duplicate of this bug. ***
Comment 199 Patrick Byrne 2006-08-02 00:48:02 UTC
> Bug 142272 has been marked as a duplicate of this bug
Upgrading my RAM from 128MB to 512MB fixed this problem.


Comment 200 Donnie Berkholz (RETIRED) gentoo-dev 2006-08-02 22:59:39 UTC
*** Bug 139328 has been marked as a duplicate of this bug. ***
Comment 201 Jakub Moc (RETIRED) gentoo-dev 2006-08-05 05:08:07 UTC
*** Bug 142861 has been marked as a duplicate of this bug. ***
Comment 202 Jakub Moc (RETIRED) gentoo-dev 2006-08-08 00:35:10 UTC
*** Bug 143153 has been marked as a duplicate of this bug. ***
Comment 203 Jakub Moc (RETIRED) gentoo-dev 2006-08-10 00:42:49 UTC
*** Bug 143406 has been marked as a duplicate of this bug. ***
Comment 204 Jakub Moc (RETIRED) gentoo-dev 2006-08-10 14:19:28 UTC
*** Bug 143501 has been marked as a duplicate of this bug. ***
Comment 205 Jakub Moc (RETIRED) gentoo-dev 2006-08-19 08:42:24 UTC
*** Bug 144424 has been marked as a duplicate of this bug. ***
Comment 206 Carsten Lohrke (RETIRED) gentoo-dev 2006-08-24 08:41:52 UTC
*** Bug 142529 has been marked as a duplicate of this bug. ***
Comment 207 Carsten Lohrke (RETIRED) gentoo-dev 2006-08-24 11:46:40 UTC
*** Bug 95276 has been marked as a duplicate of this bug. ***
Comment 208 Jakub Moc (RETIRED) gentoo-dev 2006-08-30 10:20:26 UTC
*** Bug 145623 has been marked as a duplicate of this bug. ***
Comment 209 Jakub Moc (RETIRED) gentoo-dev 2006-08-31 09:10:21 UTC
*** Bug 145720 has been marked as a duplicate of this bug. ***
Comment 210 Jakub Moc (RETIRED) gentoo-dev 2006-09-01 15:49:14 UTC
*** Bug 145916 has been marked as a duplicate of this bug. ***
Comment 211 Jakub Moc (RETIRED) gentoo-dev 2006-09-02 14:17:14 UTC
*** Bug 146034 has been marked as a duplicate of this bug. ***
Comment 212 Jakub Moc (RETIRED) gentoo-dev 2006-09-03 08:45:15 UTC
*** Bug 146141 has been marked as a duplicate of this bug. ***
Comment 213 Jakub Moc (RETIRED) gentoo-dev 2006-09-04 15:27:50 UTC
*** Bug 146312 has been marked as a duplicate of this bug. ***
Comment 214 Jakub Moc (RETIRED) gentoo-dev 2006-09-13 23:37:28 UTC
*** Bug 147510 has been marked as a duplicate of this bug. ***
Comment 215 Jakub Moc (RETIRED) gentoo-dev 2006-09-17 01:22:25 UTC
*** Bug 147834 has been marked as a duplicate of this bug. ***
Comment 216 Jakub Moc (RETIRED) gentoo-dev 2006-09-25 09:14:53 UTC
*** Bug 149070 has been marked as a duplicate of this bug. ***
Comment 217 Jakub Moc (RETIRED) gentoo-dev 2006-10-01 12:23:12 UTC
*** Bug 149667 has been marked as a duplicate of this bug. ***
Comment 218 Jakub Moc (RETIRED) gentoo-dev 2006-10-01 14:52:37 UTC
*** Bug 149780 has been marked as a duplicate of this bug. ***
Comment 219 SpanKY gentoo-dev 2006-10-04 06:41:16 UTC
*** Bug 149950 has been marked as a duplicate of this bug. ***
Comment 220 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-10-04 23:59:41 UTC
*** Bug 89086 has been marked as a duplicate of this bug. ***
Comment 221 Jakub Moc (RETIRED) gentoo-dev 2006-10-07 15:28:37 UTC
*** Bug 150418 has been marked as a duplicate of this bug. ***
Comment 222 Jakub Moc (RETIRED) gentoo-dev 2006-10-09 00:01:50 UTC
*** Bug 150512 has been marked as a duplicate of this bug. ***
Comment 223 cj 2006-10-10 04:17:30 UTC
The UK used to be 240, we stepped down to 230...
All computers I know of run on DC (12V , 5V etc) which is why you need a PSU, sounds like yours needs replacing :-)

(In reply to comment #29)
>  It can be fault of dirty hardware. It can be I think also a problem of raised
> voltage from power station. Normally in Poland there was 220 V and now it is
> 230. The power supply in computer (in Poland of course) is designed to take
> 220V. I thing higher volatage can rise the speed of linear rising of the signal
> in CPU clock and make the CPU frequency faster, then (cause the processor is
> running in funny frequency) hazards can occur (as said below). Good resolve
> should be a voltage converter. And fuck up the Polish politics for changing the
> Voltage only for buying the power from Western Europe (we have enough power
> stations). 
> 

Comment 224 Jakub Moc (RETIRED) gentoo-dev 2006-10-27 14:09:30 UTC
*** Bug 153029 has been marked as a duplicate of this bug. ***
Comment 225 Jakub Moc (RETIRED) gentoo-dev 2006-10-31 07:42:00 UTC
*** Bug 153557 has been marked as a duplicate of this bug. ***
Comment 226 Jakub Moc (RETIRED) gentoo-dev 2006-11-04 09:36:46 UTC
*** Bug 154046 has been marked as a duplicate of this bug. ***
Comment 227 Jakub Moc (RETIRED) gentoo-dev 2006-11-05 07:50:06 UTC
*** Bug 154141 has been marked as a duplicate of this bug. ***
Comment 228 Jakub Moc (RETIRED) gentoo-dev 2006-11-13 05:04:36 UTC
*** Bug 154990 has been marked as a duplicate of this bug. ***
Comment 229 Jakub Moc (RETIRED) gentoo-dev 2006-11-14 11:58:29 UTC
*** Bug 155110 has been marked as a duplicate of this bug. ***
Comment 230 Jakub Moc (RETIRED) gentoo-dev 2006-11-17 06:10:59 UTC
*** Bug 155423 has been marked as a duplicate of this bug. ***
Comment 231 Jakub Moc (RETIRED) gentoo-dev 2006-11-18 13:21:25 UTC
*** Bug 155611 has been marked as a duplicate of this bug. ***
Comment 232 Jakub Moc (RETIRED) gentoo-dev 2006-11-19 07:24:00 UTC
*** Bug 155678 has been marked as a duplicate of this bug. ***
Comment 233 Jakub Moc (RETIRED) gentoo-dev 2006-11-21 00:05:23 UTC
*** Bug 155817 has been marked as a duplicate of this bug. ***
Comment 234 Jakub Moc (RETIRED) gentoo-dev 2006-11-23 02:24:02 UTC
*** Bug 155968 has been marked as a duplicate of this bug. ***
Comment 235 Jakub Moc (RETIRED) gentoo-dev 2006-11-27 13:40:40 UTC
*** Bug 156441 has been marked as a duplicate of this bug. ***
Comment 236 Jakub Moc (RETIRED) gentoo-dev 2006-12-02 11:22:40 UTC
*** Bug 156333 has been marked as a duplicate of this bug. ***
Comment 237 David M. Sanderson 2006-12-07 05:22:26 UTC
*** Bug 157363 has been marked as a duplicate of this bug. ***
Comment 238 Jakub Moc (RETIRED) gentoo-dev 2006-12-16 03:49:51 UTC
*** Bug 158272 has been marked as a duplicate of this bug. ***
Comment 239 Jakub Moc (RETIRED) gentoo-dev 2006-12-20 07:45:26 UTC
*** Bug 158644 has been marked as a duplicate of this bug. ***
Comment 240 Jakub Moc (RETIRED) gentoo-dev 2006-12-22 00:03:48 UTC
*** Bug 158805 has been marked as a duplicate of this bug. ***
Comment 241 no_return_address 2007-01-02 07:19:55 UTC
*** Bug 159709 has been marked as a duplicate of this bug. ***
Comment 242 no_return_address 2007-01-02 16:02:42 UTC
*** Bug 159709 has been marked as a duplicate of this bug. ***
Comment 243 Jakub Moc (RETIRED) gentoo-dev 2007-01-29 21:11:17 UTC
*** Bug 164464 has been marked as a duplicate of this bug. ***
Comment 244 no_return_address 2007-01-30 23:04:04 UTC
I've managed to work around this by replacing my compilers with scripts that call the real compilers and then call them a second time in the event of a failure.  I also added a "sleep $DELAY" as well so that I can emerge things with "DELAY=3 emerge whatever" to give the CPU a few seconds to rest between each execution of GCC.  I also tried simply a 90 second delay before the second attempt at compiling, but that proved problematic as it seems configure scripts attempt to compile a lot of stuff that is expected to fail. 
Comment 245 Jakub Moc (RETIRED) gentoo-dev 2007-02-05 21:57:55 UTC
*** Bug 165503 has been marked as a duplicate of this bug. ***
Comment 246 Jakub Moc (RETIRED) gentoo-dev 2007-02-18 13:49:20 UTC
*** Bug 167474 has been marked as a duplicate of this bug. ***
Comment 247 SpanKY gentoo-dev 2007-02-27 14:37:07 UTC
*** Bug 168350 has been marked as a duplicate of this bug. ***
Comment 248 Jakub Moc (RETIRED) gentoo-dev 2007-03-11 22:04:01 UTC
*** Bug 170444 has been marked as a duplicate of this bug. ***
Comment 249 Jakub Moc (RETIRED) gentoo-dev 2007-03-15 19:02:45 UTC
*** Bug 171059 has been marked as a duplicate of this bug. ***
Comment 250 Jakub Moc (RETIRED) gentoo-dev 2007-04-04 07:14:38 UTC
*** Bug 173154 has been marked as a duplicate of this bug. ***
Comment 251 Jakub Moc (RETIRED) gentoo-dev 2007-05-01 21:44:53 UTC
*** Bug 176430 has been marked as a duplicate of this bug. ***
Comment 252 Jakub Moc (RETIRED) gentoo-dev 2007-05-18 14:45:52 UTC
*** Bug 179010 has been marked as a duplicate of this bug. ***
Comment 253 Jakub Moc (RETIRED) gentoo-dev 2007-07-14 21:18:48 UTC
*** Bug 185352 has been marked as a duplicate of this bug. ***
Comment 254 Jakub Moc (RETIRED) gentoo-dev 2007-07-17 05:59:09 UTC
*** Bug 185626 has been marked as a duplicate of this bug. ***
Comment 255 Jakub Moc (RETIRED) gentoo-dev 2007-07-22 18:12:40 UTC
*** Bug 186250 has been marked as a duplicate of this bug. ***
Comment 256 Jakub Moc (RETIRED) gentoo-dev 2007-08-21 17:41:22 UTC
*** Bug 189736 has been marked as a duplicate of this bug. ***
Comment 257 Jakub Moc (RETIRED) gentoo-dev 2007-08-25 15:10:51 UTC
*** Bug 190169 has been marked as a duplicate of this bug. ***
Comment 258 Dominique Michel 2007-08-28 18:21:32 UTC
My 2 cents contrib about the power supply issue. As Paul said above, 230V is inside the tolerance of a 220V power supply (typically +10 -15%, the same tolerance as the power line). 

Things can go wrong if the power get to 230V + 15%. It will be outside the tolerance of the power supply. But I have never seen this to append. Most (all?) of the time, the power line will be somewhere between 230V and 230V -15%.

Another issue is money. It cost money to make a power supply, and for the same amount of manufactured power supplies, it will be cheaper to make one model for 220-230V (or 220-240V), as one model for 220V and another one for 230V.

And most power supply are very cheap today. That bring the last problem: quality. A cheap power supply (or whatever cheap electronic) will always be made with cheap components. The number one problem in the power supply is the electrolytic capacitors. They are aging very fast, and cheaper they are, faster their characteristics are decreasing. I will not go into technical details, but a computer power supply is all about charging and decharging very fast such capacitors. They are doing the hardest work in the supply.  

Siemens, one of the best electrolytic manufacturer, is manufacturing many different qualities of those components. At different prices of course. For their best quality, they state at such a component must be changed in any case after ten years of work if we want to be sure of its characteristic. No testing, just to change it! We can not expect at we will get the same lifetime from the same component coming from one at least 20 time less expensive brand.

(Don't buy old electrolytic capacitors, they are becoming dry when they do nothing. And the dry electrolytic will not like at all when you will plug the power in. Siemens state about half lifetime after one year of non activity for its best quality.)
Comment 259 Jakub Moc (RETIRED) gentoo-dev 2007-09-09 21:04:48 UTC
*** Bug 190462 has been marked as a duplicate of this bug. ***
Comment 260 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 20:45:40 UTC
*** Bug 192461 has been marked as a duplicate of this bug. ***
Comment 261 Jakub Moc (RETIRED) gentoo-dev 2007-09-26 07:07:24 UTC
*** Bug 193813 has been marked as a duplicate of this bug. ***
Comment 262 Jakub Moc (RETIRED) gentoo-dev 2007-10-07 15:03:19 UTC
*** Bug 194998 has been marked as a duplicate of this bug. ***
Comment 263 Jakub Moc (RETIRED) gentoo-dev 2007-10-18 21:53:38 UTC
*** Bug 196287 has been marked as a duplicate of this bug. ***
Comment 264 SpanKY gentoo-dev 2007-11-11 20:08:13 UTC
*** Bug 198819 has been marked as a duplicate of this bug. ***
Comment 265 SpanKY gentoo-dev 2007-11-18 17:29:13 UTC
*** Bug 198521 has been marked as a duplicate of this bug. ***
Comment 266 Jakub Moc (RETIRED) gentoo-dev 2007-11-20 07:33:03 UTC
*** Bug 199728 has been marked as a duplicate of this bug. ***
Comment 267 Jakub Moc (RETIRED) gentoo-dev 2007-11-26 21:01:53 UTC
*** Bug 200416 has been marked as a duplicate of this bug. ***
Comment 268 Mark Loeser (RETIRED) gentoo-dev 2007-12-09 02:34:48 UTC
*** Bug 201729 has been marked as a duplicate of this bug. ***
Comment 269 Jakub Moc (RETIRED) gentoo-dev 2007-12-14 12:03:24 UTC
*** Bug 201954 has been marked as a duplicate of this bug. ***
Comment 270 Jakub Moc (RETIRED) gentoo-dev 2008-01-09 13:22:48 UTC
*** Bug 204894 has been marked as a duplicate of this bug. ***
Comment 271 Jakub Moc (RETIRED) gentoo-dev 2008-01-16 22:15:33 UTC
*** Bug 206080 has been marked as a duplicate of this bug. ***
Comment 272 Jakub Moc (RETIRED) gentoo-dev 2008-01-29 21:18:24 UTC
*** Bug 208083 has been marked as a duplicate of this bug. ***
Comment 273 Jakub Moc (RETIRED) gentoo-dev 2008-02-06 13:18:59 UTC
*** Bug 209131 has been marked as a duplicate of this bug. ***
Comment 274 Jakub Moc (RETIRED) gentoo-dev 2008-03-09 19:38:39 UTC
*** Bug 212839 has been marked as a duplicate of this bug. ***
Comment 275 Jakub Moc (RETIRED) gentoo-dev 2008-03-13 06:52:53 UTC
*** Bug 213230 has been marked as a duplicate of this bug. ***
Comment 276 Mark Loeser (RETIRED) gentoo-dev 2008-04-12 13:12:49 UTC
*** Bug 217320 has been marked as a duplicate of this bug. ***
Comment 277 Dmytro Korduban 2008-04-19 15:47:20 UTC
I've upgraded my RAM from 64M to 192M and increased swap space from 128M to 1G, now everything works fine. Thanks Jakub!
Comment 278 SpanKY gentoo-dev 2008-04-24 03:53:37 UTC
*** Bug 218910 has been marked as a duplicate of this bug. ***
Comment 279 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-30 21:17:07 UTC
*** Bug 219878 has been marked as a duplicate of this bug. ***
Comment 280 Mark Loeser (RETIRED) gentoo-dev 2008-05-16 13:57:36 UTC
*** Bug 216922 has been marked as a duplicate of this bug. ***
Comment 281 Michael Croes 2008-06-06 17:57:37 UTC
Today I started undervolting my pentium m cpu. When I tried to compile firefox gcc segfaulted, tried again, gcc segfaulted again. Now I raised all my voltages (the lower ones) with about 32 mV and firefox is compiling again.

Summary: an undervolted cpu can seem to run fine but you're never sure until you run into problems.
Comment 282 Ulrich Müller gentoo-dev 2008-06-30 12:42:07 UTC
*** Bug 229939 has been marked as a duplicate of this bug. ***
Comment 283 SpanKY gentoo-dev 2008-08-20 02:16:58 UTC
*** Bug 232952 has been marked as a duplicate of this bug. ***
Comment 284 SpanKY gentoo-dev 2008-08-20 02:26:04 UTC
*** Bug 231218 has been marked as a duplicate of this bug. ***
Comment 285 SpanKY gentoo-dev 2008-09-17 09:16:57 UTC
*** Bug 237325 has been marked as a duplicate of this bug. ***
Comment 286 Scott 2008-12-24 11:32:31 UTC
Was having segfault issue on my fileserver today. Turned out my CMOS had gotten cleared yesterday, fixed the issue by setting my memory timings to the most aggressive my motherboard would support. Go figure
Comment 287 Daniel Solano Gómez 2009-02-20 02:29:55 UTC
*** Bug 259662 has been marked as a duplicate of this bug. ***
Comment 288 Mark Loeser (RETIRED) gentoo-dev 2009-04-20 21:59:03 UTC
*** Bug 199033 has been marked as a duplicate of this bug. ***
Comment 289 Tomas Thiemel 2009-04-23 12:26:05 UTC
(In reply to comment #29)
>  It can be fault of dirty hardware. It can be I think also a problem of raised
> voltage from power station. Normally in Poland there was 220 V and now it is
> 230. The power supply in computer (in Poland of course) is designed to take
> 220V. 
It is due to unifying voltage/frequency in whole EU, don't blame politicans.

> Good resolve should be a voltage converter.
You should use devices which comply some standarts and not devices build "on knees". I live in CZ near borders with PL and I had bad experiences with (cheap) broadband TV antennas from Poland.



Comment 290 Dominique Michel 2009-04-25 14:01:36 UTC
£Another issue with the power line is the phase between the voltage and the current (called power factor or charge factor). Normally, the dephasing must be equal to 0, but in practice, you will get almost always a little dephasing. If you are living at the country or in a place where the line have a very long distance, or you are using a lot of cheap extension cords, you can get a dephasing that will be outside the tolerance.

If it is the case, no one single manufacturer will give you a guaranty that its devices will or can work fine.

For a general discussion one this issue on power lines, see  http://en.wikipedia.org/wiki/Power_factor
Comment 291 Mark Loeser (RETIRED) gentoo-dev 2009-05-02 02:23:19 UTC
*** Bug 263624 has been marked as a duplicate of this bug. ***
Comment 292 SpanKY gentoo-dev 2010-06-13 02:47:53 UTC
*** Bug 322565 has been marked as a duplicate of this bug. ***
Comment 293 SpanKY gentoo-dev 2010-08-09 22:03:20 UTC
*** Bug 331909 has been marked as a duplicate of this bug. ***
Comment 294 SpanKY gentoo-dev 2010-10-03 20:57:40 UTC
*** Bug 332621 has been marked as a duplicate of this bug. ***
Comment 295 SpanKY gentoo-dev 2011-03-01 21:09:37 UTC
*** Bug 356869 has been marked as a duplicate of this bug. ***
Comment 296 Jeroen Roovers gentoo-dev 2011-08-03 15:00:15 UTC
*** Bug 377449 has been marked as a duplicate of this bug. ***
Comment 297 SpanKY gentoo-dev 2011-09-11 19:26:41 UTC
*** Bug 382399 has been marked as a duplicate of this bug. ***
Comment 298 SpanKY gentoo-dev 2011-10-02 18:30:35 UTC
*** Bug 385335 has been marked as a duplicate of this bug. ***
Comment 299 SpanKY gentoo-dev 2011-10-09 16:23:26 UTC
*** Bug 386347 has been marked as a duplicate of this bug. ***
Comment 300 SpanKY gentoo-dev 2011-11-11 01:37:51 UTC
*** Bug 390121 has been marked as a duplicate of this bug. ***
Comment 301 SpanKY gentoo-dev 2012-01-02 07:02:24 UTC
*** Bug 397327 has been marked as a duplicate of this bug. ***
Comment 302 SpanKY gentoo-dev 2012-03-24 06:28:17 UTC
*** Bug 409279 has been marked as a duplicate of this bug. ***
Comment 303 SpanKY gentoo-dev 2012-05-31 00:39:13 UTC
*** Bug 399143 has been marked as a duplicate of this bug. ***
Comment 304 SpanKY gentoo-dev 2012-07-18 12:09:09 UTC
*** Bug 424345 has been marked as a duplicate of this bug. ***
Comment 305 SpanKY gentoo-dev 2012-08-10 00:43:49 UTC
*** Bug 430644 has been marked as a duplicate of this bug. ***
Comment 306 SpanKY gentoo-dev 2012-08-14 16:29:23 UTC
*** Bug 381061 has been marked as a duplicate of this bug. ***
Comment 307 SpanKY gentoo-dev 2012-08-17 04:21:42 UTC
*** Bug 431582 has been marked as a duplicate of this bug. ***
Comment 308 Sergey Popov gentoo-dev Security 2012-10-10 12:32:04 UTC
*** Bug 437818 has been marked as a duplicate of this bug. ***
Comment 309 Jeroen Roovers gentoo-dev 2013-01-15 12:02:21 UTC
*** Bug 451612 has been marked as a duplicate of this bug. ***
Comment 310 SpanKY gentoo-dev 2016-04-17 16:25:24 UTC
*** Bug 578926 has been marked as a duplicate of this bug. ***
Comment 311 SpanKY gentoo-dev 2016-06-01 03:00:33 UTC
*** Bug 584606 has been marked as a duplicate of this bug. ***
Comment 312 SpanKY gentoo-dev 2016-06-21 15:10:47 UTC
*** Bug 586032 has been marked as a duplicate of this bug. ***
Comment 313 Ulrich Müller gentoo-dev 2016-09-06 09:06:35 UTC
*** Bug 592868 has been marked as a duplicate of this bug. ***
Comment 314 SpanKY gentoo-dev 2017-02-17 19:04:55 UTC
*** Bug 603494 has been marked as a duplicate of this bug. ***
Comment 315 Dominique Michel 2017-07-15 18:10:20 UTC
A question. Now the rt-sources is in portage. Does that mean it will not trigger compilation failures? Or is it still necessary/better to use the a vanilla or gentoo-sources kernel with emerge?