Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80655 - ICE: gcc-3.4.3: xorg-x11-
Summary: ICE: gcc-3.4.3: xorg-x11-
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Blocks: 81597
  Show dependency tree
Reported: 2005-02-03 16:58 UTC by Michael Hill
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Contents of /var/tmp/portage/xorg-x11- (xorg-x11-,153.68 KB, text/plain)
2005-02-03 19:42 UTC, Michael Hill

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hill 2005-02-03 16:58:37 UTC
emerge of xorg-x11, upgrading to from fails during compile:

gcc -c -ansi -pedantic -Wno-return-type -w    -I../.. -I../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                            -D_POSIX_SOURCE -D_XOPEN_SOURCE                                 -D_BSD_SOURCE -D_SVID_SOURCE                             -D_GNU_SOURCE                            -DFUNCPROTO=15 -DNARROWPROTO -DXTHREADS  -D_REENTRANT -DXUSE_MTSAFE_API    -DMALLOC_0_RETURNS_NULL  -DHAS_SNPRINTF -DLIBX11                   -DPOSTLOCALELIBDIR=\"lib\"      -O3 -march=athlon-xp -pipe -mno-sse2 -mno-sse3 -fno-strict-aliasing   cmsMath.c -o unshared/cmsMath.o
cmsMath.c: In function `_XcmsCubeRoot':
cmsMath.c:91: internal compiler error: in try_split, at emit-rtl.c:3343
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
Preprocessed source stored into /var/tmp/portage/xorg-x11- file, please attach this to your bugreport.
make[4]: *** [cmsMath.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11- failed.
!!! Function build, Line 938, Exitcode 2
!!! make World failed
!!! If you need support, post the topmost build error, NOT this status message.

[mhill@shadowfax:~] 17:57:26 $ emerge info
Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.4.3, glibc-, 2.6.10-gentoo-r6 i686)
System uname: 2.6.10-gentoo-r6 i686 AMD Athlon(tm) XP 1800+
Gentoo Base System version 1.6.9
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Jan 29 2005, 09:47:17)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.9.4, 1.5, 1.4_p6, 1.6.3, 1.7.9, 1.8.5-r3
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.4.19-r1, 2.4.22
CFLAGS="-O3 -march=athlon-xp -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -funroll-loops -pipe"
FEATURES="autoaddcvs autoconfig buildpkg ccache digest distlocks sandbox sfperms"
USE="x86 3dnow X Xaw3d acpi alsa apache2 apm audiofile avi bcmath berkdb bitmap-fonts bonobo bzlib calendar caps cdb cdr crypt cscope ctype cups curl dba dbase dbx dedicated dga doc dvd dvdr encode esd exif f77 fbcon fftw flac flatfile font-server foomaticdb freetds ftp gd gif ginac gmp gnome gnutls gpm gtk gtk2 hardened hardenedphp imagemagick imlib inifile jack jpeg kde libwww mad mbox memlimit mhash mikmod milter mime mmap mmx mng motif mozilla mpeg mpi mysql ncurses nocardbus nocd odbc oggvorbis opengl oss pam pcntl pcre pda pdflib perl php pic pie plotutils png posix ppds python qt quicktime readline samba sdl shared sharedmem simplexml sndfile sockets speex spell spl sse ssl svg sysvipc tcltk tcpd tidy tiff tokenizer truetype truetype-fonts type1-fonts usb vhosts videos wmf xine xml xml2 xmlrpc xmms xpm xsl xv xvid zlib"
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-03 17:55:17 UTC
Can you reproduce this in the exact same place?
Comment 2 Michael Hill 2005-02-03 19:42:21 UTC
Created attachment 50296 [details]
Contents of /var/tmp/portage/xorg-x11-
Comment 3 Michael Hill 2005-02-03 19:42:59 UTC
Yes, I've run it three times and it fails each time in the same function, on the same line.  I compared the output file from the last two runs and it is identical.  I attached the file just now.
Comment 4 Michael Hill 2005-02-05 10:37:07 UTC
Dang...  saw a new patch tarball this morning, dated late last night, got excited...  emerge failed again, same spot.  :^/
Comment 5 aethyr 2005-02-14 14:23:27 UTC
I don't know if it will help, but someone on the forums got the exact same error message while emerging fontconfig:
Comment 6 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-14 15:35:05 UTC
I'm going to assign this to our toolchain people, because it's hitting the same ICE on a different package in that forums thread. They can feel free to dup it of bug #20600.
Comment 7 Jeremy Huddleston (RETIRED) gentoo-dev 2005-02-14 18:20:48 UTC
-O3 -funroll-loops??!!

Yick.  Please try 6.8.2 with CFLAGS="-O2 -march=i686 -pipe" then work your way up on the optimization scale if that worked.

Also, please try gcc-
Comment 8 Michael Hill 2005-02-14 18:28:36 UTC
I am currently trying with CFLAGS="-O2 -mcpu=athlon-xp".  It's griping at every turn about -mcpu being deprecated, but I just want to see if it'll get it built.
Comment 10 Michael Hill 2005-02-14 20:14:28 UTC
Okay, it made it to the make install stage that time, so it apparently was the optimization settings.  A couple questions:

1)  What would you gurus recommend as an all-round good-performance, yet safe, set of optimization settings for compiling everything on a system?  I plan to use -march=athlon-xp, but beyond that?

2)  In xorg-x11 specifically, how can I keep it from consuming lots of disk space building and installing fonts I don't want?  It built ISO8859-{1,2,3,4,9,10,13,14,15}.  All I really want is the US/English characters.

Thanks for your help.
Comment 11 Jeremy Huddleston (RETIRED) gentoo-dev 2005-02-14 23:48:42 UTC
Personally, I use:
-O2 -pipe -fomit-frame-pointer -march=athlon-xp

Beyond that, you start getting into weird issues.  -O3 is not very safe.  -Os isn't very safe either.  -funroll-loops is usually safe, but it can cause problems, and you're wasting memory, so it's not worth it to me.

*** This bug has been marked as a duplicate of 20600 ***
Comment 12 Michael Hill 2005-02-16 13:53:51 UTC
Okay, this is weird.

This works:
  # CFLAGS="-O2 -mcpu=athlon-xp" emerge -u xorg-x11

This fails:
  # CFLAGS="-O2 -march=athlon-xp" emerge -u xorg-x11

As you can see, the only difference is -mcpu vs. -march, which I don't *think* should qualify as "overly aggressive optimizations".  :^)  Especially as gcc itself prints a message about -mcpu being deprecated every time it's called in the first command above.

I'm guessing this is a gcc bug and out of the control of the Gentoo/portage teams, yes?  If so, who should file a bug report?

I might try emerging gcc-3.3.x and see if it works with -march , because this is the first time I've come across this problem.
Comment 13 Jeremy Huddleston (RETIRED) gentoo-dev 2005-02-16 19:43:03 UTC
-march=athlon-xp sets things like mmx, sse, sse2, and 3dnow.  mcpu just sets alignment.