Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190462 - gcc-4.1.2 segfault when compiling oofice
Summary: gcc-4.1.2 segfault when compiling oofice
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-08-27 20:49 UTC by Dominique Michel
Modified: 2007-09-09 21:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

result of the compilation (result,9.17 KB, text/plain)
2007-08-27 20:51 UTC, Dominique Michel
my emerge --info (emerge-info,9.50 KB, text/plain)
2007-08-27 21:24 UTC, Dominique Michel

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Michel 2007-08-27 20:49:29 UTC
During a revdep-rebuild, gcc-4.1.2 crashed with a segfault:

/mnt/data/var/tmp/portage/app-office/openoffice-2.2.1/work/ooo/build/OOF680_m18/sw/source/ui/shells/textsh1.cxx:1255: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
dmake:  Error code 1, while making '../../../'
'---* *---'

ERROR: Error 65280 occurred while making /mnt/data/var/tmp/portage/app-office/openoffice-2.2.1/work/ooo/build/OOF680_m18/sw/source/ui/shells
make: *** [stamp/build] Error 1

!!! ERROR: app-office/openoffice-2.2.1 failed.

Reproducible: Always

Steps to Reproduce:
1. emerge openoffice

Actual Results:  
See attachments

Expected Results:  
At openoffice did compile fine.

I try to run the failed g++ command above and it worked, so I will remove revdep-rebuild temporary files and try again.

The problem for me is that the error message said at it can be a hardware or system problem. How can I know if it is hardware related or not? I post this report here because the message tell me to do that, but my first reflex was to post it in the forum.
Comment 1 Dominique Michel 2007-08-27 20:51:37 UTC
Created attachment 129369 [details]
result of the compilation
Comment 2 Dominique Michel 2007-08-27 21:24:00 UTC
Created attachment 129376 [details]
my emerge --info
Comment 3 Dominique Michel 2007-08-27 22:00:19 UTC
The link on the full log (54MB)
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-08-28 06:05:23 UTC
Can you reproduce it at *exactly* the same place? If not, see Bug 20600.
Comment 5 Dominique Michel 2007-09-09 21:02:59 UTC
No, emerge did it fine. From bug 20600, I can see that the most probable cause of this failure the first time I run emerge is my rt-kernel. I must plan to run emerge in a chroot or on another machine.

I guess that you can marl this bug as closed.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-09-09 21:04:31 UTC
Lets dupe it then.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-09-09 21:04:48 UTC
Thanks for reporting back.

*** This bug has been marked as a duplicate of bug 20600 ***