Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 229939 - x11-libs/openmotif-2.3.1 compile failure
Summary: x11-libs/openmotif-2.3.1 compile failure
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Ulrich Müller
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-28 20:09 UTC by Alexey Shvetsov
Modified: 2008-06-30 12:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,329.92 KB, text/plain)
2008-06-28 20:10 UTC, Alexey Shvetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Shvetsov gentoo-dev 2008-06-28 20:09:14 UTC
Portage 2.2_rc1 (default/linux/x86/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-rc8-zen1.0 i686)
=================================================================
System uname: Linux-2.6.26-rc8-zen1.0-i686-Pentium_III_-Coppermine-with-glibc2.0
Timestamp of tree: Sat, 28 Jun 2008 18:30:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=native -mtune=native -mno-tls-direct-seg-refs -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -march=native -mtune=native -mno-tls-direct-seg-refs -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy ccache distlocks parallel-fetch prelink preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp.linux.ee/pub/gentoo/distfiles/"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--sort-common"
LINGUAS="ru en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/rusxmms /usr/local/portage/layman/sunrise /usr/local/portage/layman/science /usr/local/portage/layman/zen-overlay /usr/local/portage/layman/kdesvn-portage /usr/local/portage-arm /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="16bit 3ds 7zip X Xaw3d a52 aac acl acpi addbookmarks additions administrator aiglx aim aimextras aio akode alias alsa amarok amd amr amrnb amrwb ansi ao aotuv apache2 asf asterisk async atk atlas auctex audiofile audit autoipd automount autoreplace avalon bash-completion bdf berkdb bidi big-tables bigpatch bind-mysql bl blender-game bonobo branding browserplugin bugzilla buttons bzip2 c++ c3p0 cacheemu cairo calendar caps catalogs ccache cdda cddb cdf cdinstall cdio cdparanoia cdr cdrom cegui cflags cgi chm chroot clamav clamd cle266 clearcase cli cluster color-console concurrentmodphp contactnotes context cp1251 cpdflib cracklib crypt cscope css cups curl curlwrappers cvs cvsgraph cxx cyrillic d daap dbase dbus dbx device-mapper dga dhcp dia dict dio divx4linux djbfft djvu dmi dnd doc double-precision dri dts dv dvb dvd dvdnav dvdr dvdread dvi dx dxr3 dynagraph dynamic eap-tls ecc edb editor edl emacs-w3 emboss emerald emf emovix enca encode epiphany erandom esd exif expat exscalibar extra extraengine extrafilters extras f90 faad fam fame fastcgi fbcon fbcondecor fbdev fbsplash ffmpeg fftw flac flash fltk font-server fontconfig foomaticdb fortran fortran95 fpx freetds freetype freewnn ft ftp fuse galago games gamess gb gd gdbm gecko-sdk geometry ggi gif gimp gimpprint ginac git gkrellm glep glgd glib glibc-omitfp glitz glut glx gmail gmailtimestamps gml gmp gnuplot gnustep gnutls gpg gpg2-experimental gphoto2 gpm graphics graphviz gs gsl gsm gstreamer gstreamer010 gtalk gtk gtk2 gtkhtml gzip hal haskell hddtemp hdri hipe history howl html http httpd humanities icon iconv id3 idea idn ieee1394 imagemagick imap imlib innodb inotify ipv6 irda isdnlog ithreads jack-tmpfs jadetex java jbig jikes jingle jmx jpeg jpeg2k js justify kde kdehiddenvisibility kdepim kexi kpoll ladspa lame latex lcd lcms leim lesstif libclamav libffi libnotify libsamplerate libvisual linuxthreads-tls live lm_sensors logrotate logwatch lyx lzo mad mailwrapper maps math max-idx-128 mbox mbrola md5sum mhash midi mikmod milter mime ming mixer mjpeg mktemp mmap mmx mmxext mng mod_muc mod_pubsub modplug mopac7 motif mozcalendar mozdevelop mozilla mozsvg mp2 mp3 mp3rtp mp4 mp4live mpe mpeg mpeg2 mpeg4 mpi mpi_njtree mplayer mpm-worker mpqc msdfs msession mtp mudflap mule musepack music mysql mysqli mythtv nagios-dns nagios-game nagios-ntp nagios-ping nagios-ssh nas nautilus ncurses neXt netboot netjack network-cron newspr nextaw nfs nls no-old-linux nocd nowlistening nptl nptlonly nsplugin numeric nxclient oav objc objc++ odbc odk offensive ogg oggvorbis omega onaccess openal openbabel openexr opengl openmp osc overlays pam pam_chroot pam_timestamp pango parse-clocks pascal passwdqc paste64 pbxt pch pcre pda pdf pdfkit perforce perl pertty php physfs pic plasma plotting plotutils plugins png pnm portaudio posix postscript povray ppds pppd prelude preview-latex profile pstricks publishers pulseaudio pwdb pygrub python q32 q8 qq qt-copy qt3 qt3support qt4 quicktime radio rar rdesktop readline reflection reiserfs resolvconf rle romio rpc rplay rrdcgi rss rtc ruby samba sasl sbcl scanner science screen script sdk sdl sendfile sendmail sensord server session slang slp smime smp sms sname sndfile sni softmmu solver sound soundex sounds sox speedo speex spell spl spoof-source sql sqlite sqlite3 srp srt srvdir sse sse-filters ssl startup-notification statistics stroke subversion svg swat swig symlink sysfs syslog sysvipc szip t1lib taglib tcl tcltk tcpd tetex tex4ht tga theora threads threadsonly tidy tiff timidity tivo tk toolbar tools transcode truetype ucs2 uim uml unicode ups urandom usb userlocales utempter utf8 v4l v4l2 vboxbfe vcd vcdimager videos vidix vim vim-pager vim-syntax visualization voice vorbis vorbis-psy vst wavpack web webinterface wideband wifi win32codecs winbind wma wma123 wmf wxgtk1 wxwindows x264 x86 x86emu xanim xattr xcb xchatdccserver xchattext xcomposite xetex xface xine xml xml2 xmldoclet xmlreader xmlrpc xmlwriter xmp xorg xosd xpm xrandr xscreensaver xulrunner xv xvid yv12 zip zlib" ALSA_CARDS="cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="event" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="radeon fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexey Shvetsov gentoo-dev 2008-06-28 20:10:17 UTC
Created attachment 158797 [details]
build.log

build log
Comment 2 Ulrich Müller gentoo-dev 2008-06-29 13:28:01 UTC
Is this reproducible?
Comment 3 Alexey Shvetsov gentoo-dev 2008-06-29 13:36:16 UTC
(In reply to comment #2)
> Is this reproducible?
> 
It happens every time =( on this x86 machine
but on x86_64 it compiles fine

Comment 4 Ulrich Müller gentoo-dev 2008-06-30 06:28:21 UTC
I am sorry, but I cannot reproduce the bug here (up-to-date ~x86 system).

Does it also happen with "ccache" and "prelink" turned off?
Comment 5 Alexey Shvetsov gentoo-dev 2008-06-30 09:17:23 UTC
(In reply to comment #4)
> I am sorry, but I cannot reproduce the bug here (up-to-date ~x86 system).
> 
> Does it also happen with "ccache" and "prelink" turned off?
> 

Looks like preoblem was ccache
now it builds fine
Thanks
Comment 6 Ulrich Müller gentoo-dev 2008-06-30 12:42:07 UTC

*** This bug has been marked as a duplicate of bug 20600 ***