Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 206080 - sys-devel/gcc-4.2.2 failed. (segmentation fault in gcc.c)
Summary: sys-devel/gcc-4.2.2 failed. (segmentation fault in gcc.c)
Status: VERIFIED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2008-01-16 13:34 UTC by Antonio Pezo
Modified: 2008-01-16 22:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Pezo 2008-01-16 13:34:16 UTC
gentoo ~ # emerge -va --newuse --update --deep world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild  NS   ] sys-devel/gcc-4.2.2  USE="doc fortran gtk mudflap nls openmp (-altivec) -bootstrap -build -gcj (-hardened) -ip28 -ip32r10k (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 0 kB 

Reproducible: Always

Steps to Reproduce:
1.emerge gcc-4.2.2

Actual Results:  
        SHLIB_MULTILIB=''; \
        /var/tmp/portage/sys-devel/gcc-4.2.2/work/build/./prev-gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.2.2/work/build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/   -O2 -pipe -fprofile-generate -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wmissing-format-attribute    -DHAVE_CONFIG_H -I. -I. -I/var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc -I/var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc/. -I/var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc/../include -I/var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc/../libcpp/include  -I/var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc/../libdecnumber -I../libdecnumber    \
  -DSTANDARD_STARTFILE_PREFIX=\"../../../\" -DSTANDARD_EXEC_PREFIX=\"/usr/lib/gcc/\" -DSTANDARD_LIBEXEC_PREFIX=\"/usr/libexec/gcc/\" -DDEFAULT_TARGET_VERSION=\"4.2.2\" -DDEFAULT_TARGET_MACHINE=\"x86_64-pc-linux-gnu\" -DSTANDARD_BINDIR_PREFIX=\"/usr/x86_64-pc-linux-gnu/gcc-bin/4.2.2/\" -DTOOLDIR_BASE_PREFIX=\"../../../../\"  `test "X${SHLIB_LINK}" = "X" || test "yes" != "yes" || echo "-DENABLE_SHARED_LIBGCC"` `test "X${SHLIB_MULTILIB}" = "X" || echo "-DNO_SHARED_LIBGCC_MULTILIB"` \
  -c /var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc/gcc.c -o gcc.o)
 STMT MODIFIED. - <0x2b42a93fe000> delete_this_arg_9489 = PHI <delete_this_arg_5575(76), delete_this_arg_4277(21), delete_this_arg_363(26), delete_this_arg_4282(41), delete_this_arg_534(54), delete_this_arg_5281(66), delete_this_arg_4324(369), delete_this_arg_5198(63), delete_this_arg_9308(365), delete_this_arg_4323(364), delete_this_arg_9095(334), delete_this_arg_14(331), delete_this_arg_8970(317), delete_this_arg_4321(310), delete_this_arg_8886(306), delete_this_arg_8517(276), delete_this_arg_8476(273), delete_this_arg_8351(268), delete_this_arg_8269(261), delete_this_arg_8228(258), delete_this_arg_8187(255), delete_this_arg_8146(252), delete_this_arg_8105(249), delete_this_arg_8064(243), delete_this_arg_8023(240), delete_this_arg_7982(237), delete_this_arg_7941(234), delete_this_arg_7900(232), delete_this_arg_7818(228), delete_this_arg_7736(224), delete_this_arg_7654(220), delete_this_arg_7531(210), delete_this_arg_14(190), delete_this_arg_14(189), delete_this_arg_14(188), delete_this_arg_7317(187), delete_this_arg_4309(184), delete_this_arg_7194(178), delete_this_arg_6614(165), delete_this_arg_1171(152), delete_this_arg_1052(126), delete_this_arg_14(100), delete_this_arg_783(93), delete_this_arg_762(84), delete_this_arg_5575(77), delete_this_arg_5327(68), delete_this_arg_607(67), delete_this_arg_4323(363), delete_this_arg_9054(333), delete_this_arg_14(264), delete_this_arg_8434(271), delete_this_arg_4314(209), delete_this_arg_4302(162), delete_this_arg_14(99), delete_this_arg_14(101), delete_this_arg_783/var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc/gcc.c: In function ‘do_spec_1’:
/var/tmp/portage/sys-devel/gcc-4.2.2/work/gcc-4.2.2/gcc/gcc.c:4606: internal compiler error: Segmentation fault

gentoo ~ # emerge --info
Portage 2.1.4 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 x86_64)
System uname: 2.6.23-gentoo-r3 x86_64 Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz
Timestamp of tree: Wed, 16 Jan 2008 12:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en hr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="7zip X a52 acl acpi alsa amd64 arts artswrappersuid bash-completion bashlogger berkdb bitmap-fonts bzip2 cairo caps cddb cdr cdrom cli cracklib crypt cups dbus dia doc dri dv dvb dvd dvdr dvdread eds emboss encode esd evo examples expat fam ffmpeg firefox fontconfig fortran ftp gd gdbm gif gimpprint glib gnome gphoto2 gpm gstreamer gtk gtktml hal iconv imagemagick inkjar isdnlog java jpeg jpeg2k kde kerberos ldap lzo mad md5sum midi mikmod mmx mmxext mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl php pic plotutils png postscript ppds pppd python qt3 qt3support qt4 quicktime rar rdesktop readline reflection scanner sdl session slang spell spl srt sse sse2 ssl ssse3 svg tcpd tga threads tiff tk truetype truetype-fonts type1-fonts unicode usb v4l vorbis wmf x264 xanim xinerama xml xorg xpm xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en hr" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Comment 1 Tais P. Hansen 2008-01-16 13:43:25 UTC
Try adding -march=athlon64 or similar to your CFLAGS in make.conf. Solved the issues I had compiling gcc-4.2.2 on amd64.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2008-01-16 14:33:17 UTC
Can you reproduce this repeatedly at *exactly* the same place? If yes, then attach the preprocessed course here as the message told you. Otherwise, I'd suggest checking your HW stability.
Comment 3 Antonio Pezo 2008-01-16 22:12:34 UTC
Jakub, you are right, the error cannot be reproduced at exactly the same place, so it must be HW or OS problem.
I removed "~amd64" from ACCEPT_KEYWORDS, after that my system downgraded a bit, and all was emerged correctly.
Also, after "downgrade" completed, i tried to compile only gcc-4.2.2 with "-march=athlon64" CFLAGS and ACCEPT_KEYWORDS="~amd64" and segmentation fault error shows again.

My conclusion, and i might be wrong, is that HW is ok, there was no problem to emerge over 70 sources. Revdep-rebuild also did ok. I emerged over 250 sources recently and all finished correctly. So, i assume that something is "OS problem" but i have no knowledge to find what exactly. On the same hardware i have other OS and i have never ever had a crash of OS. Not linux (gentoo) nor M$Win.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2008-01-16 22:15:21 UTC
Well, thanks for reporting back. Random segfaults -> see Bug 20600 for suggestions. 
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-01-16 22:15:33 UTC

*** This bug has been marked as a duplicate of bug 20600 ***