Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 108540 - liboggz failes to compile because of an internal compiler error. (+ Version bump)
Summary: liboggz failes to compile because of an internal compiler error. (+ Version b...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-08 14:53 UTC by Francisco José Cañizares Santofimia
Modified: 2006-02-10 19:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Output when compiling liboggz. (ccpYSWj2.out,97.29 KB, text/plain)
2005-10-08 14:58 UTC, Francisco José Cañizares Santofimia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco José Cañizares Santofimia 2005-10-08 14:53:11 UTC
When compiling libggz 0.9.1 I obtain an internal compiler error (output is
attached):
----
Making all in tools
make[3]: Entering directory
`/var/tmp/portage/liboggz-0.9.3/work/liboggz-0.9.3/src/tools'
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include    
-Wall -pedantic -g -march=pentium4 -O3 -pipe -fomit-frame-pointer -Wall -g -MT
oggzdump.o -MD -MP -MF ".deps/oggzdump.Tpo" -c -o oggzdump.o oggzdump.c; \
then mv -f ".deps/oggzdump.Tpo" ".deps/oggzdump.Po"; else rm -f
".deps/oggzdump.Tpo"; exit 1; fi
oggzdump.c: In function `read_packet':

Error interno del compilador: Error al reportar rutinas reentradas.
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /var/tmp/portage/liboggz-0.9.3/temp/ccL2gEgm.out
file, please attach this to your bugreport.
make[3]: *** [oggzdump.o] Error 1
make[3]: Leaving directory
`/var/tmp/portage/liboggz-0.9.3/work/liboggz-0.9.3/src/tools'
----

I only see two options:
Removing pedantic flags with a src_unpack or so (I think this is arch-dependant,
so perhaps an arch checking will be good):

#src_unpack()
{
       unpack ${A}
       cd ${S}
       sed -i src/tools/Makefile.am -e 's/-pedantic//'
       sed -i src/tests/Makefile.am -e 's/-pedantic//'
       sed -i src/examples/Makefile.am -e 's/-pedantic//'
}

or, to set LC_ALL=C 

I think all options are good, but perhaps first is better, although I'm not sure.

Also, liboggz 0.9.3 has been released, so perhaps you could do a version bump
(by the way, error is still in 0.9.3)

Reproducible: Always
Steps to Reproduce:





Portage 2.0.51.22-r2 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.4.31-gentoo-r1 i686)
=================================================================
System uname: 2.4.31-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 2.50GHz
Gentoo Base System version 1.12.0_pre5
dev-lang/python:     2.4.1-r1
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.4.22-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="es_ES@euro"
LC_ALL="es_ES@euro"
LINGUAS="es"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib adns aim alsa apache2 apm arts artswrappersuid atk avi
bash-completion berkdb bindinst bitmap-fonts bmp cairo cdda cddb cdparanoia cdr
cjk cle266 cpdflib crypt cups curl dba dedicated dga directfb divx4linux doc dri
dvb dvd editor eds emboss encode esd estraier exif faad fam fbcon ffmpeg firefox
flac font-server foomaticdb fortran freetts freetype gcc-libffi gcj gd gdbm
geoip gg ggi gif glitz gnome gnustep gphoto2 gpm gstreamer gtk gtk2 guile httpd
icq imagemagick imlib insecure-savers intl irc jabber jack java javascript
joystick jpeg junit kde ldap libcaca libdsk libg++ libwww lirc live lj lzo lzw
mad matroska mbrola mikmod mmx mmx2 mng mod motif mozcalendar mozdevelop mozilla
mozsvg mozxmlterm mp3 mpeg msn mysql ncurses nls nsplugin objc ode offensive ogg
oggvorbis old-eq opengl oss pam pdflib perl png ppds python qt quicktime
readline real rss ruby samba scanner screen sdl server silc slang softmmu speex
spell sse sse2 ssl stream subversion svg svga symlink tcltk tcpd tetex theora
tiff tools truetype truetype-fonts type1-fonts usb vcd vidix vlm vorbis webcam
win32codecs wxwindows xchatdccserver xchattext xine xinerama xml xml2 xmltools
xmms xosd xprint xv xvid xvmc yafray yahoo zlib video_cards_radeon linguas_es
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, MAKEOPTS
Comment 1 Francisco José Cañizares Santofimia 2005-10-08 14:54:16 UTC
Forgot to mention that when compiling with LC_ALL=C, some files give output like
this:
seek-stress.c:67: warning: ISO C90 does not support the `ll' printf length modifier
Comment 2 Francisco José Cañizares Santofimia 2005-10-08 14:58:09 UTC
Created attachment 70178 [details]
Output when compiling liboggz.
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2005-10-08 15:32:59 UTC
Most likely you ran out of memory or your hardware is broken (bad ram,
overheating box,...).
Comment 4 Mark Loeser (RETIRED) gentoo-dev 2006-01-15 16:27:28 UTC
I can not reproduce this.
Comment 5 Mark Loeser (RETIRED) gentoo-dev 2006-01-15 16:27:54 UTC
This works for me, probably hardware related.

*** This bug has been marked as a duplicate of 20600 ***
Comment 6 Jesús Pérez (Chuso) 2006-02-10 19:12:07 UTC
> I can not reproduce this.

I can. I get the same error as Francisco Jose and, when removing
pedantic flags as he says all works.