Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 139328 - emerge xorg-server-1.0.2-r7 failed
Summary: emerge xorg-server-1.0.2-r7 failed
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 154814 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-07-05 08:55 UTC by baso
Modified: 2006-11-11 09:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge_info.txt,8.62 KB, text/plain)
2006-07-05 08:55 UTC, baso
Details
emerge xorg-server-1.0.2-r7.log (x11-base:xorg-server-1.0.2-r7:20060705-162707.log,28.12 KB, text/plain)
2006-07-05 09:32 UTC, baso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baso 2006-07-05 08:55:22 UTC
fbcompose.c: In function 'gradientPixel':
fbcompose.c:2652: error: 'RepeatNormal' undeclared (first use in this function)
fbcompose.c:2652: error: (Each undeclared identifier is reported only once
fbcompose.c:2652: error: for each function it appears in.)
fbcompose.c:2656: error: 'RepeatReflect' undeclared (first use in this function)
fbcompose.c:2662: error: 'RepeatPad' undeclared (first use in this function)
fbcompose.c: In function 'fbFetchTransformed':
fbcompose.c:2898: error: 'RepeatNormal' undeclared (first use in this function)
fbcompose.c: In function 'fbCompositeRect':
fbcompose.c:3411: error: 'RepeatNormal' undeclared (first use in this function)
fbcompose.c: In function 'fbCompositeGeneral':
fbcompose.c:3535: error: 'RepeatNormal' undeclared (first use in this function)
make[1]: *** [fbcompose.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I../in clude -I../include -I../include -I../include -I../hw/xfree86/os-support -I../hw/ xfree86/os-support/bus -I../hw/xfree86/common -DHAVE_DIX_CONFIG_H -DXFree86Serve r -DIN_MODULE -DXFree86Module -DXFree86LOADER -DUSE_MMX -Wall -Wpointer-arith -W strict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs - fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../include  -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../m i -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I../lbx -m arch=athlon-xp -O3 -fomit-frame-pointer -pipe -MT fbfill.lo -MD -MP -MF .deps/fb fill.Tpo -c fbfill.c  -fPIC -DPIC -o .libs/fbfill.o
make[1]: Leaving directory `/var/tmp/portage/xorg-server-1.0.2-r7/work/xorg-serv er-1.0.2/fb'
make: *** [all-recursive] Error 1

!!! ERROR: x11-base/xorg-server-1.0.2-r7 failed.
Call stack:
  ebuild.sh, line 1545:   Called dyn_compile
  ebuild.sh, line 940:   Called src_compile
  ebuild.sh, line 1254:   Called x-modular_src_compile
  x-modular.eclass, line 327:   Called x-modular_src_make
  x-modular.eclass, line 322:   Called die
Comment 1 baso 2006-07-05 08:55:45 UTC
Created attachment 90974 [details]
emerge --info
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2006-07-05 09:10:37 UTC
Please set PORT_LOGDIR in make.conf and attach the complete compilation log it produces.
Comment 3 baso 2006-07-05 09:32:12 UTC
Created attachment 90975 [details]
emerge xorg-server-1.0.2-r7.log
Comment 4 Joshua Baergen (RETIRED) gentoo-dev 2006-07-05 18:46:52 UTC
This is almost certainly caused by something from coffee's XGL overlay.  You cannot run things like the server, especially an old server, from the Portage tree with the snapshots provided in his overlay.
Comment 5 baso 2006-07-05 23:44:31 UTC
I tried excluding the xgl-coffe portage tree and re-emerging xorg-server but I get the same error. 
Comment 6 Joshua Baergen (RETIRED) gentoo-dev 2006-07-06 18:53:54 UTC
You'd have to exclude it from the overlays then do 'emerge -e xorg-x11', or 'emerge -e xorg-server' at the very least.  That'll rebuild some of your toolchain, which is unnecessary, but you need to clean out your x11 install.
Comment 7 baso 2006-07-07 04:51:54 UTC
I excluded the xgl-coffe portage tree in the make.conf
PORTDIR_OVERLAY="/usr/local/portage"
#PORTDIR_OVERLAY="${PORTDIR_OVERLAY} /usr/local/overlays/xgl-coffee"

but I can't go on with "emerge -e xorg-server" because 

[blocks B     ] >=x11-base/xorg-server-1.0.99 (is blocking media-video/nvidia-glx-1.0.8762)

I masked >=x11-base/xorg-server-1.0.99

my version of xorg-server is
*  x11-base/xorg-server
      Latest version available: 1.0.2-r7
      Latest version installed: 1.0.99.901-r1

Comment 8 baso 2006-07-08 07:29:06 UTC
I observed that the error is always different.
Sometime is the above's one, sometime is: 
pict.Tpo -c fbpict.c  -fPIC -DPIC -o .libs/fbpict.o
fbpict.c: In function 'fbComposite':
fbpict.c:845: error: 'RepeatNormal' undeclared (first use in this function)
fbpict.c:845: error: (Each undeclared identifier is reported only once
fbpict.c:845: error: for each function it appears in.)
make[1]: *** [fbpict.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/xorg-server-1.0.2-r7/work/xorg-server-1.0.2/fb'
make: *** [all-recursive] Error 1


sometime is 
make[1]: *** [fbcompose.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I../include -I../include -I../include -I../include -I../hw/xfree86/os-support -I../hw/xfree86/os-support/bus -I../hw/xfree86/common -DHAVE_DIX_CONFIG_H -DXFree86Server -DIN_MODULE -DXFree86Module -DXFree86LOADER -DUSE_MMX -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I../lbx -march=athlon-xp -O3 -fomit-frame-pointer -pipe -MT fbline.lo -MD -MP -MF .deps/fbline.Tpo -c fbline.c  -fPIC -DPIC -o .libs/fbline.o
make[1]: Leaving directory `/var/tmp/portage/xorg-server-1.0.2-r7/work/xorg-server-1.0.2/fb'
make: *** [all-recursive] Error 1


but I don't know why.
Comment 9 Joshua Baergen (RETIRED) gentoo-dev 2006-07-16 10:11:36 UTC
Is this in the latest attempts of 'emerge -e xorg-x11' ?
Comment 10 Donnie Berkholz (RETIRED) gentoo-dev 2006-08-02 22:59:39 UTC

*** This bug has been marked as a duplicate of 20600 ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-11-11 09:37:11 UTC
*** Bug 154814 has been marked as a duplicate of this bug. ***