Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 153557 - Cannot emerge tetex-2.0.2-r9
Summary: Cannot emerge tetex-2.0.2-r9
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-31 07:12 UTC by Florian Marienfeld
Modified: 2006-10-31 07:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Marienfeld 2006-10-31 07:12:32 UTC
# emerge tetex
fails with the following result.

...
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H  -I. -I. -I.. -I./..   -march=opteron -O2 -pipe  -c etex1.c
etex1.c: In function `scanexpr':
etex1.c:352: warning: comparison is always false due to limited range of data type
x86_64-pc-linux-gnu-gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <URL:http://bugs.gentoo.org/> for instructions.{standard input}: Assembler messages:
{standard input}:15077: Warning: end of file not at end of a line; newline inserted

make[2]: *** [etex1.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/tetex-2.0.2-r9/work/tetex-src-2.0.2/texk/web2c'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/var/tmp/portage/tetex-2.0.2-r9/work/tetex-src-2.0.2/texk'
make: *** [all] Error 1

!!! ERROR: app-text/tetex-2.0.2-r9 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  tetex-2.0.2-r9.ebuild, line 44:   Called tetex_src_compile
  tetex.eclass, line 175:   Called die





Portage 2.1.1-r1 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.4-r3, 2.6.17-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.17-gentoo-r4 x86_64 AMD Opteron(tm) Processor 150
Gentoo Base System version 1.12.5
Last Sync: Fri, 20 Oct 2006 14:30:07 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa apache2 berkdb bitmap-fonts bzip2 cli cracklib crypt cups dlloader dri eds elibc_glibc emboss encode foomaticdb fortran gd gif gnome gpm gstreamer gtk gtk2 imagemagick imlib input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kde kernel_linux lzw lzw-tiff mp3 mpeg mysql mysqli ncurses nls nptl nptlonly opengl pam pcre pear-db perl php png pppd python qt3 qt4 quicktime readline reflection session spell spl ssl tcpd tetex tiff truetype-fonts type1-fonts unzip usb userland_GNU video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i810 video_cards_mga video_cards_neomagic video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo xml xorg xpm xsl xv zip zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-10-31 07:42:00 UTC
Mostly likely out of RAM/disk space.

*** This bug has been marked as a duplicate of 20600 ***