Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 101750 - can't compile mysql-4.0.24
Summary: can't compile mysql-4.0.24
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-08 07:16 UTC by Matthias F. Brandstetter
Modified: 2005-08-08 07:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias F. Brandstetter gentoo-dev 2005-08-08 07:16:52 UTC
When I try to merge mysql I get the following error during compilation:

...
{standard input}: Assembler messages:
{standard input}:6530: Warning: partial line at end of file ignored
g++: Internal error: Segmentation fault (program cc1plus)
Please submit a full bug report.
See <URL:http://bugs.gentoo.org/> for instructions.
make[3]: *** [sql_select.o] Error 1
make[3]: Leaving directory
`/var/tmp/portage/mysql-4.0.24/work/mysql-4.0.24/libmysqld'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/var/tmp/portage/mysql-4.0.24/work/mysql-4.0.24/libmysqld'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mysql-4.0.24/work/mysql-4.0.24'
make: *** [all] Error 2

Reproducible: Always
Steps to Reproduce:
just did a "emerge mysql"




Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.4,
glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r5 i686)
=================================================================
System uname: 2.6.11-gentoo-r5 i686 AMD Athlon(tm) XP 2100+
Gentoo Base System version 1.4.16
dev-lang/python:     2.2.2, 2.3.4
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.14.90.0.8-r1
sys-devel/libtool:   1.4.1-r10, 1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE=""
ANT_HOME="/usr/share/ant-core"
ARCH="x86"
AUTOCLEAN="yes"
BASH_ENV="/etc/spork/is/not/valid/profile.env"
CBUILD="i686-pc-linux-gnu"
CC="gcc"
CFLAGS="-O2 -march=athlon-xp -pipe -w"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
COLORTERM=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/share/config:/usr/kde/3.3/env:/usr/kde/3.3/shutdown
/usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CRYSTAL="/opt/crystal"
CVSROOT=":pserver:haim@firewall.ebox.at:/usr/local/cvsroot"
CVS_RSH="ssh"
CXX="g++"
CXXFLAGS="-O2 -march=athlon-xp -pipe -w"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_WARNING_DELAY="10"
FEATURES="autoconfig candy distlocks moo sandbox sfperms strict userpriv
usersandbox"
FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://gentoo.inode.at/
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/
http://mirrors.sec.informatik.tu-darmstadt.de/gentoo
http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
GLIBC_SSP_CHECKED="1"
GPG_AGENT_INFO="/tmp/gpg-WxNcqM/S.gpg-agent:8302:1"
GRP_STAGE23_USE="ipv6 pam tcpd readline nls ssl gpm perl python berkdb ncurses"
GS_LIB="/home/haim/.fonts"
GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:/home/haim/.gtkrc-2.0:/home/haim/.kde3.4/share/config/gtkrc"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/haim/.gtkrc:/home/haim/.kde3.4/share/config/gtkrc"
GUILE_LOAD_PATH="/usr/share/guile/1.6"
G_BROKEN_FILENAMES="1"
HOME="/home/haim"
HOSTNAME="itchy"
INFODIR="/usr/share/info"
INFOPATH="/usr/share/info:/usr/share/gcc-data/i686-pc-linux-gnu/3.3/info:/usr/share/info"
INPUTRC="/etc/inputrc"
JAVA_HOME="/opt/sun-jre-bin-1.4.2.08"
JRE_HOME="/opt/sun-jre-bin-1.4.2.08"
KDEDIR="/usr/kde/3.3"
KDEDIRS="/usr"
KDE_FULL_SESSION="true"
KDE_MULTIHEAD="false"
KERNEL="linux"
KONSOLE_DCOP="DCOPRef(konsole-25273,konsole)"
KONSOLE_DCOP_SESSION="DCOPRef(konsole-25273,session-1)"
LESS="-r"
LESSOPEN="|lesspipe.sh %s"
LOGNAME="haim"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.png=01;35:*.mpg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:"
MAIL="/var/mail/haim"
MANPATH="/usr/share/man:/usr/local/share/man:/usr/share/gcc-data/i686-pc-linux-gnu/3.3/man:/usr/X11R6/man::/opt/sun-jre-bin-1.4.2.08/man:/usr/qt/3/man:/usr/qt/3/doc/man:/opt/vmware/man:/opt/sun-jre-bin-1.4.2.08/man"
MOZILLA_FIVE_HOME="/usr/lib/mozilla"
PAGER="/usr/bin/most"
PATH="/opt/sun-jre-bin-1.4.2.08/bin:/opt/sun-jre-bin-1.4.2.08/javaws:/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/usr/qt/3/bin:/usr/kde/3.4/bin:/usr/games/bin:/home/haim/scripts:/usr/bin/wrappers"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos ppc-od
s390 sh sparc x86 x86-fbsd x86-obsd x86-od"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_CALLER="emerge"
PORTAGE_GID="250"
PORTAGE_MASTER_PID="14488"
PORTAGE_NICENESS="10"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
PRELINK_PATH=""
PRELINK_PATH_MASK="/usr/lib/gstreamer-0.8"
PS1="\[\033[00m\][ \[\033[01;37m\]$(/bin/date +%H:%M) \[\033[01;32m\]\u@\h
\[\033[01;34m\]$(ps1dir $PWD) \[\033[00m\]] "
PWD="/home/haim"
PYTHONDOCS="/usr/share/doc/python-docs-2.3.4/html"
PYTHONPATH="/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
RPMDIR="/usr/portage/rpm"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT="180"
SESSION_MANAGER="local/itchy:/tmp/.ICE-unix/8393"
SGML_CATALOG_FILES="/etc/sgml/sgml-ent.cat:/etc/sgml/sgml-docbook.cat:/etc/sgml/openjade-1.3.1.cat:/etc/sgml/sgml-docbook-3.1.cat:/etc/sgml/sgml-lite.cat:/etc/sgml/dsssl-docbook-stylesheets.cat:/etc/sgml/sgml-docbook-3.0.cat"
SHELL="/bin/bash"
SHLVL="5"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
TMAKEPATH="/usr/lib/tmake/linux-g++"
USE="x86 3dnow X aalib alsa arts avi bash-completion bitmap-fonts bonobo cdr
crypt cscope cups curl dga divx4linux doc dvd dvdr dvdread eds emboss encode esd
fam fastcgi flac foomaticdb fortran gd gdbm gif gphoto2 gstreamer gtk gtk2
gtkhtml guile hbci imagemagick ipv6 java jpeg junit kde kdeenablefinal kerberos
ldap libg++ libwww lirc mad maildir md5sum mmx mmx2 motif mp3 mpeg mysql ncurses
nvidia odbc offensive ogg opengl pam pdflib perl png python qt quicktime
readline real samba sdl slang sqlite sse sse2 ssl svga tcpd tiff truetype
truetype-fonts type1-fonts usb videos visualization vorbis win32codecs xine xml
xml2 xmms xv xvid zlib userland_GNU kernel_linux elibc_glibc"
USER="haim"
USERLAND="GNU"
USE_EXPAND="FRITZCAPI_CARDS FCDSL_CARDS VIDEO_CARDS INPUT_DEVICES LINGUAS
USERLAND KERNEL ELIBC"
WINDOWID="46137352"
XARGS="xargs -r"
XAUTHORITY="/home/haim/.Xauthority"
XCURSOR_THEME="whiteglass"
XINITRC="/etc/X11/xinit/xinitrc"
_="/usr/bin/emerge"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-08-08 07:23:45 UTC
Out of disk space, bad memory or broken toolchain... Also your system is pretty
outdated.
Comment 2 Matthias F. Brandstetter gentoo-dev 2005-08-08 07:27:12 UTC
*) bad memory: don't thnink so, I never had any problems with it. I can compile
thinks like OOorg, KDE or such w/o any problem.

*) out of disk space: no, I have several GBs left

*) broken toolchain: what can I do about that? what do I have to update?

*) outdated system: what do you mean? how does this affect the MySQL compilation?
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-08-08 07:34:07 UTC
(In reply to comment #2)
> *) broken toolchain: what can I do about that? what do I have to update?
> 
> *) outdated system: what do you mean? how does this affect the MySQL compilation?

You have outdated gcc, glibc, binutils, linux-headers, libtool (unmerge the
*really* obsolete libtool-1.4.1-r10) and upgrade the other version, etc. etc.
Emerge sync and upgrade everything. Internal compiler error is not MySQL bug. 

*** This bug has been marked as a duplicate of 20600 ***