Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 194998 - x11-libs/qt-3.3.8-r4 segfault during compile
Summary: x11-libs/qt-3.3.8-r4 segfault during compile
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-10-07 14:52 UTC by jonathan e. Snow
Modified: 2007-10-07 15:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description jonathan e. Snow 2007-10-07 14:52:57 UTC
emerging x11-libs/qt-3.3.8-r4 I get the same error message consistently:

{standard input}: Assembler messages: 
 {standard input}:10542: Warning: end of file not at end of a line; newline inserted 
 i686-pc-linux-gnu-g++: Internal error: Segmentation fault (program cc1plus) 
It's not always at the same place, but always the same error: "newline inserted", which of course then triggers the segfault. 

It is not sensitive to cpu cooling -- behavior is the same at a heat sink temperature of 46 degrees C or 33 degrees C. It's not memory shortage, the system has 1GB ram and 1GB swap. I tried reducing the memory footprint with 
MAKEOPTS="j1" so that fewer instances of gcc would be running. No change.

This only happens with qt, *not* with other large packages such as kdelibs. 

Reproducible: Always
Comment 1 jonathan e. Snow 2007-10-07 14:54:17 UTC
Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.18-gentoo-r6 i686)
System uname: 2.6.18-gentoo-r6 i686 VIA Nehemiah
Timestamp of tree: Fri, 05 Oct 2007 02:30:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
CFLAGS="-Os -march=i686 -msse -mmmx -finline-functions -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-Os -march=i686 -msse -mmmx -finline-functions -fomit-frame-pointer -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en de fr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="X aac aalib acl acpi alsa apm arts artswrapersuid asf avi berkdb bitmap-fonts bzlib cairo cdr cdrom cle266 cli cracklib crypt cups dbus dga directfb divx4linux dri dts dvb dvd dvdr dvdread eds emboss encode esd evo exif fam fbcon ffmpeg firefox flac flash foomaticdb fortran freetype gdbm gif gimp gimpprint gpm gstreamer gtk gutenprint hal iconv idga ipv6 isdnlog java jpeg kde kerberos ldap mad midi mikmod mmx mmxext mp3 mpeg mpeg4 mplayer mudflap ncurses nls nptl nptlonly nsplugin nspluginnptl ogg opengl openmp pam pch pcre pdf perl png ppds pppd print python qt3 qt3support quicktime readline reflection rtc samba scanner sdl session spell spl sqlite sse ssl svg svga tcpd theora tiff truetype truetype-fonts type1 type1-fonts unichrome unicode usb v4l vidix vorbis win32codecs wma x86 xine xml xorg xrandr xscreensaver xv xvid xvmc zeroconf zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de fr" USERLAND="GNU" VIDEO_CARDS="via"

Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-10-07 15:03:19 UTC
Well, failures at random places seriously are not gcc issue, see Bug 20600 for hints.

*** This bug has been marked as a duplicate of bug 20600 ***