Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451612 - sys-devel/gcc-4.6.3 - g++ segfaults whilst compiling thunderbird 17.0.2
Summary: sys-devel/gcc-4.6.3 - g++ segfaults whilst compiling thunderbird 17.0.2
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-13 05:24 UTC by Lyall Pearce
Modified: 2013-01-15 12:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lyall Pearce 2013-01-13 05:24:29 UTC
x86_64-pc-linux-gnu-g++ -o jsnum.o -c  -I./../../dist/system_wrappers_js -include /tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/config/gcc_hidden.h -DENABLE_YARR_JIT=1 -DMOZ_GLUE_IN_PROGRAM -DEXPORT_JS_API -DJS_HAS_CTYPES -DDLL_PREFIX=\"lib\" -DDLL_SUFFIX=\".so\" -DNO_NSPR_10_SUPPORT -DUSE_ZLIB -I/usr/lib64/libffi-3.0.11/include   -I.  -I/tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/../../mfbt/double-conversion -I/tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src -I. -I./../../dist/include  -I/usr/include/nspr      -I/tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src -I/tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/assembler -I/tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/yarr  -fPIC  -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -ggdb -mtune=native -march=native -pipe -Wno-return-type -w -mno-avx -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -pthread -pipe  -DNDEBUG -DTRIMMED -g -O3 -freorder-blocks  -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1   -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/jsnum.o.pp /tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/jsnum.cpp
jsobj.cpp
In file included from /tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/jsprvtd.h:28:0,
                 from /tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/jsatom.h:14,
                 from /tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/jsgc.cpp:50:
./../../dist/include/js/HashTable.h: In member function 'bool js::HashSet<T, HashPolicy, AllocPolicy>::has(const Lookup&) const [with T = js::gc::Chunk*, HashPolicy = js::GCChunkHasher, AllocPolicy = js::SystemAllocPolicy, js::HashSet<T, HashPolicy, AllocPolicy>::Lookup = js::gc::Chunk*]':
/tmp/portage/mail-client/thunderbird-17.0.2/work/comm-esr17/mozilla/js/src/jsgc.cpp:1033:34:   instantiated from here
./../../dist/include/js/HashTable.h:1399:34: internal compiler error: Segmentation fault
Please submit a full bug report,

# emerge --info
Portage 2.1.11.40 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.1
Timestamp of tree: Sat, 12 Jan 2013 23:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: zugaina java-overlay enlightenment sunrise gamerlay x-local gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -ggdb -mtune=native -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /lib/udev/rules.d /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/lib/sabnzbd/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -ggdb -mtune=native -march=native -pipe"
DISTDIR="/portage/gentoo/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.internode.on.net/pub/gentoo ftp://mirror.pacific.net.au/linux/Gentoo http://mymirror.asiaosc.org/gentoo/ http://www.zentek-international.com/mirrors/gentoo/ http://open-systems.ufl.edu/mirrors/gentoo http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/portage/gentoo/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/portage/gentoo"
PORTDIR_OVERLAY="/portage/local/layman/zugaina /portage/local/layman/java-overlay /portage/local/layman/enlightenment /portage/local/layman/sunrise /portage/local/layman/gamerlay /portage/local /portage/gentoo"
SYNC="rsync://mirror.internode.on.net/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr apache2 avahi berkdb bluetooth branding bzip2 cairo cdb cdda cddb cdio cdr cleartype cli consolekit corefonts cracklib crypt css cups cxx daap dbus dri dts dvd dvdr emboss encode esd exif ffmpeg firefox flac fortran gd gdbm gdu gif gpm iconv ipod ipv6 java javascript joystick jpeg jpeg2k kde laptop latin1 lcms lm_sensors mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nls nptl nsplugin nvidia ogg opengl openmp oss pam pango pcre pdf perl pmu png policykit posix ppds pppd python qt3support qt4 readline rss samba sdl semantic-desktop server session smp spell sqlite sse sse2 sse3 ssl svg tcpd threads tiff transcode truetype type1 udev udisks unicode upower usb v4l v4l2 vcd virtuoso vorbis wifi wma wxwidgets x264 xcb xcomposite xine xinerama xml xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2013-01-15 12:02:21 UTC

*** This bug has been marked as a duplicate of bug 20600 ***