Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 399143 - www-client/chromium-17..0.963.33 - chrome/browser/sync/syncable/syncable.cc:555:1: internal compiler error: Segmentation fault
Summary: www-client/chromium-17..0.963.33 - chrome/browser/sync/syncable/syncable.cc:5...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 08:15 UTC by Robert
Modified: 2012-05-31 00:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Full build log, not compressed (build.log,781.93 KB, text/plain)
2012-01-17 08:16 UTC, Robert
Details
the use flags i have enabled for chromium at build time (not many) (useflags.txt,491 bytes, text/plain)
2012-01-17 08:17 UTC, Robert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2012-01-17 08:15:58 UTC
I have tried all of the different profiles for the different version of gcc i have install and haven't have much luck. I have tried compiling with 4.5.3 (hardened / PaX only) and then with 4.5.3-nopie, 4.5.3-bopiessp 4.5.3-nossp 4.5.3-vanilla. I did the same for 4.6.* and since chromium nor FF will compile with 4.4.* I really dont know what else to.

Reproducible: Always

Steps to Reproduce:
1. emerge -av =www-client/chromium-17.0.963.33

2.  wait

3.  SegFault (at random places it seems)
Actual Results:  
Chromium fails to compile on any profile options I have, not just generally gcc-4.5.3-hardened 

Expected Results:  
Chromium should have compiled, It worked up till 16.0.912.63, that compiled fine.

Portage 2.2.0_alpha84 (hardened/linux/amd64, gcc-4.5.3, glibc-2.14.1-r2, 3.1.5-hardened x86_64)
=================================================================
System uname: Linux-3.1.5-hardened-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E4600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Tue, 17 Jan 2012 02:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.2
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2, 4.6.0
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo enlightenment my_local_overlay
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA googleearth Oracle-BCLA-JavaSE Intel-SDP"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://mirrors.rit.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/enlightenment /usr/local/portage"
SYNC="rsync://rsync5.us.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi alsa amd64 apm bash-completion berkdb bluetooth bzip2 cairo calender cdda cddb cdinstall cdparanoia cdr cjk cli consolekit cracklib crypt css cups curl curlwrappers cxx dbus dbx dga djvu dri dts dv dvb dvd dvdr encode enscript exif expat ffmpeg fftw firefox flac flash fontconfig foomaticdb fortran ftp gd gdbm geoip gif gimp ginac gpm graphviz gsl gstreamer gtk gzip hardened hddtemp iconv ieee1394 imagemagick imap imlib inifile ios ipod ipv6 java javascript jbig joystick jpeg jpeg2k justify lame latex lcms ldap libnotify libsamplerate libwww lm_sensors lzma lzo mad matroska mime mmap mms mmx mmxext mng modules mp3 mp4 mpeg mplayer msn mtp mudflap multilib musicbrainz nas ncurses neXt nls nntp nocd nptl nptlonly nsplugin ocml offensive ofx ogg openexr opengl openmp pam pango pax_kernel pcntl pcre pda pdf perl php pic plasma plotutils png ppds pppd python qt4 quicktime raw readline rss ruby samba sasl scanner sdl session sharedext smartcard smp snmp soap sockets socks5 sound spell sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification subversion svg sysfs syslog szip taglib tcl tcpd theora threads tidy tiff tk truetype udev unicode upnp urandom usb v4l v4l2 vcd videos vorbis wavpack wifi wmf wxwidgets x264 xattr xcb xcomposite xine xinerama xinetd xml xorg xpm xscreensaver xsl xv xvid xvmc yaz zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Robert 2012-01-17 08:16:57 UTC
Created attachment 299127 [details]
Full build log, not compressed

helps me please!?
Comment 2 Robert 2012-01-17 08:17:33 UTC
Created attachment 299129 [details]
the use flags i have enabled for chromium at build time (not many)
Comment 3 Robert 2012-01-17 08:21:13 UTC
I should probably add that I thought that the program kept crashing at the same place as long as the gcc profile was the same only that it failed in different places when using different gcc profiles. However after knocking it back to -j1 with normal 4.5.3 (hardened w/ PaX only) it gave a different than with -j2, so I reran the compile again at -j1 and it stopped at yet ANOTHER file!!!

To me this would mean physical hardware problems but I did a full test with memtest (the only modules I have changed in this comp within the last week, havent changed anything else for over a year) and it can out 100% no errors.......

Anyway, thought that extra bit might be enough.
Comment 4 Tolga Dalman 2012-01-18 08:45:40 UTC
Indeed, this seems rather strange. Have you looked at your system logs after the crash (or dmesg) ? I'm asking, because I had some crashs with my T61 a few months ago while compiling stuff. The cause was, that I had no power management activated. After cleaning my fans and enabling the PM all problems are gone.

I have no experience with hardened/PaX stuff, but I suspect the error would be more deterministic in any case.

Hope that helps.
Comment 5 Joe Kappus 2012-05-29 01:44:21 UTC
This screams overheating issue.  My T60 was prone to compiler segfaults like this before I switched out the TIM to arctic silver 5 and replaced the cooling system. I suggest watching /proc/acpi/ibm/thermal as it compiles and see if it gets above 90C.

Or try compiling this with the laptop in your refrigerator or freezer and see how it results.

Otherwise, I'd suggest closing this bug as unable to reproduce.
Comment 6 SpanKY gentoo-dev 2012-05-31 00:39:13 UTC
you can use cpufreq-set from sys-power/cpufrequtils to force your CPU to a lower frequency that will presumably not overheat, and then see if building with -j1 works better

*** This bug has been marked as a duplicate of bug 20600 ***