Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 381061 - sys-libs/glibc-2.12.2 - make[16369]: segfault at 41414180 ip 400b26a1 sp bfde0988 error 6 in libc-2.12.2.so[4003f000+154000]
Summary: sys-libs/glibc-2.12.2 - make[16369]: segfault at 41414180 ip 400b26a1 sp bfde...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-29 14:09 UTC by Thomas Beutin
Modified: 2012-08-14 16:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
last 200 lines of /var/tmp/portage/sys-libs/glibc-2.12.2/temp/build.log (build-last-200-lines.log,22.82 KB, text/plain)
2011-08-29 14:13 UTC, Thomas Beutin
Details
/var/tmp/portage/sys-libs/glibc-2.12.2/temp/environment (environment,153.91 KB, text/plain)
2011-08-29 14:14 UTC, Thomas Beutin
Details
complete build.log gzipped (build.log.gz,263.30 KB, application/gzip)
2011-08-31 16:40 UTC, Thomas Beutin
Details
complete build.log gzipped (build.log.gz,263.31 KB, application/gzip)
2012-01-23 19:49 UTC, Thomas Beutin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Beutin 2011-08-29 14:09:24 UTC
On a fresh installed gentoo system i can compile the package sys-libs/glibc-2.12.2 only once. The second reinstallation fails with an Segmentation fault.
# dmesg | grep segfault
make[16369]: segfault at 41414180 ip 400b26a1 sp bfde0988 error 6 in libc-2.12.2.so[4003f000+154000]
make[4223]: segfault at 41414180 ip b76526a1 sp bf902c08 error 6 in libc-2.12.2.so[b75df000+154000]

The hardware is a AMD E-350 Processor on an ASUS E35M1-M pro, the kernel a 2.6.38-gentoo-r6 #1 SMP Thu Aug 18 18:36:30 CEST 2011 i686 AMD E-350 Processor AuthenticAMD GNU/Linux 32bit system


Reproducible: Always

Steps to Reproduce:
1. install gentoo using stage3-i486-20110712.tar.bz2
2. do an emerge -e world
3. do an emerge -1 =sys-libs/glibc-2.12.2
Actual Results:  
make  subdir=locale -C locale ..=../ subdir_install
make[1]: *** [locale/subdir_install] Segmentation fault
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.12.2/work/glibc-2.12.2'
make: *** [install] Error 2
emake failed

(i'll attach /var/tmp/portage/sys-libs/glibc-2.12.2/temp/build.log and /var/tmp/portage/sys-libs/glibc-2.12.2/temp/environment soon)

Expected Results:  
i expect a clean smooth, compilation as many times as i'm in the mood to do so

Portage 2.1.10.3 (default/linux/x86/10.0/server, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-i686-AMD_E-350_Processor-with-gentoo-2.0.3
Timestamp of tree: Wed, 27 Jul 2011 13:00:02 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O1 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O1 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 modules mudflap ncurses nls nptl nptlonly openmp pam pcre pppd readline session snmp ssl sysfs tcpd truetype unicode x86 xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Thomas Beutin 2011-08-29 14:13:25 UTC
Created attachment 285005 [details]
last 200 lines of /var/tmp/portage/sys-libs/glibc-2.12.2/temp/build.log

this are only the last 200 lines of /var/tmp/portage/sys-libs/glibc-2.12.2/temp/build.log. if required i can post the full build.log or provide a download link for the gzipped file.
Comment 2 Thomas Beutin 2011-08-29 14:14:08 UTC
Created attachment 285007 [details]
/var/tmp/portage/sys-libs/glibc-2.12.2/temp/environment
Comment 3 Thomas Beutin 2011-08-29 14:19:03 UTC
#  emerge -pqv =sys-libs/glibc-2.12.2
 * Last emerge --sync was 33d 1h 43m 6s ago.
[ebuild   R   ] sys-libs/glibc-2.12.2  USE="nls -debug -gd -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla"
Comment 4 Jeroen Roovers gentoo-dev 2011-08-31 16:09:49 UTC
(In reply to comment #1)
> Created attachment 285005 [details]
> last 200 lines of /var/tmp/portage/sys-libs/glibc-2.12.2/temp/build.log
> 
> this are only the last 200 lines of
> /var/tmp/portage/sys-libs/glibc-2.12.2/temp/build.log. if required i can post
> the full build.log or provide a download link for the gzipped file.

Just attach the gzipped file.
Comment 5 Thomas Beutin 2011-08-31 16:40:29 UTC
Created attachment 285151 [details]
complete build.log gzipped

the complete build.log gzipped as request in comment #4
Comment 6 SpanKY gentoo-dev 2011-12-06 23:47:42 UTC
i don't suppose current stable glibc-2.13 + binutils-2.21 works ?
Comment 7 Thomas Beutin 2011-12-17 18:59:19 UTC
(In reply to comment #6)
> i don't suppose current stable glibc-2.13 + binutils-2.21 works ?

last week i tried an almost recent amd64 install, and the problem wasn't there - everything worked like a charme. unfortunally i need a x86 system, so i'm installing install-x86-minimal-20111213.iso, stage3-i686-20111213.tar.bz2 and portage-20111214.tar.bz2 at the moment. maybe i can report status updates tomorrow or next weekend.
Comment 8 SpanKY gentoo-dev 2012-01-14 09:19:59 UTC
any luck ?
Comment 9 Thomas Beutin 2012-01-21 23:24:55 UTC
(In reply to comment #8)
> any luck ?

i installed a new x86 gentoo around Dec. 17., and this specific error was not the problem anymore, but another error occured while emerging glibc (and i don't know neither the glibc version i installed at this time nor the precise error message). to reproduce the error again i booted today the machine into this x86 system, and after a sync and an "emerge -pv1DNu world" the sys-libs/glibc-2.13-r4 showed up for reemerging. The first try of reemerging failed in the patch stage (1075_* iirc), and now i scheduled 20 emerge cycles. The second cycle failed:
make[2]: Entering directory `/var/tmp/portage/sys-libs/glibc-2.13-r4/work/glibc-2.13/login'
Makefile:72: warning: overriding recipe for target `/var/tmp/portage/sys-libs/glibc-2.13-r4/work/build-default-i686-pc-linux-gnu-nptl/login/pt_chown'
../Rules:120: warning: ignoring old recipe for target `/var/tmp/portage/sys-libs/glibc-2.13-r4/work/build-default-i686-pc-linux-gnu-nptl/login/pt_chown'
make[1]: *** [login/subdir_install] Illegal instruction
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.13-r4/work/glibc-2.13'
make: *** [install] Error 2
emake failed

but nothing in the dmesg output shows up.

but the third cycle already started and all log files in the temporary directory are overwritten. tomorrow i'll change the test script to stop after emerge failure.


in the meantime i decided to stay with an amd64 system on this particular machine, because this works w/o any problem so far, and i've no need for a 32bit server system anymore. but for now i still can provide error messages and logs if You think this is helpful to hunt the bug.
Comment 10 Thomas Beutin 2012-01-23 19:49:10 UTC
Created attachment 299645 [details]
complete build.log gzipped

here is a new complete build log (example). emerge failes almost every second run somwhere with an "Illegal instruction".

output of 'emerge -pqv =sys-libs/glibc-2.13-r4':
[ebuild   R   ] sys-libs/glibc-2.13-r4  USE="-debug -gd -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla" 

output of 'emerge --info =sys-libs/glibc-2.13-r4':
Portage 2.1.10.41 (default/linux/x86/10.0, gcc-4.5.3, glibc-2.13-r4, 3.1.6-gentoo i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.1.6-gentoo-i686-AMD_E-350_Processor-with-gentoo-2.0.3
Timestamp of tree: Sat, 21 Jan 2012 14:30:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 mmx modules mudflap ncurses nls nptl nptlonly openmp pam pcre pppd readline session sse sse2 ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-libs/glibc-2.13-r4 was built with the following:
USE="-debug -gd -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla"
CFLAGS="-pipe -O2 -fno-strict-aliasing"
CXXFLAGS="-pipe -O2 -fno-strict-aliasing"
Comment 11 SpanKY gentoo-dev 2012-08-14 16:29:23 UTC

*** This bug has been marked as a duplicate of bug 20600 ***