Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 430644 - sys-devel/binutils-2.22-r1 - {standard input}:22612: Error: ARM register expected -- `ldr' {standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
Summary: sys-devel/binutils-2.22-r1 - {standard input}:22612: Error: ARM register expe...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: ARM Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-09 17:26 UTC by Norman Rieß
Modified: 2012-08-10 00:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Full build log (file_430644.txt,355.53 KB, text/plain)
2012-08-09 17:26 UTC, Norman Rieß
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Norman Rieß 2012-08-09 17:26:08 UTC
Created attachment 320818 [details]
Full build log

sys-devel/binutils-2.22-r1 fails to build on MAKEOPTS="-j2".
Building will succeed with -j1.
Later version 2.29 also fails.


cat /etc/make.conf
CFLAGS="-O2 -pipe -mcpu=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard"
CXXFLAGS="${CFLAGS}"
CHOST="armv6j-hardfloat-linux-gnueabi"
MAKEOPTS="-j1"

USE="X dbus directfb fbcon png jpeg ogg xvid vorbis theora matroska mp3 mjpeg mpeg x264 vaapi vpx alsa nls unicode threads tls gnutls"

LINGUAS="de"
AUTOCLEAN="yes"
SYNC="rsync://asgard/gentoo-portage"
FEATURES="parallel-fetch"

VIDEO_CARDS="dummy fbdev"


####################################
emerge --info
Portage 2.1.10.65 (default/linux/arm/10.0/armv6j, gcc-4.5.3, glibc-2.14.1-r3, 3.1.9+ armv6l)
=================================================================
System uname: Linux-3.1.9+-armv6l-ARMv6-compatible_processor_rev_7_-v6l-with-gentoo-2.1
Timestamp of tree: Thu, 09 Aug 2012 01:00:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv6j-hardfloat-linux-gnueabi"
CFLAGS="-O2 -pipe -mcpu=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard"
CHOST="armv6j-hardfloat-linux-gnueabi"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -mcpu=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe -march=armv6j -mfpu=vfp -mfloat-abi=softfp"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe -march=armv6j -mfpu=vfp -mfloat-abi=softfp"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://asgard/gentoo-portage"
USE="X acl alsa arm berkdb bzip2 cli cracklib crypt cups cxx dbus directfb fbcon fortran gdbm gnutls gpm iconv ipv6 jpeg matroska mjpeg modules mp3 mpeg mudflap ncurses nls nptl ogg openmp pam pcre png pppd readline session ssl tcpd theora threads tls unicode vorbis xvid zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="dummy fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2012-08-10 00:03:07 UTC
armv6j-hardfloat-linux-gnueabi-g++: Interner Fehler: Getötet (Programm cc1plus)

That means you ran out of RAM, most likely. The usual actions are:

1) install more RAM
2) Remove -pipe from your CFLAGS
3) Set MAKEOPTS=-j1
4) install more RAM
5) cross-compile it on a bigger system
Comment 2 SpanKY gentoo-dev 2012-08-10 00:43:49 UTC

*** This bug has been marked as a duplicate of bug 20600 ***