Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 110283 - Segmentation fault's on install of gawk, gcc, glibc
Summary: Segmentation fault's on install of gawk, gcc, glibc
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2005-10-23 18:41 UTC by Rance Smith
Modified: 2005-11-10 18:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rance Smith 2005-10-23 18:41:27 UTC
I orignally had this problem when doing upgrades on my system I usually use
--deep and --update when doing this.  the first time I saw it was when it tried
to upgrade gawk.  As far as I can tell from the output it looks like it actually
finishes the install but something crashes with emerge?  I've searched the
forums and bugs tried many different solutions for problems that looked like
what I was running into like the fix_lib....  revdep-rebuild  emerge -e system 
etc.  but I only foudn more problems.  I found that glibc wouldn't update at a
later date, then when trying the emerge -e system I found that Gcc wouldn't
compile.  I always run into the same errors at the same places, and I've waited
about a month to see if there was just a simple bug that would be fixed.  Any
help with this would be greatly appreciated.

Reproducible: Always
Steps to Reproduce:
1. Unknown "emerge gcc" "emerge gawk" "emerge glibc"?

Actual Results:  
Verious Segmentation faults what appears to be the install stages of the emerge.

Expected Results:  
Installed without errors.


make[4]: Leaving directory `/var/tmp/portage/gcc-3.4.4-r1/work/build/gcc'
./xgcc -B./ -B/usr/x86_64-pc-linux-gnu/bin/ -isystem /usr/x86_64-pc-linux-gnu/in
clude -isystem /usr/x86_64-pc-linux-gnu/sys-include -L/var/tmp/portage/gcc-3.4.4
-r1/work/build/gcc/../ld -O2  -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prot
otypes -Wmissing-prototypes -Wold-style-definition  -isystem ./include  -fPIC -D
C_PROVIDES_SSP_ -shared -nodefaultlibs -Wl, -Wl,--version-
script=libgcc/32/ -o 32/  -m32  libgcc/32/_muldi3.o l
ibgcc/32/_negdi2.o libgcc/32/_lshrdi3.o libgcc/32/_ashldi3.o libgcc/32/_ashrdi3.
o libgcc/32/_cmpdi2.o libgcc/32/_ucmpdi2.o libgcc/32/_floatdidf.o libgcc/32/_flo
atdisf.o libgcc/32/_fixunsdfsi.o libgcc/32/_fixunssfsi.o libgcc/32/_fixunsdfdi.o
 libgcc/32/_fixdfdi.o libgcc/32/_fixunssfdi.o libgcc/32/_fixsfdi.o libgcc/32/_fi
xxfdi.o libgcc/32/_fixunsxfdi.o libgcc/32/_floatdixf.o libgcc/32/_fixunsxfsi.o l
ibgcc/32/_fixtfdi.o libgcc/32/_fixunstfdi.o libgcc/32/_floatditf.o libgcc/32/_cl
ear_cache.o libgcc/32/_enable_execute_stack.o libgcc/32/_trampoline.o libgcc/32/
__main.o libgcc/32/_absvsi2.o libgcc/32/_absvdi2.o libgcc/32/_addvsi3.o libgcc/3
2/_addvdi3.o libgcc/32/_subvsi3.o libgcc/32/_subvdi3.o libgcc/32/_mulvsi3.o libg
cc/32/_mulvdi3.o libgcc/32/_negvsi2.o libgcc/32/_negvdi2.o libgcc/32/_ctors.o li
bgcc/32/_ffssi2.o libgcc/32/_ffsdi2.o libgcc/32/_clz.o libgcc/32/_clzsi2.o libgc
c/32/_clzdi2.o libgcc/32/_ctzsi2.o libgcc/32/_ctzdi2.o libgcc/32/_popcount_tab.o
 libgcc/32/_popcountsi2.o libgcc/32/_popcountdi2.o libgcc/32/_paritysi2.o libgcc
/32/_paritydi2.o libgcc/32/_stack_smash_handler.o libgcc/32/_divdi3.o libgcc/32/
_moddi3.o libgcc/32/_udivdi3.o libgcc/32/_umoddi3.o libgcc/32/_udiv_w_sdiv.o lib
gcc/32/_udivmoddi4.o  libgcc/32/unwind-dw2.o libgcc/32/unwind-dw2-fde-glibc.o li
bgcc/32/unwind-sjlj.o libgcc/32/gthr-gnat.o libgcc/32/unwind-c.o -lc && rm -f li && if [ -f 32/ ]; then mv -f 32/ 32/libgc; else true; fi && mv 32/ 32/ && ln
 -s 32/
/bin/sh: line 1: 19391 Segmentation fault      mv 32/ 32/libgcc
make[3]: *** [32/] Error 139
make[3]: Leaving directory `/var/tmp/portage/gcc-3.4.4-r1/work/build/gcc'
make[2]: *** [stmp-multilib] Error 2
make[2]: Leaving directory `/var/tmp/portage/gcc-3.4.4-r1/work/build/gcc'
make[1]: *** [stageprofile_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.4.4-r1/work/build/gcc'
make: *** [profiledbootstrap] Error 2

!!! ERROR: sys-devel/gcc-3.4.4-r1 failed.
!!! Function gcc_do_make, Line 1308, Exitcode 2
!!! emake failed with profiledbootstrap
!!! If you need support, post the topmost build error, NOT this status message.


test ! -x /var/tmp/portage/glibc-2.3.5-r2/work/build-amd64-x86_64-pc-linux-gnu-l
inuxthreads/elf/ldconfig || LC_ALL=C LANGUAGE=C \ 
ads/elf/ldconfig -r /var/tmp/portage/glibc-2.3.5-r2/image/ \
                                 /lib64 /usr/lib64
s/elf/ldconfig: Can't open configuration file /etc/ No such file or d
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.5-r2/work/glibc-2.3.5'
strip: x86_64-pc-linux-gnu-strip --strip-unneeded
strip: x86_64-pc-linux-gnu-strip --strip-unneeded
/usr/lib/portage/bin/prepstrip: line 19: 30524 Segmentation fault      ${STRIP}


>>> Completed installing gawk-3.1.4-r4 into /var/tmp/portage/gawk-3.1.4-r4/image/

>>> Merging sys-apps/gawk-3.1.4-r4 to /
--- /bin/
>>> /bin/awk -> gawk-3.1.4
>>> /bin/gawk -> gawk-3.1.4
>>> /bin/gawk-3.1.4
--- /lib64/
--- /lib64/rcscripts/
>>> /lib64/rcscripts/ ->
>>> /lib64/rcscripts/ ->
>>> /lib64/rcscripts/
--- /usr/
--- /usr/bin/
>>> /usr/bin/awk -> /bin/gawk-3.1.4
>>> /usr/bin/gawk -> /bin/gawk-3.1.4
Segmentation fault

After trying to compile and getting these Failures a lot of different things
stop working on my computer and I have to reboot to make things right again.

Portage (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.13-mm3 x86_64)
System uname: 2.6.13-mm3 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
CFLAGS="-O3 -march=k8 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=k8 -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="amd64 X aac alsa avi berkdb bitmap-fonts cdparanoia cdr crypt cups curl
directfb dmo dshow dts dvb dvd dvdr dvdread eds emboss encode esd fam fbcon
ffmpeg foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 h264 imagemagick
imlib ipv6 java jpeg junit kde live lzw lzw-tiff mad matroska mozilla mp3 mpeg
mysql mythtv ncurses net network nls nvidia ogg oggvorbis opengl pam pdflib perl
png postgres python qt quicktime readline real rtc samba sdl spell sse3 ssl tcpd
theora tiff transcode truetype truetype-fonts type1-fonts udev usb userlocales
v4l2 vorbis x264 xanim xinerama xml2 xmms xpm xv xvid zlib userland_GNU
kernel_linux elibc_glibc"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-10-24 00:55:47 UTC
Time to check your hardware...

*** This bug has been marked as a duplicate of 20600 ***
Comment 2 Rance Smith 2005-10-24 08:27:35 UTC
How can this be a hardware problem the error happens at the exact same place
every time.  other programs compile just fine.
Comment 3 Rance Smith 2005-10-24 08:33:12 UTC
I'll go ahead and do what I didn't want to do, reinstall.  wow bringing back MS
memories.. :)  I'll let you know if then everything compiles fine.
Comment 4 SpanKY gentoo-dev 2005-10-24 18:06:22 UTC
because you said as soon as you reboot, everything starts working again

that implies either hardware or kernel
Comment 5 Rance Smith 2005-10-25 17:05:03 UTC
sorry that isn't what I meant.  I meant after attempting to compile and it has a
segmentation fault other parts of the system start to not work correctly.  when
I reboot that is fixed.  but I am still unable to install these packages.  when
I try again they fail in the same place.
Comment 6 SpanKY gentoo-dev 2005-10-25 17:17:12 UTC
remove /lib/* and run ldconfig

then make sure you have the latest version of gcc-config
Comment 7 Rance Smith 2005-10-25 17:24:36 UTC
I didn't find that lib in /lib I did a find and here is where it is:

yours lib # find / -name*

I ran ldconfig  I'll try to compile one of the failing programs again  I seem to
have the latest version of gcc-config.  I did an emerge sync about 3 days ago.  

*  sys-devel/gcc-config
      Latest version available: 1.3.12-r2
      Latest version installed: 1.3.12-r2

yours ~ # gcc-config -l
 [1] x86_64-pc-linux-gnu-3.4.4 *
 [2] x86_64-pc-linux-gnu-3.4.4-hardened
 [3] x86_64-pc-linux-gnu-3.4.4-hardenednopie
 [4] x86_64-pc-linux-gnu-3.4.4-hardenednopiessp
 [5] x86_64-pc-linux-gnu-3.4.4-hardenednossp
Comment 8 Rance Smith 2005-10-25 17:32:27 UTC
Just tried to compile gawk and I've got a failure again.
Comment 9 Rance Smith 2005-11-10 18:00:07 UTC
I've played with my system for a while now.  I was planning on just reinstalling
gentoo, but I didn't end up doing that.  

First I booted to a live CD that supported Reiser4, which is what my root FS is.
 Then I tried to mount the FS, and it said that the FS had problems and needed
to be check, I didn't check it and rebooted my computer and everything came up
fine with no complaints about a dirty FS.  so I booted back to the CD.  and it
still complained I ended up having to run the fsck.reiser4 with the --build-fs
option to clean the FS.  

So I thought this might have been the source of my problem so I booted back into
my system and was still unable to compile the software.  I booted back to the CD
and had to run the same fsck again so it would mount the FS.  I then booted into
the old system and back to the cd and it messed up the file system again without
doing anything.  thought that was kinda odd.  So I though Hey I'm running
2.6.13-mm? and 2.6.14 is out maybe there was a bug.  so I did with the latest mm
patch for Reiser4.  On side note I was able to compile Gawk from a change root
shell from booting from the CD.  So after upgrading the kernel I still had
issues and actually my system ended up locking for an unknown reason.  

So now I've downgraded to 2.6.11 which is what the liveCD had and everything is
running perfectly I was able to completely update my system without any errors.
 I'm not sure what I should do next.  I imagine try to find the Bug site for
Reiser4 ?? maybe but my other systems which are 32 bit instead of AMD 64 like
this one work fine with the 2.6.13 kernel.  Any direction you could give me
would be great thanks.
Comment 10 SpanKY gentoo-dev 2005-11-10 18:18:10 UTC
reiser4 is not supported