Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77944 - emerge xorg-x11 fails with SegFault (program as)
Summary: emerge xorg-x11 fails with SegFault (program as)
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-14 00:31 UTC by Jeff Turley
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
End of the compile output. Includes initial error. (segfault.txt,2.26 KB, text/plain)
2005-01-14 00:32 UTC, Jeff Turley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Turley 2005-01-14 00:31:48 UTC
When I try to emerge xorg, gcc sends a Segmentation fault error.  This has happened repeatedly.

Reproducible: Always
Steps to Reproduce:
1. emerge xorg-x11

Actual Results:  
Compile failed with Sementation Fault in (program as)

Expected Results:  
Finish compiling without errors, install xorg

emerge info:
Portage 2.0.51-r2 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.4.20040808-r1,
2.4.28-gentoo-r5 i686)
=================================================================
System uname: 2.4.28-gentoo-r5 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.14.90.0.8-r1
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://mirror.usu.edu/mirrors/gentoo
ftp://cudlug.cudenver.edu/pub/mirrors/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups dvd encode f77
font-server foomaticdb fortran gdbm gif gpm gtk2 imlib ipv6 jpeg kde libg++
libwww mad mikmod motif mpeg ncurses nls oggvorbis opengl oss pam pdflib perl
png python qt quicktime readline sdl spell ssl svga tcpd truetype truetype-fonts
type1-fonts x86 xml2 xmms xv zlib"
Comment 1 Jeff Turley 2005-01-14 00:32:36 UTC
Created attachment 48440 [details]
End of the compile output.  Includes initial error.
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-14 03:59:28 UTC
Jeff: Internal compiler errors are in most cases a sign of broken hardware (bad ram, overheating box etc.)
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-14 08:19:18 UTC
Jeff: Please try to reproduce, and see whether it happens at the exact same place.
Comment 4 Jeff Turley 2005-01-14 12:11:11 UTC
Dang, sorry guys.  It was reproducible last night, but after rebooting today the errors are all over the place.  Looks like its that hardware issue.
Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-14 14:05:41 UTC
Thanks for checking.

*** This bug has been marked as a duplicate of 20600 ***