Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 603494 - sys-devel/llvm-3.9.1 with sys-devel/gcc-4.9.4 - lib/Transforms/InstCombine/InstCombineCompares.cpp:2371:1: (segmentation fault)
Summary: sys-devel/llvm-3.9.1 with sys-devel/gcc-4.9.4 - lib/Transforms/InstCombine/In...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-22 19:41 UTC by acidhell
Modified: 2017-02-17 19:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-devel:llvm-3.9.1:20161222-192359.log.zip (sys-devel:llvm-3.9.1:20161222-192359.log.zip,47.54 KB, application/x-zip-compressed)
2016-12-22 19:55 UTC, acidhell
Details
emerge --info (emerge.info,5.92 KB, text/plain)
2016-12-22 19:56 UTC, acidhell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description acidhell 2016-12-22 19:41:14 UTC
sys-devel/llvm-3.9.1 fails to emerge

Reproducible: Always

Steps to Reproduce:
1. emerge =sys-devel/llvm-3.9.1
Comment 1 acidhell 2016-12-22 19:55:32 UTC
Created attachment 457140 [details]
sys-devel:llvm-3.9.1:20161222-192359.log.zip
Comment 2 acidhell 2016-12-22 19:56:48 UTC
Created attachment 457142 [details]
emerge --info
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2016-12-22 20:07:29 UTC
This may be a local problem...

FAILED: lib/Transforms/InstCombine/CMakeFiles/LLVMInstCombine.dir/InstCombineCompares.cpp.o 
/usr/bin/x86_64-pc-linux-gnu-g++ -m32 -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -Ilib/Transforms/InstCombine -I/var/tmp/portage/sys-devel/llvm-3.9.1/work/llvm-3.9.1.src/lib/Transforms/InstCombine -Iinclude -I/var/tmp/portage/sys-devel/llvm-3.9.1/work/llvm-3.9.1.src/include  -DNDEBUG -march=native -Ofast -mvzeroupper -pipe -fPIC -fvisibility-inlines-hidden -Wall -W -Wno-unused-parameter -Wwrite-strings -Wcast-qual -Wno-missing-field-initializers -pedantic -Wno-long-long -Wno-maybe-uninitialized -Wdelete-non-virtual-dtor -Wno-comment -Werror=date-time -std=c++11 -ffunction-sections -fdata-sections -fPIC -MD -MT lib/Transforms/InstCombine/CMakeFiles/LLVMInstCombine.dir/InstCombineCompares.cpp.o -MF lib/Transforms/InstCombine/CMakeFiles/LLVMInstCombine.dir/InstCombineCompares.cpp.o.d -o lib/Transforms/InstCombine/CMakeFiles/LLVMInstCombine.dir/InstCombineCompares.cpp.o -c /var/tmp/portage/sys-devel/llvm-3.9.1/work/llvm-3.9.1.src/lib/Transforms/InstCombine/InstCombineCompares.cpp
/var/tmp/portage/sys-devel/llvm-3.9.1/work/llvm-3.9.1.src/lib/Transforms/InstCombine/InstCombineCompares.cpp: In member function ‘llvm::Instruction* llvm::InstCombiner::visitICmpInstWithInstAndIntCst(llvm::ICmpInst&, llvm::Instruction*, llvm::ConstantInt*)’:
/var/tmp/portage/sys-devel/llvm-3.9.1/work/llvm-3.9.1.src/lib/Transforms/InstCombine/InstCombineCompares.cpp:2371:1: εσωτεÏικό σφάλμα μεταγλωττιστή: Σφάλμα κατάτμησης (segmentation fault)
 }
 ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2016-12-22 20:16:43 UTC
Looks like segfault in GCC.
Comment 5 Mark Nowiasz 2016-12-30 20:19:59 UTC
Got a different segfault:

/var/tmp/portage/sys-devel/llvm-3.9.1/work/llvm-3.9.1.src/lib/Target/X86/X86MCInstLower.cpp:1686:1: internal compiler error: Segmentation fault

(gcc 5.4.0)
Comment 6 Mark Nowiasz 2016-12-31 12:01:12 UTC
Cancel my last comment: I found one of my 4 memory modules to be faulty, thus causing the segmentation fault.
Comment 7 SpanKY gentoo-dev 2017-02-17 19:04:55 UTC

*** This bug has been marked as a duplicate of bug 20600 ***