Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 155110 - gcc-4.1.1 randomly segfaults when compiling mozilla-firefox-2.0
Summary: gcc-4.1.1 randomly segfaults when compiling mozilla-firefox-2.0
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-11-14 01:37 UTC by Christoph Peltz
Modified: 2007-01-14 10:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Peltz 2006-11-14 01:37:45 UTC
Hi there,

during my "emerge gnome fluxbox ..." portage tried to compile mozilla-firefox 2.0, but at random positions during the compilation cc1plus, ergo the gcc segfaults ( with the message, that that is a non reproduceable bug and that it's a OS or Hardwareproblem ). This segault triggerd during my test yesterday and today two Kernel panics and four Kernel oops.
Currently I am trying to remerge the whole system and if that doesn't work I'll try an older gcc. I know that it is stated that it could be a hardware-problem, but I do not have a single clue where to start about hardware-problems.
Maybe someone can help me with this.

Christoph Peltz

Portage 2.1.2_rc1-r6 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r2 i686)
System uname: 2.6.18-gentoo-r2 i686 Intel(R) Core(TM)2 CPU          6400  @ 2.13GHz
Gentoo Base System version 1.12.1
Last Sync: Mon, 13 Nov 2006 09:30:01 +0000
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
CFLAGS="-O2 -march=prescott -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="de en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="x86 3dnow 3dnowext 7zip X a52 aac aalib alsa bash-completion beagle berkdb bitmap-fonts bzip2 cairo cddb cdinstall cdparanoia cdr colordiff cracklib crypt cscope cups dbus depth32 dlloader dri dvd dvdr dvdread dvi ecc elibc_glibc encode escreen esd exif fam ffmpeg firefox flac fortran ftp gcj gdbm ggi gif glut gnome gnutls gpm graphviz gs gstreamer gtk gtk2 hal iconv icq idn image imagemagick imap imlib input_devices_keyboard input_devices_mouse ipv6 jabber jack java jpeg jpeg2k kernel_linux libg++ linguas_de linguas_en_GB lm_sensors lzo lzw mad matroska mime mixer mjpeg mmap mmx mmxext mng moznocompose moznoirc moznomail moznoroaming mozsvg mp3 mp4live mpeg mpeg2 mplayer nautilus ncurses nfs nls nptl nptlonly objc objc++ objc-gc ogg openal opengl openssl pam pcre pdf perl player png ppds pppd python quicktime readline real realmedia recode reflection ruby samba sdl session snmp sockets socks5 spl sse sse2 ssl svg svga sysfs syslog tcpd tetex tga theora threads tiff tk transcode truetype-fonts type1-fonts udev unicode userland_GNU vcd video_cards_nvidia vim-syntax vorbis win32codecs wmp wxwindows xchattext xine xml xorg xosd xv xvid zlib"
Comment 1 ebfe 2006-11-14 04:19:13 UTC
sounds more like a hardware, probably memory issue. use memtest86
Comment 2 Christoph Peltz 2006-11-14 05:02:09 UTC

I have run memtest completly through and it claims, that the memory is okay. I have also tried it with a different mozilla-firefox version but it is the same, but only when compiling firefox, every other Package ( I have done a full 'emerge -e system' ) works just fine. I also enabled kernel-debugging but I do not get useful results ( mostly no messages at all just that the compiler segfaultet ). I think I will try to emerge mozilla or seamonkey an observ if these have the same problem, if yes I think I will disable SMP and/or multiple cores in the kernel ( although this features shouldn't be the problem ).

Christoph Peltz
Comment 3 Christoph Peltz 2006-11-14 10:05:15 UTC
After disabling the flags objc, objc++ and objc-gc I could successfully emerge gcc-3.4.6 and with this I could emerge mozilla-firefox-2.0.
After this I tried to recompile gcc-4.1.1 with -objc -objc++ -objc-gc and to remerge firefox an I got this message:

------------[ cut here ]------------
kernel BUG at mm/rmap.c:522!
invalid opcode: 0000 [#1]
Modules linked in: snd_hda_intel snd_hda_codec snd_pcm snd_page_alloc via_agp agpgart
CPU:    1
EIP:    0060:[<c0149e83>]    Not tainted VLI
EFLAGS: 00010286    (2.6.18-gentoo-r2 #8)
EIP is at page_remove_rmap+0x27/0x31
eax: ffffffff    ebx: f4b527c4    ecx: c11fe5a0    edx: 00000001
esi: c11fe5a0    edi: 40df1000    edp: 00000020    esp: d92cbdf0
ds: 007b    es: 007b    ss: 0068
Process cc1plus (pid: 27054, ti=d92ca999 task=f7707560 task.ti=d92ca000)
Stack: c0144450 00000000 f6d156bc d92cbe5c 00000000 00000001 41000000 f2d9a40c
       f7b3d580 c180e420 ffffff77 ffffffff f7b3d5c4 f2d9a40c 418ddfff 00376000
       418de000 00000000 d92cbe5c f75dae9c f7b3d580 d92cbf14 c0147039 ffffffff
Call Trace:
 [<c0144450>] unmap_vmas+0x28b/0x52f
 [<c0147039>] exit_mmap+0x7c/0xf4
 [<c0117df3>] mmput+0x25/0x84
 [<c011cbc4>] do_exit+0xf0/0x88e
 [<c011d38a>] do_group_exit+0x28/0x77
 [<c01255f8>] get_signal_to_deliver+0x28c/0x3e9
 [<c0111cdd>] do_page_fault+0x0/0x574
 [<c01021f5>] do_notify_resume+0x74/0x6b0
 [<c0111b61>] force_sig_info_fault+0x24/0x28
 [<c02b4276>] tty_ldisc_deref+0x46/0x6f
 [<c02b60b4>] tty_write+0x18b/0x1d0
 [<c0154e4f>] vfs_write+0x104/0x169
 [<c0111fb3>] do_page_fault+0x2d6/0x574
 [<c0111cdd>] do_page_fault+0x0/0x574
 [<c0102c4a>] work_notifysig+0x13/0x19
Code: 72 ff ff ff 89 ca f0 83 40 08 ff 0f 98 c0 84 c0 75 01 c3 8b 41 08 83 c0 01
 78 10 8b 51 10 83 f2 01 83 e2 01 89 c8 e9 73 89 ff ff <0f> 0b 0a 02 a2 87 43 c0 
 eb e6 55 57 56 53 83 ec 10 89 c5 89 d6
EIP: [<c0149e83>] page_remove_rmap+0x27/0x31 SS:ESP 0068:d92cbdf0
 <1>Fixing recursive fault but reboot is needed!

Someone got an idea? Maybe its the kernel HighMem support? (1024 MB System RAM, 2048 MB SWAP, Kernel Memory support up to 4 GB enabled)
Comment 4 SpanKY gentoo-dev 2006-11-14 11:38:00 UTC
your kernel or hardware sucks -> not a userspace/gcc problem
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-11-14 11:58:29 UTC

*** This bug has been marked as a duplicate of 20600 ***
Comment 6 Christoph Peltz 2007-01-14 10:31:12 UTC
I got it solved for me. I switched from a x86 profile to a amd64 (new install) and changed the gcc-flags to "-O2 -march=nocona -pipe".