Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385335 - www-client/firefox-7.0.1 : error compile
Summary: www-client/firefox-7.0.1 : error compile
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-02 08:57 UTC by Vicente Olivert Riera (RETIRED)
Modified: 2011-10-02 18:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge_info.txt,4.36 KB, text/plain)
2011-10-02 08:58 UTC, Vicente Olivert Riera (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vicente Olivert Riera (RETIRED) gentoo-dev 2011-10-02 08:57:58 UTC
www-client/firefox-7.0.1 fails to compile. I get this error:

collect2: ld terminated with signal 9 [Killed]
make[5]: *** [libxul.so] Error 1

* The specific snippet of code:
*           CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" MOZ_MAKE_FLAGS="${MAKEOPTS}" emake -f client.mk || die "emake failed";

Reproducible: Always

Steps to Reproduce:
1. emerge =www-client/firefox-7.0.1
Comment 1 Vicente Olivert Riera (RETIRED) gentoo-dev 2011-10-02 08:58:35 UTC
Created attachment 288521 [details]
emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2011-10-02 09:27:51 UTC
It needs 3.5gb to link, have you tried in a more large PORTAGE_TMPDIR?
Comment 3 Vicente Olivert Riera (RETIRED) gentoo-dev 2011-10-02 09:33:56 UTC
(In reply to comment #2)
> It needs 3.5gb to link, have you tried in a more large PORTAGE_TMPDIR?

My PORTAGE_TMPDIR is in the same partition as / , so I have 350GB free.
Comment 4 Francisco Blas Izquierdo Riera gentoo-dev 2011-10-02 14:32:52 UTC
How much RAM (including swap) is available? Mind sharing the dmesg output after the failure? Are there any resource limits for the portage user?

If you see an Out of Memory warning then:
Remove pipe from CFLAGS and CXXFLAGS and use MAKEOPTS=-j1 to reduce the memory strain although it will mean longer compilation times.
Comment 5 Vicente Olivert Riera (RETIRED) gentoo-dev 2011-10-02 16:19:01 UTC
(In reply to comment #4)
> How much RAM (including swap) is available? Mind sharing the dmesg output after
> the failure? Are there any resource limits for the portage user?
> 
> If you see an Out of Memory warning then:
> Remove pipe from CFLAGS and CXXFLAGS and use MAKEOPTS=-j1 to reduce the memory
> strain although it will mean longer compilation times.

I have 2GB of ram and no swap. The portage user is root.
I have this in the dmesg output:

[92454.289835] Out of memory: Kill process 30155 (ld) score 563 or sacrifice child

I'm going to try removing pipe and changing MAKEOPTS to -j1. Thanks.
Comment 6 Jory A. Pratt gentoo-dev 2011-10-02 16:19:56 UTC
You need to provide the build.log, it is impossible to track down why the failure is occuring without it.
Comment 7 SpanKY gentoo-dev 2011-10-02 18:30:35 UTC
nothing ebuilds can really do about OOM

*** This bug has been marked as a duplicate of bug 20600 ***