Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217320 - emerge dev-libs/libxml fails : tried re-emerging it however it fails over and over again.
Summary: emerge dev-libs/libxml fails : tried re-emerging it however it fails over and...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
: 217321 (view as bug list)
Depends on:
Reported: 2008-04-11 17:49 UTC by amit singh
Modified: 2008-04-12 13:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description amit singh 2008-04-11 17:49:03 UTC
>>> Unpacking source...
>>> Unpacking libxml-1.8.17.tar.gz to /var/tmp/portage/dev-libs/libxml-1.8.17-r2/work
  [32;01m* [0m Applying configure-LANG.patch ...
 [A [72C   [34;01m[  [32;01mok [34;01m ] [0m
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-libs/libxml-1.8.17-r2/work/libxml-1.8.17 ...
 * econf: updating libxml-1.8.17/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating libxml-1.8.17/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
creating cache ./config.cache
checking for a BSD compatible install... /bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -march=i686 -pipe  -lncurses) works... yes
checking whether the C compiler (gcc -O2 -march=i686 -pipe  -lncurses) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /bin/install -c
checking how to run the C preprocessor... gcc -E
checking for rm... /bin/rm
checking for mv... /bin/mv
checking for tar... /bin/tar
checking for Cygwin environment... no
checking for mingw32 environment... no
checking host system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for ld used by GCC... /usr/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for /usr/i686-pc-linux-gnu/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependant libraries... pass_all
checking for object suffix... o
checking for executable suffix... no
checking command to parse /usr/bin/nm -B output... ok
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux
checking if libtool supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking whether to enable maintainer-specific portions of Makefiles... no
checking for zlib.h... yes
checking for gzread in -lz... yes
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for ANSI C header files... yes
checking for fcntl.h... yes
checking for unistd.h... yes
checking for ctype.h... yes
checking for dirent.h... yes
checking for errno.h... yes
checking for malloc.h... yes
checking for stdarg.h... yes
checking for sys/stat.h... yes
checking for sys/types.h... yes
checking for time.h... yes
checking for ieeefp.h... no
checking for nan.h... no
checking for math.h... yes
checking for fp_class.h... no
checking for float.h... yes
checking for stdlib.h... yes
checking for sys/socket.h... yes
checking for netinet/in.h... yes
checking for arpa/inet.h... yes
checking for netdb.h... yes
checking for sys/time.h... yes
checking for sys/select.h... yes
checking for strftime... yes
checking for strdup... yes
checking for strndup... yes
checking for strerror... yes
checking for snprintf... yes
checking for finite... yes
checking for isnand... no
checking for fp_class... no
checking for class... no
checking for fpclass... no
checking for strftime... (cached) yes
checking for localtime... yes
checking for gethostent... yes
checking for setsockopt... yes
checking for connect... yes
checking for isnan... yes
checking for isinf... yes
checking host system type... i686-pc-linux-gnu
checking for append_history in -lhistory... yes
checking for main in -ltermcap... no
checking for readline in -lreadline... yes
updating cache ./config.cache
creating ./config.status
creating libxml.spec
creating Makefile
creating doc/Makefile
creating example/Makefile
sed: can't read ./example/ No such file or directory
creating xml-config
creating win32config.h
creating libxml.pc
creating config.h
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/dev-libs/libxml-1.8.17-r2/work/libxml-1.8.17'
Making all in doc
make[2]: Entering directory `/var/tmp/portage/dev-libs/libxml-1.8.17-r2/work/libxml-1.8.17/doc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/dev-libs/libxml-1.8.17-r2/work/libxml-1.8.17/doc'
make[2]: Entering directory `/var/tmp/portage/dev-libs/libxml-1.8.17-r2/work/libxml-1.8.17'
/bin/rm -f ./libxml
ln -s ./. ./libxml
/bin/sh ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. -I.   -DLIBXML_VERSION=\"1.8.17\"    -O2 -march=i686 -pipe -Wall -c SAX.c
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -DLIBXML_VERSION=\"1.8.17\" -O2 -march=i686 -pipe -Wall -c SAX.c  -fPIC -DPIC -o .libs/SAX.lo
SAX.c: In function 'attribute':
SAX.c:812: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [SAX.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-libs/libxml-1.8.17-r2/work/libxml-1.8.17'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/libxml-1.8.17-r2/work/libxml-1.8.17'
make: *** [all-recursive-am] Error 2
  [31;01m* [0m 
  [31;01m* [0m ERROR: dev-libs/libxml-1.8.17-r2 failed.
  [31;01m* [0m Call stack:
  [31;01m* [0m     , line   49:  Called src_compile
  [31;01m* [0m             environment, line 2330:  Called die
  [31;01m* [0m The specific snippet of code:
  [31;01m* [0m       emake -j1 || die
  [31;01m* [0m  The die message:
  [31;01m* [0m   (no error message)
  [31;01m* [0m 
  [31;01m* [0m If you need support, post the topmost build error, and the call stack if relevant.
  [31;01m* [0m A complete build log is located at '/var/tmp/portage/dev-libs/libxml-1.8.17-r2/temp/build.log'.
  [31;01m* [0m The ebuild environment file is located at '/var/tmp/portage/dev-libs/libxml-1.8.17-r2/temp/environment'.
  [31;01m* [0m 

Reproducible: Always

Steps to Reproduce:

Actual Results:  
please help me with a workaround.
Comment 1 amit singh 2008-04-11 18:12:41 UTC
emerge --info

Portage (default-linux/x86/2007.0, gcc-4.1.1, glibc-2.5-r0,
2.6.21-gentoo-r4 i686)
System uname: 2.6.21-gentoo-r4 i686 Intel(R) Pentium(R) 4 CPU 1.60GHz
Timestamp of tree: Fri, 04 Apr 2008 12:03:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf
/etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
/etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --stats --timeout=180 --exclude=/distfiles
--exclude=/local --exclude=/packages"
USE="acl alsa berkdb cdr cli cracklib crypt cups dbus dri dvd fortran gdbm gpm
gtk hal iconv ipv6 isdnlog kde mad midi mudflap ncurses nls nptl nptlonly
opengl openmp pam pcre perl pppd python qt3 qt4 readline reflection session spl
ssl tcpd truetype type1 unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000
atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938
es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx
via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop
empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi
null plug rate route share shm softvol" APACHE2_MODULES="actions alias
auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache
dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache
filter headers include info log_config logio mem_cache mime mime_magic
negotiation rewrite setenvif speling status unique_id userdir usertrack
vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses

Comment 2 Ingmar Vanhassel (RETIRED) gentoo-dev 2008-04-11 18:24:07 UTC
*** Bug 217321 has been marked as a duplicate of this bug. ***
Comment 3 Mark Loeser (RETIRED) gentoo-dev 2008-04-12 13:12:49 UTC
All of your failures are hardware related.  Please run memtest86+ and make sure you don't have any errors.  

*** This bug has been marked as a duplicate of bug 20600 ***