Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 147510 - emerge rt2400 fails
Summary: emerge rt2400 fails
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-13 15:30 UTC by Bartosz Krzeszewski
Modified: 2006-09-14 05:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Krzeszewski 2006-09-13 15:30:20 UTC
# emerge rt2400
Calculating dependencies... done!
>>> Emerging (1 of 1) net-wireless/rt2400-1.2.2_beta3 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking rt2400-1.2.2-b3.tar.gz ;-)
 * This profile has not been tested thoroughly and is not considered to be
 * a supported server profile at this time.  For a supported server
 * profile, please check the Hardened project (http://hardened.gentoo.org).

 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     2.6.16-gentoo-r7
 * Checking for suitable kernel configuration options...                                                                            [ ok ]
>>> Unpacking source...
>>> Unpacking rt2400-1.2.2-b3.tar.gz to /var/tmp/portage/rt2400-1.2.2_beta3/work
 * Applying rt2400-1.2.3_beta3-2.6.17.patch ...                                                                                     [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/rt2400-1.2.2_beta3/work/rt2400-1.2.2-b3 ...
 * Preparing rt2400 module
make: Entering directory `/usr/src/linux-2.6.16-gentoo-r7'
  CC [M]  /var/tmp/portage/rt2400-1.2.2_beta3/work/rt2400-1.2.2-b3/Module/rtmp_main.o
i686-pc-linux-gnu-gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <URL:http://bugs.gentoo.org/> for instructions.
make[1]: *** [/var/tmp/portage/rt2400-1.2.2_beta3/work/rt2400-1.2.2-b3/Module/rtmp_main.o] Error 1
make: *** [_module_/var/tmp/portage/rt2400-1.2.2_beta3/work/rt2400-1.2.2-b3/Module] Error 2
make: Leaving directory `/usr/src/linux-2.6.16-gentoo-r7'

!!! ERROR: net-wireless/rt2400-1.2.2_beta3 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  rt2400-1.2.2_beta3.ebuild, line 48:   Called linux-mod_src_compile
  linux-mod.eclass, line 469:   Called die

!!! Unable to make  -C /usr/src/linux M=/var/tmp/portage/rt2400-1.2.2_beta3/work/rt2400-1.2.2-b3/Module modules.
!!! If you need support, post the topmost build error, and the call stack if relevant.

# emerge --info
Portage 2.1-r1 (default-linux/x86/2006.1/server, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-gentoo-r4 i686)
=================================================================
System uname: 2.6.17-gentoo-r4 i686 Pentium II (Klamath)
Gentoo Base System version 1.6.15
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium2 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -march=pentium2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl http://gentoo.inode.at/ http://gentoo.mirror.icd.hu/"
LINGUAS="pl"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 apache2 berkdb bitmap-fonts cli crypt dlloader dri fortran gdbm ipv6 isdnlog java ldap libg++ logrotate madwifi mailwrapper mmx mysql ncurses nls nptl nptlonly openntpd pam pcre perl ppds pppd python readline reflection session slang snmp spell spl ssl sysfs tcpd truetype truetype-fonts type1-fonts udev unicode userlocales xml xorg zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux linguas_pl userland_GNU video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-09-13 23:37:28 UTC
Looks like you did run out of memory...

*** This bug has been marked as a duplicate of 20600 ***
Comment 2 Bartosz Krzeszewski 2006-09-14 05:44:22 UTC
(In reply to comment #1)
> Looks like you did run out of memory...
> 
> *** This bug has been marked as a duplicate of 20600 ***
> 

thx,I tryed on another machine and it compiled without problem