Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 322565 - [ICE] sys-devel/gcc-4.4.3-r2: verify_ssa failed
Summary: [ICE] sys-devel/gcc-4.4.3-r2: verify_ssa failed
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 322573 322577 322603 322605 322619 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-03 10:35 UTC by antonis
Modified: 2010-06-13 02:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.tar.gz,76.92 KB, application/octet-stream)
2010-06-03 22:36 UTC, antonis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description antonis 2010-06-03 10:35:46 UTC
make[5]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/build/x86_64-pc-linux-gnu/32/libgcc'
make[4]: *** [multi-do] Error 1
make[4]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/build/x86_64-pc-linux-gnu/libgcc'
make[3]: *** [all-multi] Error 2
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/build/x86_64-pc-linux-gnu/libgcc'
make[2]: *** [all-stage2-target-libgcc] Error 2
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/build'
make[1]: *** [stage2-bubble] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/build'
make: *** [bootstrap-lean] Error 2
 * ERROR: sys-devel/gcc-4.4.3-r2 failed:
 *   emake failed with bootstrap-lean
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 5163:  Called toolchain_src_compile
 *   environment, line 5758:  Called gcc_src_compile
 *   environment, line 3321:  Called gcc_do_make
 *   environment, line 3111:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
 * 
 * If you need support, post the output of 'emerge --info =sys-devel/gcc-4.4.3-r2',
 * the complete build log and the output of 'emerge -pqv =sys-devel/gcc-4.4.3-r2'.
 * The complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.4.3-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.4.3-r2/temp/environment'.
 * S: '/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/build'

>>> Failed to emerge sys-devel/gcc-4.4.3-r2, Log file:

>>>  '/var/tmp/portage/sys-devel/gcc-4.4.3-r2/temp/build.log'

 * Messages for package sys-devel/gcc-4.4.3-r2:

 * ERROR: sys-devel/gcc-4.4.3-r2 failed:
 *   emake failed with bootstrap-lean
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 5163:  Called toolchain_src_compile
 *   environment, line 5758:  Called gcc_src_compile
 *   environment, line 3321:  Called gcc_do_make
 *   environment, line 3111:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
 * 
 * If you need support, post the output of 'emerge --info =sys-devel/gcc-4.4.3-r2',
 * the complete build log and the output of 'emerge -pqv =sys-devel/gcc-4.4.3-r2'.
 * The complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.4.3-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.4.3-r2/temp/environment'.


Reproducible: Always




emerge -pqv =sys-devel/gcc-4.4.3-r2
[ebuild  NS   ] sys-devel/gcc-4.4.3-r2 [4.3.4] USE="fortran gtk mudflap (multilib) nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -gcj -graphite (-hardened) (-libffi) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla"                       




emerge --info =sys-devel/gcc-4.4.3-r2
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop/kde, gcc-4.3.4, glibc-2.10.1-r1, 2.6.33-gentoo-r1 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.33-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6700_@_2.66GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 03 Jun 2010 00:00:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.5.4-r4, 2.6.4-r1, 3.1.2-r3
dev-python/pycrypto: 2.1.0_beta1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildpkg candy distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="el_GR.utf8"
LC_ALL="el_GR.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en el"
MAKEOPTS="-j6 -l8"
PKGDIR="/usr/portage/packages/nocona"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/gnome /usr/local/portage/layman/roslin /usr/local/portage/layman/rion /usr/portage-local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 64bit 7zip X X509 a52 aac aalib acct acl acpi alsa amd64 amr amuled apache2 arts asf audiofile avi beagle berkdb bidi bl blas bluetooth branding bzip2 cairo cdda cddb cdio cdparanoia cdr chm cli consolekit cpudetection cracklib crypt cups curl cvs cxx dbus djvu dmx dnd dri dts dv dvb dvd dvdnav dvdr dvdread dvi edl emboss encode esd evo exif expat extrafilters extras fam ffmpeg firefox flac foomaticdb fortran freetype freetype2 gdbm ggi gif gimp gimpprint glib glitz gnome gnutls gphoto gphoto2 gpm graphviz gstreamer gtk gtk2 gtkhtml h264 hal hddtemp hdf5 hpn ice1712 iconv idn ieee1394 imagemagick imlib ipv6 ithreads jabber jack jadetex java joystick jpeg jpeg2k kde kdrive keyring kipi lame lcms libcaca libnotify libsamplerate live lm_sensors lua lzo mad matroska melt mikmod mime mjpeg mmap mmx mmx2 mmxext mng mod modplug modules motif mozcalendar mozsvg mp2 mp3 mp4 mpeg mpi mplayer msn mudflap multilib nas ncurses network networkmanager nfs nls nntp nodrm nptl nptlonly nss nvidia ogg oggvorbis opengl openmp pam pango pch pcre pdf perl plotutils png policykit ppds pppd python qt qt3 qt3support qt4 quicktime quotas radio rar readline reflection remote rtc ruby samba scanner screen sdl sensord session shout silc slang smp sndfile snmp sound speex spell spl srt sse sse2 sse3 ssl ssse3 startup-notification stats stream subtitles subversion svg sysfs tcltk tcpd tetex tga theora threads threadsafe tiff timidity truetype ucs2 unicode usb userlocales v4l v4l2 vcd vdpau vorbis widescreen winbind wma wmf wxgtk1 x264 xanim xcb xml xml2 xorg xpm xprint xscreensaver xulrunner xv xvid xvmc yahoo yv12 zlib" ALSA_CARDS="snd-ice1712" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en el" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Samuli Suominen gentoo-dev 2010-06-03 11:22:57 UTC
*** Bug 322573 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen gentoo-dev 2010-06-03 11:29:08 UTC
*** Bug 322577 has been marked as a duplicate of this bug. ***
Comment 3 Samuli Suominen gentoo-dev 2010-06-03 11:43:22 UTC
You need to attach build.log here (or because the file might be too big to attach, upload it somewhere and post link here).  That's because it's not clear from Comment #0 what went wrong, the real error is above all that.
Comment 4 Samuli Suominen gentoo-dev 2010-06-03 13:56:56 UTC
*** Bug 322603 has been marked as a duplicate of this bug. ***
Comment 5 Samuli Suominen gentoo-dev 2010-06-03 14:54:10 UTC
*** Bug 322605 has been marked as a duplicate of this bug. ***
Comment 6 Samuli Suominen gentoo-dev 2010-06-03 14:54:15 UTC
*** Bug 322619 has been marked as a duplicate of this bug. ***
Comment 7 antonis 2010-06-03 15:11:28 UTC
(In reply to comment #3)
> You need to attach build.log here (or because the file might be too big to
> attach, upload it somewhere and post link here).  That's because it's not clear
> from Comment #0 what went wrong, the real error is above all that.
> 

somw additional infos

/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/gcc-4.4.3/gcc/ira-conflicts.c: In function ‘print_hard_reg_set’:
/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/gcc-4.4.3/gcc/ira-conflicts.c:667: warning: format not a string literal and no format arguments
/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/gcc-4.4.3/gcc/ira-build.c: In function ‘create_insn_allocnos’:
/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/gcc-4.4.3/gcc/ira-build.c:1421: error: missing definition
for SSA_NAME: flag_branch_probabilities_157 in statement:
flag_branch_probabilities_76 = PHI <flag_branch_probabilities_146(D)(4), flag_branch_probabilities_157(5)>
PHI argument
flag_branch_probabilities_157
for PHI node
flag_branch_probabilities_76 = PHI <flag_branch_probabilities_146(D)(4), flag_branch_probabilities_157(5)>
/var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/gcc-4.4.3/gcc/ira-build.c:1421: internal compiler error: verify_ssa failed
Please submit a full bug report,

there is my build log
http://www.2shared.com/file/_a299rsF/build.html?
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2010-06-03 22:24:32 UTC
compress it and attach it here please.
Comment 9 antonis 2010-06-03 22:36:03 UTC
Created attachment 234045 [details]
build.log
Comment 10 antonis 2010-06-05 14:59:23 UTC
(In reply to comment #8)
> compress it and attach it here please.
> 
any help?it is important..
Comment 11 SpanKY gentoo-dev 2010-06-05 19:48:15 UTC
everybody's bug is important to them
Comment 12 antonis 2010-06-05 20:16:56 UTC
(In reply to comment #11)
> everybody's bug is important to them
> 

of course but i am a step near to system ctash
we talk about gcc....not for an application..
Comment 13 antonis 2010-06-07 22:02:30 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > everybody's bug is important to them
> > 
> 
> of course but i am a step near to system ctash
> we talk about gcc....not for an application..
> 
 now with the command 
emerge --ask --update --deep --newuse world
gentoo wants to install all the 4,3,5 kde components...why?is thiss another bug?
i have 4.4.2
before that i gave eix-sync and eix-remote update
Comment 14 SpanKY gentoo-dev 2010-06-07 22:46:10 UTC
if you dont know how deps work, ask in the forums/mailing lists/irc.  bugzilla is not a support forum for questions.
Comment 15 SpanKY gentoo-dev 2010-06-10 03:20:30 UTC
does it fail in the same spot every time you try to emerge it ?  how about if you use MAKEOPTS=-j1 ?

the first error you posted does not match the second log
Comment 16 antonis 2010-06-10 11:09:22 UTC
(In reply to comment #15)
> does it fail in the same spot every time you try to emerge it ?  how about if
> you use MAKEOPTS=-j1 ?
> 
> the first error you posted does not match the second log
> 
-j1 ?
i have quad core processor i could use -j1 and after emerging gcc i can change it again with -j6 -l8   ?
Comment 17 Xake 2010-06-10 11:22:18 UTC
(In reply to comment #16)
> i have quad core processor i could use -j1 and after emerging gcc i can change
> it again with -j6 -l8   ?
> 

on your command line type:
MAKEOPTS="-j1" emerge gcc
Comment 18 antonis 2010-06-10 16:31:45 UTC
> on your command line type:
> MAKEOPTS="-j1" emerge gcc
> 

it seems to be right but at the end i took the messages

* The current gcc config appears valid, so it will not be
 * automatically switched for you.      If you would like to
 * switch to the newly installed gcc version, do the
 * following:

 * gcc-config x86_64-pc-linux-gnu-4.4.3
 * source /etc/profile

 * Switching native-compiler to x86_64-pc-linux-gnu-4.3.4 ...
>>> Regenerating /etc/ld.so.cache...                                                                                           [ ok ]

 * If you have issues with packages unable to locate libstdc++.la,
 * then try running 'fix_libtool_files.sh' on the old gcc versions.

>>> Regenerating /etc/ld.so.cache...

>>> Recording sys-devel/gcc in "world" favorites file...

 * Messages for package sys-devel/gcc-4.4.3-r2:

 * If you have issues with packages unable to locate libstdc++.la,
 * then try running 'fix_libtool_files.sh' on the old gcc versions.
Comment 19 Mattias 2010-06-11 10:41:22 UTC
(In reply to comment #18)
> > on your command line type:
> > MAKEOPTS="-j1" emerge gcc
> > 
> 
> it seems to be right but at the end i took the messages

I get the same error, but MAKEOPTS="-j1" emerge gcc doesn't make a difference for me. Having never used bugzilla, I thougt it best to ask a couple of questions: I'm supposed to continue this bug report, right, not file a new one? And do I post my build log and emerge --info right here? Anything else?
Comment 20 Xake 2010-06-11 15:31:26 UTC
(In reply to comment #18)
> > on your command line type:
> > MAKEOPTS="-j1" emerge gcc
> > 
> 
> it seems to be right but at the end i took the messages
> 
> * The current gcc config appears valid, so it will not be
>  * automatically switched for you.      If you would like to
>  * switch to the newly installed gcc version, do the
>  * following:
> 
>  * gcc-config x86_64-pc-linux-gnu-4.4.3
>  * source /etc/profile
> 
>  * Switching native-compiler to x86_64-pc-linux-gnu-4.3.4 ...
> >>> Regenerating /etc/ld.so.cache...                                                                                           [ ok ]
> 
>  * If you have issues with packages unable to locate libstdc++.la,
>  * then try running 'fix_libtool_files.sh' on the old gcc versions.
> 
> >>> Regenerating /etc/ld.so.cache...
> 
> >>> Recording sys-devel/gcc in "world" favorites file...
> 
>  * Messages for package sys-devel/gcc-4.4.3-r2:
> 
>  * If you have issues with packages unable to locate libstdc++.la,
>  * then try running 'fix_libtool_files.sh' on the old gcc versions.
> 

Please read http://www.gentoo.org/doc/en/gcc-upgrading.xml,

Portage keeps  at least one version of each minor release because things sometimes break with new gcc-versions and in those cases you want to be able to switch back to the old version. Because of that and other reasons portage does not try to be smarter then you, and therefore does not switch to the new version but tells you to do it if you want to.
The other message about fix_libtool_files does always appear.
Comment 21 antonis 2010-06-11 18:51:35 UTC
> Please read http://www.gentoo.org/doc/en/gcc-upgrading.xml,
> 
> Portage keeps  at least one version of each minor release because things
> sometimes break with new gcc-versions and in those cases you want to be able to
> switch back to the old version. Because of that and other reasons portage does
> not try to be smarter then you, and therefore does not switch to the new
> version but tells you to do it if you want to.
> The other message about fix_libtool_files does always appear.
> 

thank you mark it as solved please although i can not understand the reason for not compiling new gcc with my makeopts
Comment 22 SpanKY gentoo-dev 2010-06-13 02:47:53 UTC

*** This bug has been marked as a duplicate of bug 20600 ***