Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 356869 - sys-devel/gcc-4.4.5 - {standard input}:145813: Error: suffix or operands invalid for `movq'
Summary: sys-devel/gcc-4.4.5 - {standard input}:145813: Error: suffix or operands inva...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-28 16:06 UTC by Marc Richter
Modified: 2011-03-02 22:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
It's the buildlog from the failing emerge (build.log.bz2,86.83 KB, application/octet-stream)
2011-02-28 21:12 UTC, Marc Richter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Richter 2011-02-28 16:06:40 UTC
sys-devel/gcc-4.4.5 is part of the packets which are built when using "emerge --update --deep --newuse --verbose world". When it comes to this package, it fails:

 * Messages for package sys-devel/gcc-4.4.5:

 * ERROR: sys-devel/gcc-4.4.5 failed:
 *   emake failed with bootstrap-lean
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5008:  Called toolchain_src_compile
 *   environment, line 5603:  Called gcc_src_compile
 *   environment, line 3152:  Called gcc_do_make
 *   environment, line 2934:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
 *
 * If you need support, post the output of 'emerge --info =sys-devel/gcc-4.4.5',
 * the complete build log and the output of 'emerge -pqv =sys-devel/gcc-4.4.5'.
 * The complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.4.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.4.5/temp/environment'.
 * S: '/var/tmp/portage/sys-devel/gcc-4.4.5/work/build'


Reproducible: Always

Steps to Reproduce:
Try using "emerge --update --deep --newuse --verbose world" on amd64
Actual Results:  
 * ERROR: sys-devel/gcc-4.4.5 failed:
 *   emake failed with bootstrap-lean

Expected Results:  
It should compile fine.

jb-gen2-0001 ~ # emerge --info =sys-devel/gcc-4.4.5
Portage 2.1.9.25 (hardened/linux/amd64, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36-jb1 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.36-jb1-x86_64-Intel-R-_Xeon-R-_CPU_L5630_@_2.13GHz-with-gentoo-1.12.14
Timestamp of tree: Mon, 28 Feb 2011 13:45:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.6.6-r2, 3.1.3-r1
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="acl amd64 apache2 bash-completion bcmath berkdb bzip2 cli cracklib crypt ctype cups curl cxx dri exif fam ftp gd-external gdbm gif gnutls gpm gzip hardened hash iconv imap imlib inifile innodb jadetex jpeg jpeg2k justify lame latex libwww lzo maildir mhash mime mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib mysql mysqli ncurses netpbm nls nptl nptlonly ogg openmp pae pam pcre pdf pdo perl php pic plotutils png posix pppd python readline rss sasl session snmp soap sockets sse sse2 ssl subversion suhosin sysfs syslog szip tcpd threads tidy tiff truetype unicode urandom vhosts vim-syntax vorbis wmf xattr xml xmlreader xmlrpc xmlwriter xorg zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default auth_digest authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

jb-gen2-0001 ~ # emerge -pqv =sys-devel/gcc-4.4.5
[ebuild     U ] sys-devel/gcc-4.4.5 [4.4.4-r2] USE="hardened* mudflap (multilib) nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -fortran* -gcj -graphite -gtk (-libffi) -multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla"


jb-gen2-0001 ~ # cat /var/tmp/portage/sys-devel/gcc-4.4.5/temp/build.log
 * Package:    sys-devel/gcc-4.4.5
 * Repository: gentoo
 * Maintainer: toolchain@gentoo.org
 * USE:  amd64 elibc_glibc hardened kernel_linux mudflap multilib nls nptl openmp userland_GNU
>>> Unpacking source...
>>> Unpacking gcc-4.4.5.tar.bz2 to /var/tmp/portage/sys-devel/gcc-4.4.5/work
>>> Unpacking gcc-4.4.5-patches-1.2.tar.bz2 to /var/tmp/portage/sys-devel/gcc-4.4.5/work
>>> Unpacking gcc-4.4.5-uclibc-patches-1.0.tar.bz2 to /var/tmp/portage/sys-devel/gcc-4.4.5/work
>>> Unpacking gcc-4.4.5-piepatches-v0.4.5.tar.bz2 to /var/tmp/portage/sys-devel/gcc-4.4.5/work
>>> Unpacking gcc-4.4.3-specs-0.2.0.tar.bz2 to /var/tmp/portage/sys-devel/gcc-4.4.5/work
 * Applying Gentoo patches ...
 *   00_all_gcc-4.1-alpha-mieee-default.patch ...                                                                                                                                                                                                                                          [ ok ]
 *   00_all_gcc-trampolinewarn.patch ...                                                                                                                                                                                                                                                   [ ok ]
 *   01_all_gcc-4.1-alpha-asm-mcpu.patch ...
Comment 1 Marc Richter 2011-02-28 16:29:55 UTC
These are the last lines of the compile:

/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -c -DEFAULT_PIE_SSP -DEFAULT_RELRO -DEFAULT_BIND_NOW   -O2 -pipe -march=core2 -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototype
s -Wmissing-prototypes -Wcast-qual -Wold-style-definition -Wc++-compat -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -I. -I. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc -I/var/tmp/portage/sys-devel/gcc-4.4.5
/work/gcc-4.4.5/gcc/. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../include -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libcpp/include  -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libdecnumber -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-
4.4.5/gcc/../libdecnumber/bid -I../libdecnumber    /var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/bitmap.c -o bitmap.o
/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -c -DEFAULT_PIE_SSP -DEFAULT_RELRO -DEFAULT_BIND_NOW   -O2 -pipe -march=core2 -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition -Wc++-compat -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -I. -I. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../include -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libcpp/include  -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libdecnumber -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libdecnumber/bid -I../libdecnumber    /var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/bt-load.c -o bt-load.o
/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -c -DEFAULT_PIE_SSP -DEFAULT_RELRO -DEFAULT_BIND_NOW   -O2 -pipe -march=core2 -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition -Wc++-compat -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -I. -I. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../include -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libcpp/include  -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libdecnumber -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libdecnumber/bid -I../libdecnumber    /var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/builtins.c -o builtins.o
{standard input}: Assembler messages:
{standard input}:145803: Warning: end of file not at end of a line; newline inserted
{standard input}:145813: Error: suffix or operands invalid for `movq'
{standard input}:145813: Error: open CFI at the end of file; missing .cfi_endproc directive
xgcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <http://bugs.gentoo.org/> for instructions.
make[3]: *** [insn-attrtab.o] Error 1
make[3]: *** Waiting for unfinished jobs....
rm gcc.pod
make[3]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/gcc'
make[2]: *** [all-stage3-gcc] Error 2
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.5/work/build'
make[1]: *** [stage3-bubble] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.5/work/build'
make: *** [bootstrap-lean] Error 2
emake failed
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-02-28 17:44:45 UTC
Please attach the full build log to this bug report.
Can you reproduce the same error?
Comment 3 Marc Richter 2011-02-28 21:11:30 UTC
(In reply to comment #2)
> Please attach the full build log to this bug report.
> Can you reproduce the same error?
> 

Sure - it happens everytime I issue "emerge --update --deep --newuse --verbose world".

Please find the complete Build Log attached (sorry, I don't know how to strip the color codes).

There's one more thing I can offer to help fixing this bug: Since this is a rented virtual Machine Server, and the machine is fresh installed without any personalized files in it, I could give you a root login to investigate the situation easily. Please let me know if this is needed.

Comment 4 Marc Richter 2011-02-28 21:12:51 UTC
Created attachment 264209 [details]
It's the buildlog from the failing emerge
Comment 5 Matt Whitlock 2011-03-01 12:03:00 UTC
I get a different failure:


{standard input}: Assembler messages:
{standard input}:134323: Warning: end of file not at end of a line; newline inserted
{standard input}:134411: Error: open CFI at the end of file; missing .cfi_endproc directive
xgcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <http://bugs.gentoo.org/> for instructions.
make[3]: *** [insn-attrtab.o] Error 1
make[3]: *** Waiting for unfinished jobs....
rm gcc.pod
make[3]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/gcc'
make[2]: *** [all-stage2-gcc] Error 2
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.5/work/build'
make[1]: *** [stage2-bubble] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.5/work/build'
make: *** [bootstrap-lean] Error 2
emake failed
 * ERROR: sys-devel/gcc-4.4.5 failed:
 *   emake failed with bootstrap-lean
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5017:  Called toolchain_src_compile
 *   environment, line 5612:  Called gcc_src_compile
 *   environment, line 3161:  Called gcc_do_make
 *   environment, line 2943:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
Comment 6 Jeroen Roovers gentoo-dev 2011-03-01 19:39:47 UTC
{standard input}: Assembler messages:
{standard input}:145803: Warning: end of file not at end of a line; newline inserted
{standard input}:145813: Error: suffix or operands invalid for `movq'
{standard input}:145813: Error: open CFI at the end of file; missing .cfi_endproc directive
xgcc: Internal error: Killed (program cc1)
Comment 7 SpanKY gentoo-dev 2011-03-01 21:09:37 UTC
xgcc: Internal error: Killed (program cc1)

almost never a bug in the compiler or package in question, but rather a problem with the system.  look at `dmesg` to see the problem.  maybe you need more ram, or swap, or lose the -pipe.

*** This bug has been marked as a duplicate of bug 20600 ***
Comment 8 Matt Whitlock 2011-03-01 21:19:02 UTC
SpanKY, marking this bug a dupe of that metabug was premature.

You're thinking it's the OOM killer at work, but nope, I have nothing in my dmesg indicating that any process was killed due to OOM.
Comment 9 Marc Richter 2011-03-02 10:03:10 UTC
(In reply to comment #7)
> xgcc: Internal error: Killed (program cc1)
> 
> almost never a bug in the compiler or package in question, but rather a problem
> with the system.  look at `dmesg` to see the problem.  maybe you need more ram,
> or swap, or lose the -pipe.
> 
> *** This bug has been marked as a duplicate of bug 20600 ***
> 

It seems as if you are right! Somehow I messed up my fstab during installation and so no swap was activated! The output of dmesg proves, that the compile gets out of RAM:

                                   
Out of memory: Kill process 17905 (cc1) score 417 or sacrifice child                                                                                                                                                                                                                              
Killed process 17905 (cc1) total-vm:445372kB, anon-rss:425360kB, file-rss:456kB



Sorry, this was a stupid one. Thank you for your help!
Comment 10 Matt Whitlock 2011-03-02 15:11:51 UTC
Then apparently that I received a different error message does in fact indicate that I have a different bug.  I'll try building again, and if I still encounter the problem, I'll open a new bug report.
Comment 11 Matt Whitlock 2011-03-02 15:14:28 UTC
(In reply to comment #10)
> Then apparently that I received a different error message does in fact indicate
> that I have a different bug.  I'll try building again, and if I still encounter
> the problem, I'll open a new bug report.
> 

Embarrassment! I dmesg'd the wrong box. Yeah, it was an OOM. Phooey.
Comment 12 SpanKY gentoo-dev 2011-03-02 22:00:13 UTC
i dont *always* talk out my ass.  sometimes i know what i'm talking about ;).