Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 69089 - xorg and xfree always segfaulting
Summary: xorg and xfree always segfaulting
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-26 19:29 UTC by Mine GO BOOM
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mine GO BOOM 2004-10-26 19:29:42 UTC
Whenever I emerge either xfree or xorg, both will always segfault. No other build segfaults at all, and have tried a couple of different CFLAGS.

Please note that this is a VIA C3 Samuel2 processor. The flag values I've used were ones recommended by others after googling for results.

Tried two different sticks of ram, both of which past on memtest86.

Reproducible: Always
Steps to Reproduce:
emerge xorg-x11
or
emerge xfree
Actual Results:  
Sample output, though occurs at different places everytime:
XlibInt.c: In function `_XAsyncReply':
XlibInt.c:1851: internal compiler error: Segmentation fault



Portage 2.0.51-r2 (default-x86-2004.0, gcc-3.3.4, glibc-2.3.4.20040808-r1,
2.6.6-love2 i686)
=================================================================
System uname: 2.6.6-love2 i686 VIA Samuel 2
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.14.90.0.8-r1
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=i586 -m3dnow -O3 -pipe -fomit-frame-pointer -mmmx"
CHOST="i586-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=i586 -m3dnow -O3 -pipe -fomit-frame-pointer -mmmx"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo
ftp://mirrors.tds.net/gentoo http://mirrors.tds.net/gentoo
http://mirror.datapipe.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb bitmap-fonts crypt cups encode esd f77
foomaticdb gdbm gif gnome gpm gtk gtk2 guile imlib jpeg libg++ libwww mad mikmod
motif mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl png python
quicktime readline sdl slang spell ssl svga tcpd truetype x86 xml2 xmms xprint
xv zlib"
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2004-10-27 11:18:32 UTC

*** This bug has been marked as a duplicate of 20600 ***