Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 204894 - media-libs/freetype-2.3.5-r2 ebuild will not build.
Summary: media-libs/freetype-2.3.5-r2 ebuild will not build.
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 204899 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-08 12:50 UTC by Cory Hardman
Modified: 2008-01-09 13:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cory Hardman 2008-01-08 12:50:42 UTC
Emerging media-libs/freetype-2.3.5-r2 errors out while compiling. 

Reproducible: Always

Steps to Reproduce:
1. emerge =media-libs/freetype-2.3.5-r2


Actual Results:  
make: *** [/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/objs/ftbase.lo] Error 1
make: *** Waiting for unfinished jobs....
 gcc -pedantic -ansi -I/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/objs -I./builds/unix -I/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/include -c -Wall -O2 -march=i686 -pipe -fno-strict-aliasing -DFT_CONFIG_OPTION_SYSTEM_ZLIB "-DFT_CONFIG_CONFIG_H=<ftconfig.h>" -DFT2_BUILD_LIBRARY "-DFT_CONFIG_MODULES_H=<ftmodule.h>" -I/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/src/base /var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/src/base/fttype1.c  -fPIC -DPIC -o /var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/objs/.libs/fttype1.o
 gcc -pedantic -ansi -I/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/objs -I./builds/unix -I/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/include -c -Wall -O2 -march=i686 -pipe -fno-strict-aliasing -DFT_CONFIG_OPTION_SYSTEM_ZLIB "-DFT_CONFIG_CONFIG_H=<ftconfig.h>" -DFT2_BUILD_LIBRARY "-DFT_CONFIG_MODULES_H=<ftmodule.h>" -I/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/src/base /var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/src/base/fttype1.c -o /var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/objs/fttype1.o >/dev/null 2>&1
 *
 * ERROR: media-libs/freetype-2.3.5-r2 failed.
 * Call stack:
 *                  ebuild.sh, line 1701:  Called dyn_compile
 *                  ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                  ebuild.sh, line   44:  Called src_compile
 *   freetype-2.3.5-r2.ebuild, line   84:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/freetype-2.3.5-r2/temp/build.log'.
 *


Expected Results:  
it should have installed
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-01-08 12:52:44 UTC
<snip>
make: ***
[/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/objs/ftbase.lo]
Error 1
</snip>

The important part is *above*, not below the above snippet. Post it or just attach the complete log.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2008-01-08 21:49:25 UTC
*** Bug 204899 has been marked as a duplicate of this bug. ***
Comment 3 Cory Hardman 2008-01-09 13:17:45 UTC
(In reply to comment #1)
> <snip>
> make: ***
> [/var/tmp/portage/media-libs/freetype-2.3.5-r2/work/freetype-2.3.5/objs/ftbase.lo]
> Error 1
> </snip>
> 
> The important part is *above*, not below the above snippet. Post it or just
> attach the complete log.
> 

The problem turned out to be hardware related.  My CPU fan had died and my system was over heating.  It was causing random errors to happen everywhere and would not let me compile anything.  I have replaced the fan and now the system works fine again.  media-libs/freetype-2.3.5-r2 compiles now.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2008-01-09 13:22:34 UTC
Well, lets resolve this properly then...
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-01-09 13:22:48 UTC

*** This bug has been marked as a duplicate of bug 20600 ***