Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 382399 - kde-base/ksirk-4.7.1 fails to compile, gas error "invalid operands (*UND* and .gcc_except_table sections) for `-'"
Summary: kde-base/ksirk-4.7.1 fails to compile, gas error "invalid operands (*UND* and...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal blocker (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-09 14:00 UTC by Geoff Madden
Modified: 2011-09-12 16:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log for ksirk (build.log.tar.bz2,11.47 KB, text/plain)
2011-09-09 14:00 UTC, Geoff Madden
Details
emerge info x86_64 kde-base/ksirk-4.7.1 (emerge.inf,4.93 KB, text/plain)
2011-09-09 14:03 UTC, Geoff Madden
Details
eclass debug.log (eclass-debug.log,8.51 KB, text/plain)
2011-09-09 14:04 UTC, Geoff Madden
Details
environment file (environment.tar.bz2,37.01 KB, application/octet-stream)
2011-09-09 14:05 UTC, Geoff Madden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Madden 2011-09-09 14:00:37 UTC
Created attachment 285967 [details]
build log for ksirk

Scanning dependencies of target ksirk                                                                                                          
[ 46%] Building CXX object ksirk/ksirk/CMakeFiles/ksirk.dir/ksirk_automoc.o                                                                    
[ 47%] Building CXX object ksirk/ksirk/CMakeFiles/ksirk.dir/GameLogic/gameautomaton.o                                                          
[ 48%] Building CXX object ksirk/ksirk/CMakeFiles/ksirk.dir/kgamewin.o                                                                         
{standard input}: Assembler messages:                                                                                                          
{standard input}:40370: Warning: end of file not at end of a line; newline inserted
{standard input}:39873: Error: invalid operands (*UND* and .gcc_except_table sections) for `-'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/as: BFD (GNU Binutils) 2.21.1 assertion fail /var/tmp/portage/sys-devel/binutils-2.21.1-r1/work/binutils-2.21.1/bfd/elf.c:2823
x86_64-pc-linux-gnu-g++: Internal error: Killed (program cc1plus)
Please submit a full bug report.
See <http://bugs.gentoo.org/> for instructions.
make[2]: *** [ksirk/ksirk/CMakeFiles/ksirk.dir/kgamewin.o] Error 1
make[1]: *** [ksirk/ksirk/CMakeFiles/ksirk.dir/all] Error 2
make: *** [all] Error 2
 * ERROR: kde-base/ksirk-4.7.1 failed (compile phase):
 *
Comment 1 Geoff Madden 2011-09-09 14:03:14 UTC
Created attachment 285969 [details]
emerge info x86_64 kde-base/ksirk-4.7.1
Comment 2 Geoff Madden 2011-09-09 14:04:23 UTC
Created attachment 285971 [details]
eclass debug.log
Comment 3 Geoff Madden 2011-09-09 14:05:18 UTC
Created attachment 285973 [details]
environment file
Comment 4 Geoff Madden 2011-09-09 14:07:56 UTC
The build log is in .tar.bz2 form ie (octet/stream)
My computer has also become very very slow even though there isn't any compilation going on at present
Comment 5 Andreas K. Hüttel gentoo-dev 2011-09-09 20:24:26 UTC
@toolchain: any idea?
Comment 6 Geoff Madden 2011-09-10 03:46:37 UTC
Not too sure whether this's a !!!!!(real) bug yet as I had gpsd-3 installed.
Since replaced it with the latest from portage,and am proceding with updates
Comment 7 SpanKY gentoo-dev 2011-09-11 19:26:41 UTC
you ran out of memory.  get some more.  review `dmesg` for exact reasons.

x86_64-pc-linux-gnu-g++: Internal error: Killed (program cc1plus)

*** This bug has been marked as a duplicate of bug 20600 ***
Comment 8 SpanKY gentoo-dev 2011-09-12 16:50:23 UTC
sorry, forgot to mention another option.  drop -pipe from CXXFLAGS as C++ often writes much more data to pipes than C.