Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80905 - Emerging xorg-x11-6.8.1.904 fails with XKBList.c:226: internal compiler error: in calc_dfs_tree, at dominance.c:356
Summary: Emerging xorg-x11-6.8.1.904 fails with XKBList.c:226: internal compiler error...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 80921 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-05 13:48 UTC by Israel Thomas
Modified: 2005-10-05 20:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Israel Thomas 2005-02-05 13:48:33 UTC
When emerging xorg-x11-6.8.1.904 , I get a reproducible error:
XKBList.c:226: internal compiler error: in calc_dfs_tree, at dominance.c:356

The build then fails.

Reproducible: Always
Steps to Reproduce:
1.emerge -nvDu xorg
2.
3.

Actual Results:  
 -DFUNCPROTO=15 -DNARROWPROTO -DXTHREADS  -D_REENTRANT -DXUSE_MTSAFE_API    -
DMALLOC_0_RETURNS_NULL  -DHAS_SNPRINTF -DLIBX11                        -
DPOSTLOCALELIBDIR=\"lib\"     -fPIC XKBExtDev.c
rm -f XKBList.o unshared/XKBList.o
i686-pc-linux-gnu-gcc -c -ansi -pedantic -Wno-return-type -w    -I../.. -I../../exports/include   -Dlinux -
D__i386__ -D_POSIX_C_SOURCE=199309L                              -D_POSIX_SOURCE -
D_XOPEN_SOURCE                             -D_BSD_SOURCE -D_SVID_SOURCE                -
D_GNU_SOURCE                             -DFUNCPROTO=15 -DNARROWPROTO -DXTHREADS  -
D_REENTRANT -DXUSE_MTSAFE_API    -DMALLOC_0_RETURNS_NULL  -DHAS_SNPRINTF -
DLIBX11                  -DPOSTLOCALELIBDIR=\"lib\"       -O3 -march=athlon-xp -fomit-frame-pointer -pipe -
fno-strict-aliasing   XKBList.c -o unshared/XKBList.o
rm -f XKBList.o
i686-pc-linux-gnu-gcc -c -O3 -march=athlon-xp -fomit-frame-pointer -pipe -fno-strict-aliasing  -ansi -
pedantic -Wno-return-type -w    -I../.. -I../../exports/include   -Dlinux -D__i386__ -
D_POSIX_C_SOURCE=199309L                            -D_POSIX_SOURCE -D_XOPEN_SOURCE    -
D_BSD_SOURCE -D_SVID_SOURCE                              -D_GNU_SOURCE                       -
DFUNCPROTO=15 -DNARROWPROTO -DXTHREADS  -D_REENTRANT -DXUSE_MTSAFE_API    -
DMALLOC_0_RETURNS_NULL  -DHAS_SNPRINTF -DLIBX11                        -
DPOSTLOCALELIBDIR=\"lib\"     -fPIC XKBList.c
XKBList.c: In function `XkbListComponents':
XKBList.c:226: internal compiler error: in calc_dfs_tree, at dominance.c:356
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[4]: *** [XKBList.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.1.904/work/xc/lib/X11'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.1.904/work/xc/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.1.904/work/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.1.904/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11-6.8.1.904 failed.
!!! Function build, Line 947, Exitcode 2
!!! make World failed
!!! If you need support, post the topmost build error, NOT this status message

Expected Results:  

emerged xorg-x11

 emerge info                                             <2167>
Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.4.20041102-r0, 2.6.9 i686)
=================================================================
System uname: 2.6.9 i686 AMD Duron(tm) Processor
Gentoo Base System version 1.6.9
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Dec  8 2004, 13:49:20)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r2
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O3  -march=athlon-xp -fomit-frame-pointer -fno-inline-functions -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/
shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/
share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/
share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3  -march=athlon-xp -fomit-frame-pointer -fno-inline-functions -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://mirror.pacific.net.au/linux/Gentoo htpp://mirrot.isp.net.au/ftp/pub/gentoo 
http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="x86 X aalib alsa apm arts avi berkdb bitmap-fonts cdr crypt cups dvd emacs encode esd f77 fam 
flac font-server foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 guile imagemagick imlib 
ipv6 java jpeg junit libg++ libwww mad mikmod motif mpeg mysql ncurses nls nptl oggvorbis opengl oss 
pam pdflib perl png python quicktime readline ruby sdl spell ssl svga tcltk tcpd tetex tiff truetype 
truetype-fonts type1-fonts usb xface xml xml2 xmms xv zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-05 16:20:57 UTC
Can you reproduce this at the exact same place?
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-05 16:30:40 UTC
*** Bug 80921 has been marked as a duplicate of this bug. ***
Comment 3 Manuel Wächter 2005-02-10 08:25:51 UTC
Hi,

got the same error, tried it many times(also with different USE-Flags), but the merge keeps crashing.

My 'emerge info':

Gentoo Base System version 1.6.9
Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.4.3, glibc-2.3.4.20041102-r0, 2.6.11-rc1-love1-ph030-babylove i686)
=================================================================
System uname: 2.6.11-rc1-love1-ph030-babylove i686 Intel(R) Pentium(R) M processor 1400MHz
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  8 2005, 01:22:15)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.8.5-r3, 1.6.3, 1.9.4, 1.5
sys-devel/binutils:  2.15.92.0.2-r2
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O3 -funroll-loops -ffast-math -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -funroll-loops -ffast-math -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X acpi apm avi bash-completion berkdb bitmap-fonts cdr cdrom chroot crypt encode esd f77 fam font-server foomaticdb fortran gdbm gif gpm gtk gtk2 hardened hardenedphp imagemagick imlib ipv6 java jpeg kerberos krb4 libg++ libwww mad mikmod mmx mmx2 motif mpeg ncurses nls nptl offensive oggvorbis opengl oss pam pdflib perl png python qt quicktime readline ruby sdl spell sse sse2 ssl stroke svga tcltk tcpd tiff truetype truetype-fonts type1-fonts unicode wxwindows xface xml2 xmms xosd xv zeo zlib zvbi video_cards_radeon"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS

Hope this bug won't last too long :)
Comment 4 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-10 13:56:51 UTC
Could you humor me and try with a vanilla kernel?
Comment 5 Brian Harring gentoo-dev 2005-09-13 06:44:22 UTC
See dev ml re: your request, and a brief explanation of why ICE's pretty much
point at your system/toolchain/kernel as being at fault, not the source being
compiled.
Comment 6 Martin Schlemmer (RETIRED) gentoo-dev 2005-09-13 07:49:58 UTC
(In reply to comment #0)

[...]

> System uname: 2.6.9 i686 AMD Duron(tm) Processor

[ ... ]

> CFLAGS="-O3  -march=athlon-xp -fomit-frame-pointer -fno-inline-functions -pipe"

Except if its one of the very latish Duron processors, it does not have full SSE
support, so running it with -march=athlon-xp could also cause issues.


(In reply to comment #3)

[...]

> System uname: 2.6.11-rc1-love1-ph030-babylove i686 Intel(R) Pentium(R) M
processor 1400MHz

[...]

> CFLAGS="-march=pentium4 -O3 -funroll-loops -ffast-math -fomit-frame-pointer -pipe"

I am sure comment #4 was more for this comment, as the love-sources ... err ...
are known to have some issues.

Also, the Pentium M (if on of the later models) does have SSE2, etc, but its
instruction scheduling is not 100% the same, and if using gcc-3.4 or later, you
should rather use -march=pentium4m, or -march=pentium3 if gcc-3.3 ....

Comment 7 Luca Barbato gentoo-dev 2005-09-13 23:19:44 UTC
2.6.11-rc1-love1-ph030-babylove

It lead to consider a non supported kernel source known to be problematic and
surely not supported. If you are using reiserfs4 you may either wait till it is
stable (consider few weeks) 

-ffast-math is known to be problematic in certain situations and should not be
enable by default...
Comment 8 Donnie Berkholz (RETIRED) gentoo-dev 2005-10-05 20:03:19 UTC

*** This bug has been marked as a duplicate of 20600 ***