Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 377449 - games-emulation/daphne - i686-pc-linux-gnu-g++: Internal error: Killed (program cc1plus)
Summary: games-emulation/daphne - i686-pc-linux-gnu-g++: Internal error: Killed (progr...
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-02 18:06 UTC by Alex Weiss
Modified: 2011-08-03 15:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
output of 'emerge --info =games-emulation/daphne-1.0' (emergeinfo.txt,4.86 KB, text/plain)
2011-08-02 18:10 UTC, Alex Weiss
Details
build log (build.log.txt,28.03 KB, text/plain)
2011-08-02 18:12 UTC, Alex Weiss
Details
ebuild environment (ebuildenvironment.txt,91.89 KB, text/plain)
2011-08-02 18:13 UTC, Alex Weiss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Weiss 2011-08-02 18:06:46 UTC
When I attempted to emerge the daphne emulator, I got the following error. After the error, the emerge stops and exits.

Reproducible: Always

Steps to Reproduce:
1.emerge daphne
2.
3.
Actual Results:  
i686-pc-linux-gnu-g++: Internal error: Killed (program cc1plus)
Please submit a full bug report.
See <http://bugs.gentoo.org/> for instructions.
make[1]: *** [m80.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/games-emulation/daphne-1.0/work/v_1_0/src/cpu'
make: *** [sub] Error 2
emake failed
 * ERROR: games-emulation/daphne-1.0 failed (compile phase):
 *   src build failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2483:  Called die
 * The specific snippet of code:
 *       emake CXX=$(tc-getCXX) DFLAGS="${CXXFLAGS} ${archflags}" || die "src build failed";
 * 
 * If you need support, post the output of 'emerge --info =games-emulation/daphne-1.0',
 * the complete build log and the output of 'emerge -pqv =games-emulation/daphne-1.0'.
 * The complete build log is located at '/var/tmp/portage/games-emulation/daphne-1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/games-emulation/daphne-1.0/temp/environment'.
 * S: '/var/tmp/portage/games-emulation/daphne-1.0/work/v_1_0/src'


Expected Results:  
Daphne should have emerged successfully.

The emerge --info details are as follows:

# emerge --info
Portage 2.1.10.3 (default/linux/x86/10.0/desktop, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-i686-Intel-R-_Pentium-R-_4_CPU_2.60GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 02 Aug 2011 16:45:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--progress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa asf audiofile avi berkdb bitmap-fonts branding bzip2 bzlib cairo cdda cdparanoia cdr cli consolekit cracklib crypt cups curl curlwrappers custom-optimization cxx dbus declarative divx4linux dri dts dvd dvdnav dvdr dvdread emboss encode exif fam ffmpeg firefox flac fortran freetype freewnn gdbm gdu gif glib gnutls gphoto2 gpm gtk gtk2 gtkstyle iconv imagemagick imlib jpeg jpeg2k kde kpathsea lcms ldap libnotify mad matroska mbox mime mmx mng modules mp3 mp4 mpeg mudflap ncurses network nls nptl nptlonly nsplugins nvidia ogg oggvorbis opengl openmp pam pango pcre pdf pdflib perl png policykit ppds pppd preview-latex python qt qt-static qt3support qt4 quicktime readline sdl semantic-desktop session sox spell sql sqlite sse sse2 ssl startup-notification svg sysfs tcltk tcpd texlive tiff truetype truetype-fonts type1-fonts udev unicode usb vorbis webkit win32codecs x264 x86 xcb xine xml xorg xulrunner xv xvid yahoo zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia fbdev vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Alex Weiss 2011-08-02 18:10:35 UTC
Created attachment 281869 [details]
output of 'emerge --info =games-emulation/daphne-1.0'
Comment 2 Alex Weiss 2011-08-02 18:12:16 UTC
Created attachment 281871 [details]
build log
Comment 3 Alex Weiss 2011-08-02 18:13:03 UTC
Created attachment 281873 [details]
ebuild environment
Comment 4 Jeroen Roovers gentoo-dev 2011-08-03 15:00:15 UTC
Looks like you ran out of memory, or at least your kernel thought so.

In the former case: Try with MAKEOPTS=-j1, or stop all other processes that consume a lot of memory, or get more RAM.

In the latter case: provide your dmesg output: the OOM killer will normally explain what it's doing right there.

*** This bug has been marked as a duplicate of bug 20600 ***