Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 98445 - media-video/vlc-0.8.2 fails to build (linker or gcc problem?)
Summary: media-video/vlc-0.8.2 fails to build (linker or gcc problem?)
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-09 03:50 UTC by Guillaume Ceccarelli
Modified: 2005-11-03 16:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
vlc-config (vlc-config,28.20 KB, text/plain)
2005-10-11 01:37 UTC, Olaf Walkowiak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Ceccarelli 2005-07-09 03:50:33 UTC
When building, at a very early stage, the linker complains about a missing   
entry point (main) in /usr/lib64/crt1.o  
Obviously, it should not try to search a main function in a library... 

Reproducible: Always
Steps to Reproduce:
1. emerge vlc 
Actual Results:  
The build fails : here is the last lines of output 
 
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../..   -DSYS_LINUX  
-I../../include `top_builddir="../.." ../../vlc-config --cflags plugin  
access_file` -Wsign-compare -Wall -march=k8 -O2 -pipe -fomit-frame-pointer  
-nopie -fno-stack-protector -pipe -c -o libaccess_file_plugin_a-file.o `test  
-f 'file.c' || echo './'`file.c  
x86_64-pc-linux-gnu-gcc -Wsign-compare -Wall -march=k8 -O2 -pipe  
-fomit-frame-pointer -nopie -fno-stack-protector -pipe -o  
libaccess_file_plugin.so libaccess_file_plugin_a-file.o  
`top_builddir=../.. ../../vlc-config --libs plugin access_file`  
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../lib64/crt1.o: In function  
`_start':  
init.c:(.text+0x21): undefined reference to `main'  
collect2: ld returned 1 exit status  
make[4]: *** [libaccess_file_plugin.so] Error 1  
make[4]: Leaving directory  
`/var/tmp/portage/vlc-0.8.2/work/vlc-0.8.2/modules/access'  
make[3]: *** [all-modules] Error 1  
make[3]: Leaving directory  
`/var/tmp/portage/vlc-0.8.2/work/vlc-0.8.2/modules/access'  
make[2]: *** [all-recursive] Error 1  
make[2]: Leaving directory `/var/tmp/portage/vlc-0.8.2/work/vlc-0.8.2/modules'  
make[1]: *** [all-recursive] Error 1  
make[1]: Leaving directory `/var/tmp/portage/vlc-0.8.2/work/vlc-0.8.2'  
make: *** [all] Error 2  
  
!!! ERROR: media-video/vlc-0.8.2 failed.  
!!! Function src_compile, Line 250, Exitcode 2  
!!! make of VLC failed  
!!! If you need support, post the topmost build error, NOT this status  
message.  
 

Expected Results:  
vlc should be built and installed 

emerge info output :  
 
Portage 2.0.51.22-r1 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r0, 
2.6.12-gentoo-r1 x86_64) 
================================================================= 
System uname: 2.6.12-gentoo-r1 x86_64 AMD Athlon(tm) 64 Processor 3500+ 
Gentoo Base System version 1.6.12 
ccache version 2.4 [enabled] 
dev-lang/python:     2.3.5-r1, 2.4.1-r1 
sys-apps/sandbox:    1.2.10 
sys-devel/autoconf:  2.13, 2.59-r7 
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5 
sys-devel/binutils:  2.16.1 
sys-devel/libtool:   1.5.18-r1 
virtual/os-headers:  2.6.11-r2 
ACCEPT_KEYWORDS="amd64 ~amd64" 
AUTOCLEAN="yes" 
CBUILD="x86_64-pc-linux-gnu" 
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -nopie -fno-stack-protector" 
CHOST="x86_64-pc-linux-gnu" 
CONFIG_PROTECT="/etc /opt/openjms/config /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d" 
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -nopie 
-fno-stack-protector" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoconfig ccache distlocks sandbox sfperms strict" 
GENTOO_MIRRORS="http://ftp.heanet.ie/pub/gentoo http://gentoo.osuosl.org 
http://www.ibiblio.org/pub/Linux/distributions/gentoo" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/portage" 
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage" 
USE="amd64 16bit 3ds GAPING_SECURITY_HOLE S3TC X X509 Xaw3d a52 aac aalib 
accessibility accounting acl acpi acpi4linux activefilter adns aim aliaschain 
alsa amd apache2 apm arts artswrappersuid artworkextra asterisk async athena 
atlas audiofile authdaemond avantgo avi bash-completion bcmath beepmp berkdb 
bitmap-fonts blender-game bluetooth bmp bonobo bzip2 bzlib cacheemu cairo 
calendar cap caps cdb cdda cddb cdf cdinstall cdparanoia cdr cdrom cgi chasen 
chroot clamav clanJavaScript clanVoice clisp cmucl codecs crypt cscope css 
ctype cups curl curlwrappers custreloc cyrus dba dbase dbcp dbm dbx debugger 
dedicated devfs devfs26 devmap dga dhcp dict dillo dio directfb distcache 
distribution dmx dnd dnsdb dpms dts dumb-allegro dv dvb dvd dvdr dvdread dxr3 
editor edl eds emacs emacs-w3 emoticon encode erandom escreen esd ethereal 
etwin evms2 evo examples exif exim exiscan exiscan-acl extensions f77 faac 
faad fam fame fastcgi fax fb fbcon fbdev festival ffmpeg flac flash flatfile 
flood fluidsynth fmod font-server foomaticdb fortran fpx freetts freetype 
freewnn frlargefiles frxp fs ftp ftruncate gatos gb gcj gcl gd gdbm geoip ggi 
gif gimp gimpprint ginac gkrellm glade glep glgd glitz glut gmail gmp gmtfull 
gmthigh gmtsuppl gmttria gnokii gnomedb gnuplot gnutls gphoto2 gpm gprof gps 
graphviz gs gsl gsm gsnd gstreamer gtk gtk2 gtkhtml guile hal hardenedphp hbci 
hdf high-ints howl httpd hub hyperwave-api icon iconv icq icu ide idea idl 
ieee1394 image imagekits imagemagick imap imlib imlib2 immqt-bc inetd inifile 
innkeywords innodb intl ipalias ipv6 ipv6arpa irda irmc j2ee jabber jack java 
javacomm javadoc javascript jbig jboss jce jikes jit joystick jp2 jpeg jpeg2k 
jta junit jython kadu-modules kadu-voice kakasi kde kdeenablefinal kerberos 
kig-scripting koffice-plugin ladcca ladspa largeterminal latex lcd lcms ldap 
ldirectord leim libcaca libclamav libdsk libedit libgda libsamplerate libwww 
live lm_sensors lmtp ltsp lua lufsusermount lzo lzw lzw-tiff m17n-lib mad 
mailbox maildir maildrop maps matroska mbox mbrola mcal mcve md5sum mdb mecab 
messages mew mhash migemo mikmod mime mimencode ming mips16 mixer mjpeg mls 
mmap mng mnogosearch mod moneyplex monkey motif mozaccess mozcalendar mozctl 
mozdevelop mozilla mozp3p mozsvg mozxmlterm mp3 mpeg mpeg4 mpi mplayer 
msession msn mule multi-tty multipleip musepack music mysql mysqli mythtv 
nagios-dns nagios-ntp nagios-ping nagios-ssh nas native ncurses neXt net 
netbeans netboot netcdf network neural nis nls nntp no-old-linux nocd nodrm 
normalizemime nowin nptl nptl-only nptlonly ntlm nvidia nviz oav objc ocaml 
odbc offensive ogg oggvorbis openal opengl openssh opie oscar oss pam 
parse-clocks pcap pcntl pcre pda pdf pdfkit pdflib perl pg-hier pg-vacuumdelay 
php physfs pic pie playlist plotutils png pnp portaudio posix postgres povray 
ppds prelude print private procmail pthreads pwdb pyste python qdbm qemu-fast 
qhull qmail qt quicktime quotas quotes radius rdesktop readline real recode 
remote rhino rogue roundrobin rplay rrdtool rtc ruby samba sasl savedconfig 
sbcl scanner screen sdk sdl semanticfix serial server servlet-2.3 servlet-2.4 
session sftplogging shaper shared sharedmem sheep silc silverxp simplexml skey 
slang smartcard smime sms smtp sndfile snmp snortsam soap sockets socks5 
softmmu softquota sounds soundtouch source sox spamassassin speedo speex spell 
spl sqlite sqlite3 src ssl stats stencil-buffer stream streamzap stroke struts 
subject-rewrite svg sysvipc szip t1lib tcltk tcpd tcpmd5 tcsim tetex tga 
theora threads thumbnail tidy tiff timidity tlen tokenizer tools transcode 
translator transparent-proxy truetype truetype-fonts trusted type1 type1-fonts 
ucs4 uim uml underscores unicode usb usepackagedmakefiles v4l v4l2 vcd 
vcdimager vda vhosts videos vidix vim vim-pager vim-with-x virtual virus-scan 
visualization vnc vorbis wifi wildlsearch winbind withsamplescripts wma123 wmf 
wxwin wxwindows xanim xatrix xchattext xemacs xface xforms xfs xim xine 
xinerama xinetd xml xml2 xmlrpc xmms xosd xpm xprint xrandr xscreensaver xsl 
xv xvid xvmc yahoo yaz yp yv12 zeo zlib zvbi userland_GNU kernel_linux 
elibc_glibc" 
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-07-11 17:33:33 UTC
Seems like a broken toolchain. 
Comment 2 Guillaume Ceccarelli 2005-07-12 02:31:03 UTC
(In reply to comment #1) 
> Seems like a broken toolchain.  
 
But every other ebuild I try to merge (like in system updates with emerge -vDu 
--newuse world) seems to be working. VLC is the only one which appears to be 
problematic 
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-07-14 04:07:45 UTC
Try disabling ccache and removing /var/tmp/portage 
 
Comment 4 Guillaume Ceccarelli 2005-07-14 07:35:34 UTC
I got exactly the same output & problem after disabling ccache and removing 
every contents in the portage temp directory. 
Comment 5 Chuck Wegrzyn 2005-09-02 09:43:30 UTC
I got something similar. Here is the output from emerge:

clude `top_builddir="../.." ../../vlc-config --cflags plugin access_smb` -Wsign
-compare -Wall  -O2 -march=pentium4 -pipe -MT libaccess_smb_plugin_a-smb.o -MD -
MP -MF ".deps/libaccess_smb_plugin_a-smb.Tpo" \
  -c -o libaccess_smb_plugin_a-smb.o `test -f 'smb.c' || echo './'`smb.c; \
then mv -f ".deps/libaccess_smb_plugin_a-smb.Tpo" ".deps/libaccess_smb_plugin_a-
smb.Po"; \
else rm -f ".deps/libaccess_smb_plugin_a-smb.Tpo"; exit 1; \
fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
smb.c: In function `Close':
smb.c:304: error: structure has no member named `close'
make[4]: *** [libaccess_smb_plugin_a-smb.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/vlc-0.8.2-r1/work/vlc-0.8.2/modules
                                                    /access'
make[3]: *** [all-modules] Error 1
make[3]: Leaving directory `/var/tmp/portage/vlc-0.8.2-r1/work/vlc-0.8.2/modules
                                                    /access'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/vlc-0.8.2-r1/work/vlc-0.8.2/modules
                                                    '
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/vlc-0.8.2-r1/work/vlc-0.8.2'
make: *** [all] Error 2

!!! ERROR: media-video/vlc-0.8.2-r1 failed.
!!! Function src_compile, Line 231, Exitcode 2
!!! make of VLC failed
!!! If you need support, post the topmost build error, NOT this status message.


Here is emerge info for me:

marge ~ # emerge info
Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r9 i686)
=================================================================
System uname: 2.6.12-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.0_pre8
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS=" -O2 -march=pentium4"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS=" -O2 -march=pentium4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac acl acpi afs aim alsa aotuv apache2 apm arts artswrappersuid
audiofile avi bash-completion bdf berkdb bitmap-fonts bluetooth bootsplash caps
cdparanoia cdr cluster codecs crypt css cups curl dbx dga dio directfb dpms dv
dvb dvd dvdr dvdread eds encode esd ethereal exif fam fame fb fbcon fbdev flac
flatfile foomaticdb fpx freetds ftp gd gdbm gif gpg gpm gstreamer gtk gtk2
imagemagick imlib ipv6 java jpeg junit kde ldap libg++ libwww mad mikmod mime
mjpeg mmx monkey motif mp3 mpeg msn msql mysql ncurses nls odbc ogg oggvorbis
opengl oss pam pdflib perl png postgres python qt quicktime readline samba sdl
snmp spell sse sse2 ssl svga tcltk tcpd tetex tiff truetype truetype-fonts
type1-fonts vorbis xine xinerama xml2 xmms xv yahoo zeroconf zlib userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-09-02 10:01:44 UTC
Chuck, your problem is a completely different point. 
Please open a new bug about that. 
 
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-09-02 15:49:09 UTC
Someone who encounter this problem can attach vlc-config script found in the 
work directory? 
 
Comment 8 Olaf Walkowiak 2005-10-11 01:37:04 UTC
Created attachment 70345 [details]
vlc-config
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-11-03 16:32:11 UTC
The vlc-config file seems sane, so the problem is with the toolchain. 
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-11-03 16:32:24 UTC

*** This bug has been marked as a duplicate of 20600 ***