Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 132232 - QT 4.1.2 segmentation fault? Hardware vs ?
Summary: QT 4.1.2 segmentation fault? Hardware vs ?
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Other
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-05-04 04:44 UTC by Stefan de Konink
Modified: 2006-05-04 04:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Stefan de Konink 2006-05-04 04:44:04 UTC
g++ -c -pipe -O2 -march=athlon-tbird -pipe -Wall -W -D_REENTRANT -fPIC  -DQT_SHARED -DQT_BUILD_GUI_LIB -DQT_NO_CAST_TO_ASCII -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_RASTER_IMAGEENGINE -DQT_HAVE_SSE -DQT_PDF_SUPPORT -DQT_HAVE_FREETYPE -DQT_NO_STYLE_MAC -DQT_NO_STYLE_WINDOWSXP -DQT_NO_DEBUG -DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../mkspecs/linux-g++ -I. -I../../include/QtCore -I../../include -I../../include/QtGui -I/usr/include/freetype2 -I../3rdparty/opentype -I.moc/release-shared -I/usr/include -I. -o .obj/release-shared/qactiongroup.o kernel/qactiongroup.cpp
In file included from kernel/qactiongroup.cpp:29:
kernel/qevent.h:106: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[3]: *** [.obj/release-shared/qactiongroup.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/qt-4.1.2/work/qt-x11-opensource-src-4.1.2/src/gui'
make[2]: *** [release-all] Error 2
make[2]: Leaving directory `/var/tmp/portage/qt-4.1.2/work/qt-x11-opensource-src-4.1.2/src/gui'
make[1]: *** [sub-gui-all-ordered] Error 2
make[1]: Leaving directory `/var/tmp/portage/qt-4.1.2/work/qt-x11-opensource-src-4.1.2/src'
make: *** [sub-src-all-ordered] Error 2

Last night I tried the same. It ended up in a segmentation fault on another location. The problem is when I go to the /var/tmp/portage dir, and hit 'make' again it 'just' continues.

Portage 2.1_pre10-r2 (default-linux/x86/2005.0, gcc-3.4.6, glibc-2.4-r1, 2.6.15-gentoo i686)
System uname: 2.6.15-gentoo i686 AMD Athlon(tm) processor
Gentoo Base System version 1.12.0_pre19$ ssh
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]ssword: 
dev-lang/python:     2.3.5, 2.4.3006
dev-util/ccache:     [Not Present]
dev-util/confcache:  0.4.2esumed.
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
CFLAGS="-O3 -march=athlon-tbird -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/NX/home /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O3 -march=athlon-tbird -pipe -fomit-frame-pointer"
FEATURES="autoconfig ccache confcache distlocks metadata-transfer sfperms strict"
PORTDIR_OVERLAY="/usr/local/overlays/ebuildexchange /usr/local/portage"
USE="x86 3dnow 3dnowext X a52 aac alsa apm avi bitmap-fonts bpm bzip2 cli crypt cups divx4linux dri dv dvd emboss encode f77 ffmpeg flac foomaticdb fortran gif glitz gnutls gstreamer gtk gtk2 hash-dri imagemagick ipv6 isdnlog jack joystick jpeg lcms libg++ libsamplerate libwww mad mikmod mmx mmxext mng motif mp3 mpeg ncurses nls nptl nptlonly nsplugin nvidia ogg oggvorbis openal opengl oss pam pcre pic png pppd quicktime readline reflection scanner sdl session softmmu speex spell spl ssl svg tcpd theora threads tiff truetype truetype-fonts type1-fonts userlocales vorbis win32codecs wmf xml2 xorg xprint xv xvid zlib elibc_glibc input_devices_mouse input_devices_keyboard input_devices_hyperpen kernel_linux userland_GNU video_cards_nvidia"

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) processor
stepping        : 4
cpu MHz         : 1402.019
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
bogomips        : 2808.38
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-05-04 04:52:19 UTC
(In reply to comment #0)
> Last night I tried the same. It ended up in a segmentation fault on another
> location. The problem is when I go to the /var/tmp/portage dir, and hit 'make'
> again it 'just' continues.

Random failures in different places => not a code issue.

*** This bug has been marked as a duplicate of 20600 ***