Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 117430 - speex-1.1.10 - cannot compute sizeof (short)
Summary: speex-1.1.10 - cannot compute sizeof (short)
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Sound Team
Depends on:
Reported: 2006-01-02 02:30 UTC by Jonh Smith
Modified: 2008-05-17 17:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

speex emerge log (config.log,48.49 KB, text/plain)
2006-01-02 02:31 UTC, Jonh Smith

Note You need to log in before you can comment on or make changes to this bug.
Description Jonh Smith 2006-01-02 02:30:50 UTC
hi this happens all the time I try to compile speex-1.1.10 Here's the log:

checking for Ogg... yes
checking for sin in -lm... yes
checking for getopt_long... yes
checking for main in -lwinmm... yes
checking for short... yes
checking size of short... configure: error: cannot compute sizeof (short), 77
See `config.log' for more details.

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/speex-1.1.10/work/speex-1.1.10/config.log

!!! ERROR: media-libs/speex-1.1.10 failed.
!!! Function econf, Line 495, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

server ~ # emerge --info
Portage 2.0.53 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.13-gentoo-r3 i686)
System uname: 2.6.13-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=pentium4 -fomit-frame-pointer -mmmx -msse -msse2 -funroll-loops -ftracer -pipe -ffast-math -mfpmath=sse,387 -O1"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -fomit-frame-pointer -mmmx -msse -msse2 -funroll-loops -ftracer -pipe -ffast-math -mfpmath=sse,387 -O1"
FEATURES="autoconfig candy ccache distlocks sandbox sfperms strict"
USE="x86 X X509 Xaw3d a52 aac aalib acpi activefilter adns aim alsa ao apache2 apm atk atm audiofile authdaemond avalon avi bash-completion berkdb bidi bitmap-fonts bl bluetooth bonobo browserplugin bzip2 cairo caps cast cdaudio cdb cdda cddb cdio cdparanoia cdr chroot cjk commercial crypt cscope cups curl dba dbus dga dhcp directfb disablexmb divx4linux dlloader dmx dts dumb dv dvb dvd dvdr dvdread dvi dynagraph edl eds emboss encode enscript erandom escreen esd ethereal etwin evo exif expat extensions extras fam fame fb2k fbcon ffmpeg flac flash font-server foomaticdb fortran freetds freetype gd gd-external geoip gg ggi gif gimpprint glitz glut gmp gnokii gnome gnutls gphoto2 gpm graphviz gstreamer gtk gtk2 gtkhtml guile httpd i8x0 icq idn ieee1394 imagemagick imap imlib inherit-graph insecure-drivers ipv6 irc irda ithreads jabber jack java jikes joystick jpeg jpeg2k junit kerberos kjofol krb4 latex lcms ldap libao libcaca libg++ libwww lirc live lj lm_sensors logrotate lua lzo mad mailwrapper matroska mcal md5sum mhash mikmod ming mjpeg mmx mmx2 mmxext mng modperl modplug mono motif mozcalendar mozdevelop mozilla moznomail mozsvg mozxmlterm mp3 mpeg mppe-mppc msn musepack mysql mythtv nas ncurses net nethack netpbm network neural nls nntp nocd nptl nptlonly nsplugin ntlm oci8 odbc offensive ogg oggvorbis openal openexr opengl openssh oss pam pam_console pango pcre pda pdflib perl pg-hier pg-intdatetime php playlist plotutils png portaudio postgres ppds procmail psyco pyste python qt quicktime rdesktop readline real recode remote rplay rrdtool rss rtc ruby samba sasl sdl session sftplogging shaper shorten sid silc skey slang slp sms sndfile snmp socks5 softquota soundtouch sox speex spell sqlite sqlite3 sse sse2 ssl startup-notification stats stream stroke subversion svg svga symlink t1lib talkfilters tcltk tcpd tetex tga theora threads tidy tiff timidity tools truetype truetype-fonts type1-fonts udev underscores unicode urandom usb userlocales v4l v4l2 vcd vchroot vim-with-x vlm vorbis vqf wav wifi win32codecs wma wmf wxgtk1 xanim xchatdccserver xchattext xface xine xinerama xml xml2 xmms xosd xprint xrandr xscreensaver xv xvid xvmc yahoo yaz yv12 zero-penalty-hit zlib video_cards_radeon userland_GNU kernel_linux elibc_glibc"
Comment 1 Jonh Smith 2006-01-02 02:31:35 UTC
Created attachment 75980 [details]
speex emerge log

added emerge log
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-01-02 02:39:49 UTC
Reopen if it still fails with C[XX]FLAGS="-march=pentium4 -fomit-frame-pointer -pipe -O1"
Comment 3 Jonh Smith 2006-01-02 02:45:53 UTC
yup :( i tried this:

CFLAGS="-march=pentium4 -fomit-frame-pointer -pipe -O1" CXXFLAGS="-march=pentium4 -fomit-frame-pointer -pipe -O1" emerge speex

and it still fails :( Am I doing it wrong? Everything else compiles ok!
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-01-02 03:16:42 UTC

*** This bug has been marked as a duplicate of 20600 ***
Comment 5 Beetle B. 2008-05-17 17:52:24 UTC
I had the same symptoms for speex. I found the following <a href="">bug</a> (bug #207662). Renaming the /usr/local/lib/ (which did not belong to any package) worked for me as well. 

I'm not sure this is the same problem the original poster had, but I thought I'd point it out for anyone who comes looking (this bug easier to find than the one I linked to).