Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 127130 - emerge gcc-3.4.5 fails
Summary: emerge gcc-3.4.5 fails
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 127129 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-21 17:58 UTC by theHog
Modified: 2006-03-22 04:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description theHog 2006-03-21 17:58:19 UTC
When emerging gcc-3.4.5, a segmentation fault occurs. Info is attached below:

emerge world
...
stage1/xgcc -Bstage1/ -B/usr/i686-pc-linux-gnu/bin/ -c    -march=i686 -O2 -pipe -fprofile-generate -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes     -DHAVE_CONFIG_H    -I. -If -I/var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/gcc -I/var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/gcc/f -I/var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/gcc/../include  /var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/gcc/f/expr.c -o f/expr.o
/var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/gcc/f/expr.c: In function `ffeexpr_reduce_':
/var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/gcc/f/expr.c:9112: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [f/expr.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/gcc-3.4.5/work/build/gcc'
make[1]: *** [stageprofile_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.4.5/work/build/gcc'
make: *** [profiledbootstrap] Error 2

!!! ERROR: sys-devel/gcc-3.4.5 failed.
!!! Function gcc_do_make, Line 1356, Exitcode 2
!!! emake failed with profiledbootstrap
!!! If you need support, post the topmost build error, NOT this status message.

zeus ~ # emerge --info
Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.15.1 i686)
=================================================================
System uname: 2.6.15.1 i686 VIA Nehemiah
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -mmmx -msse -mfpmath=sse -O2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=i686 -mmmx -msse -mfpmath=sse -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo  ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/local/gentoo/usr/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts audiofile avi berkdb bitmap-fonts bzip2 crypt cups dri eds emboss encode expat ffmpeg flac foomaticdb fortran gdbm gif gmp gnome gpm gstreamer gtk gtk2 imlib ipv6 jpeg kde libg++ libwww lirc mad mikmod motif mp3 mpeg ncurses nls nptl nptlonly ogg oggvorbis opengl oss pam pcre pdflib perl png python qt quicktime readline samba sdl spell sqlite ssl tcpd truetype truetype-fonts type1-fonts udev usb vorbis xine xml2 xmms xv xvid zlib video_cards_via userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-21 23:00:40 UTC
*** Bug 127129 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-03-21 23:02:15 UTC
Can you reproduce the problem, i.e. does it fail at *exactly* the same place again?
Comment 3 theHog 2006-03-22 04:14:45 UTC
(In reply to comment #2)
> Can you reproduce the problem, i.e. does it fail at *exactly* the same place
> again?
> 

No, gcc does fail every time, but on different files. I ran memtest86 to test for memory errors but that didn't show any problems. I never had a problem with the machine before.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-03-22 04:36:55 UTC
(In reply to comment #3)
> No, gcc does fail every time, but on different files. I ran memtest86 to test
> for memory errors but that didn't show any problems. I never had a problem with
> the machine before.

See the other bug for suggestions.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-03-22 04:37:10 UTC

*** This bug has been marked as a duplicate of 20600 ***