Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 33716 - binutils fails to emerge; binutils-
Summary: binutils fails to emerge; binutils-
Status: RESOLVED DUPLICATE of bug 20600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
: 33720 (view as bug list)
Depends on:
Reported: 2003-11-17 17:02 UTC by jack
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description jack 2003-11-17 17:02:20 UTC
when doing an 'emerge -u world', emerge failed at binutils.
tried 'emerge -u --deep world', 'emerge binutils', 'emerge -deep binutils'. All
produce same results. Tried adjusting CFLAGS from '-O3 -march=pentium2 -pipe
-funroll-loops' to '-O3 -mcpu=i686 -pipe'.

Reproducible: Always
Steps to Reproduce:
1. emerge -u world or emerge binutils

Actual Results:  
Always fails at the same spot.


gcc -DHAVE_CONFIG_H -I. -I. -I. -D_GNU_SOURCE -DTRAD_CORE -I. -I. -I./../include
-I./../intl -I../intl -W -Wall -Wstrict-prototypes -Wmissing-prototypes -O3
-mcpu=i686 -pipe -c efi-app-ia32.c -o efi-app-ia32.o >/dev/null 2>&1
make[3]: *** [aout32.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory
make: *** [all-bfd] Error 2
!!! ERROR: sys-devel/binutils- failed.
!!! Function src_compile, Line 140, Exitcode 2
!!! (no error message)

Expected Results:  
update binutils- to binutils-

# uname -a
Linux celery 2.4.20-gaming-r3 #1 SMP Wed Oct 8 06:28:30 EST 2003 i686 Celeron
(Mendocino) GenuineIntel GNU/Linux

# emerge info
Portage 2.0.49-r15 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r3, 2.4.20-gaming-r3 )
System uname: 2.4.20-gaming-r3 i686 Celeron (Mendocino)
Gentoo Base System version
CFLAGS="-O3 -mcpu=i686 -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/confi
g /usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -mcpu=i686 -pipe"
FEATURES="sandbox ccache autoaddcvs"
GENTOO_MIRRORS=" http://csociety-ftp.ecn.p ftp://g"
USE="x86 oss apm avi crypt cups encode foomaticdb gif jpeg kde libg++ libwww mad
 mikmod motif mpeg ncurses nls pdflib png quicktime slang spell truetype xml2 xm
ms xv zlib directfb gtkhtml gdbm berkdb readline arts bonobo svga java mysql pos
tgres sdl gpm tcpd pam ssl perl esd imlib oggvorbis qt opengl mozilla voodoo3 X
gtk gnome 3dfx dga mmx tcltk python alsa video_cards_3dfx"
Comment 1 jack 2003-11-18 15:32:45 UTC
*** Bug 33720 has been marked as a duplicate of this bug. ***
Comment 2 jack 2003-11-19 16:57:26 UTC

*** This bug has been marked as a duplicate of 20600 ***