Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245954 (kde-3.5.10) - [TRACKER] KDE 3.5.10
Summary: [TRACKER] KDE 3.5.10
Status: RESOLVED FIXED
Alias: kde-3.5.10
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: Tracker
: 247288 261937 (view as bug list)
Depends on: 163873 178853 185283 189364 194668 204231 206936 207809 209565 212412 212507 213794 214198 215687 216603 219533 224263 224265 224389 224777 225115 225213 225567 225691 226399 228323 229135 231685 231996 232649 233328 234326 234624 235885 237206 237641 237905 239233 240560 241288 241432 241678 241782 241786 242166 242796 243076 243110 243434 243476 243998 244322 244906 244994 245509 245541 245604 245640 245714 246555 247817 249166 249806 250683 252275 252278 252427 252739 253018 256053 256055 257603 257625 258631 260182 260837 262397 263454 264611 264767 265136 265248 265517 268049 269029 269767 270129 270601 270926 271372 271446
Blocks: 271889
  Show dependency tree
 
Reported: 2008-11-07 12:56 UTC by Jan Kundrát (RETIRED)
Modified: 2009-11-21 19:01 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for kde(3) eclasses setting prefix to /usr/kde/3.5 (kde-functions.eclass,29.58 KB, patch)
2008-11-26 15:58 UTC, Maciej Mrozowski
Details | Diff
upps - this should be instead (kde-functions.eclass.diff,1.08 KB, patch)
2008-11-26 16:06 UTC, Maciej Mrozowski
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Kundrát (RETIRED) gentoo-dev 2008-11-07 12:56:13 UTC
All issues concerning the 3.5.10 release of KDE are supposed to block this one.
Comment 1 Jeroen Roovers gentoo-dev 2008-11-18 14:54:24 UTC
*** Bug 247288 has been marked as a duplicate of this bug. ***
Comment 2 Maciej Mrozowski gentoo-dev 2008-11-26 15:58:41 UTC
Created attachment 173479 [details, diff]
patch for kde(3) eclasses setting prefix to /usr/kde/3.5

This patch changes kde eclasses so that most KDE3 (need-kde 3 or 3.5) apps are installed with the same prefix as KDE3 - could anyone test it?
There are still problems with (possibly) several ebuilds - especially with those that f*** with hardcoded prefix and/or don't use autoconf:

so far I discovered:
x11-themes/gtk-engines-qt (uses cmake and /usr/share hardcoded paths)
Comment 3 Maciej Mrozowski gentoo-dev 2008-11-26 16:06:19 UTC
Created attachment 173480 [details, diff]
upps - this should be instead

resubmitted (patch this time)
Comment 4 Rick Harris 2008-12-04 09:37:12 UTC
Tried some preliminary testing of this patch to kde-functions.eclass and can immediately see a few problems with users using 'kdeprefix'.
I am using KDE4 as my main desktop, but use a few 3rd party/non-kdebase KDE3 apps in the KDE4 environment.
So far have tested this eclass installing with net-irc/konversation, but same will apply to all 3rd party apps that inherit kde.eclass for installation.

To the breakage:
* Binaries get installed in /usr/kde/3.5/bin/ leaving KDE4 unable to find them as this is not in $PATH in a KDE4 session.
* *.desktop files get installed in /usr/kde/3.5/share/applications/kde/ leaving KDE4 unable to find them.
* Icon breakage is still there using KDE3 apps in a KDE4 session, however this is also currently the case with the original unpatched kde-functions.eclass.

Note - The icon breakage is due to KDE4 not seeing icons installed in the default KDE3 3rd party apps icon location of '/usr/share/icons/hicolor/'. This is because the default KDE3 icontheme (crystalsvg) in KDE4, fails to inherit hicolor in crystalsvg/index.theme.
Comment 5 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-26 12:09:29 UTC
The eclasses already hit the tree, i'll keep this tracker bug for 3.5
Comment 6 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 01:33:16 UTC
All kde-base/*-3.5* bugs wrangled today. I'll fix the most important and propose the kde-3.5.10 stabilization and 3.5.9 (monos and splits) removal after. Keep in mind that many of those bugs will be UPSTREAM/CANTFIX/WONTFIX as kde3 upstream development is frozen. Thanks
Comment 7 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-05-29 22:53:59 UTC
*** Bug 261937 has been marked as a duplicate of this bug. ***
Comment 8 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-30 17:48:33 UTC
Stabilization bug opened: bug 271889
cheers!
Comment 9 Samuli Suominen gentoo-dev 2009-10-27 19:12:48 UTC
Obsolete TRACKER. KDE3 is about to be removed from tree.
Comment 10 Oliver Borm 2009-11-21 19:01:35 UTC
(In reply to comment #9)
> Obsolete TRACKER. KDE3 is about to be removed from tree.
> 

 # Samuli Suominen <ssuominen@gentoo.org> (07 Nov 2009)
 # 	 
 # Mask KDE 3.5.10 for removal, excluding the dependencies 	 
 # required for stable koffice. Removed in 30 days. 	 
 #

Does the clock tick a little bit different in the new KDE4, or why was KDE3 removed already 12 days after announcement?