Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256053 - kde-base/kicker-3.5.10: menu edit command silently fails unless kde-base/kmenuedit is installed
Summary: kde-base/kicker-3.5.10: menu edit command silently fails unless kde-base/kmen...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2009-01-22 23:56 UTC by Erik
Modified: 2009-05-27 23:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik 2009-01-22 23:56:11 UTC
Kicker's menu edit command silently fails unless kde-base/kmenuedit is installed.

Reproducible: Always

Steps to Reproduce:
1. Install kde-base/kicker but not kde-base/kmenuedit.
2. Log into a KDE session.
3. Right-click on the K-button in the panel.
4. Select the menu item "Menu Editor".
Actual Results:  
none

Expected Results:  
The menu editor is opened.

If Kicker offers a menu item to edit the menu, something must happen when that menu item is selected. Silently doing nothing is not acceptable. There are a few options to solve this:
0. Include kmenuedit in kde-base/kicker.
1. Make kde-base/kicker and kde-base/kmenuedit depend on each other (since none of them works right without the other).
2. Do not show the menu item unless kmenuedit is installed.
3. When the menu item is activated, show a dialog explaining that kde-base/kmenuedit must be installed to use this feature.
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 23:38:25 UTC
kmenuedit added as runtime depedency of kicker-3.5.10, thanks for report