Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235885 - KPDF crashes
Summary: KPDF crashes
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-08-27 09:38 UTC by Yann Forget
Modified: 2009-05-29 14:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yann Forget 2008-08-27 09:38:33 UTC
Hello,

KPDF 3.5.9 crashes while trying to open this document: http://www.geneve.ch/emploi/brochures/pdf/brochure_e301.pdf

Regards,
Yann


Reproducible: Always

Steps to Reproduce:
1. Click on the link
2.
3.
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-08-27 09:45:51 UTC
Which version of poppler do you have installed? 
Comment 2 Yann Forget 2008-08-27 10:14:30 UTC
app-text/poppler 0.6.3-r1
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-08-27 10:27:11 UTC
could you do:
echo "app-text/poppler-bindings-0.8.6" >> /etc/portage/package.keywords
echo "app-text/poppler-0.8.6" >> /etc/portage/package.keywords

and upgrade to that version and see if you can reproduce?
If that fixes it, we should probably think about stabling poppler-0.8.6
Comment 4 Yann Forget 2008-08-27 15:11:37 UTC
I upgrade both app-text/poppler and app-text/poppler-bindings to 0.8.6
But, now I have a dependency problem:

app-text/poppler-bindings:0

  ('ebuild', '/', 'app-text/poppler-bindings-0.6.3', 'merge') pulled in by
    ('installed', '/', 'media-gfx/inkscape-0.46-r2', 'nomerge')

  ('installed', '/', 'app-text/poppler-bindings-0.8.6', 'nomerge') pulled in by
    ('installed', '/', 'media-gfx/gimp-2.4.2', 'nomerge')
    ('installed', '/', 'kde-base/kpdf-3.5.9', 'nomerge')

app-text/poppler:0

  ('ebuild', '/', 'app-text/poppler-0.6.3-r1', 'merge') pulled in by
    ('ebuild', '/', 'app-text/poppler-bindings-0.6.3', 'merge')

  ('installed', '/', 'app-text/poppler-0.8.6', 'nomerge') pulled in by
    ('installed', '/', 'net-print/cups-1.3.7-r1', 'nomerge')
    ('installed', '/', 'kde-base/kpdf-3.5.9', 'nomerge')
    ('installed', '/', 'app-text/poppler-bindings-0.8.6', 'nomerge')

I am not sure what I need to do at this point, to resolve this.
revdep-rebuild tries to downgrade both packages.
kpdf still crashes.
Comment 5 Carsten Lohrke (RETIRED) gentoo-dev 2008-08-27 16:11:41 UTC
@Peter: poppler is not relevant, since only the kfile plugin is using it, but not kpdf itself. The kpdf/poppler patches from Kubuntu halfway forced upon us only introduced new bugs and pissed off upstream.

@Yann: Good news is kpdf from KDE 3.5.10 doesn't crash - on the other hand, I don't know, if it would have with 3.5.9 on my box. Bad news is that I've to crawl bugs before committing 3.5.10.
Comment 6 Timo Gurr (RETIRED) gentoo-dev 2008-08-27 18:32:19 UTC
The file didn't crash on my machine at work which is running ~x86 (KDE 3.5.9).

@Yann: Does gs crash if you try to open the file from commandline via $ gs your.pdf? Which ghostscript do you have installed and which version?
Comment 7 Yann Forget 2008-08-28 18:27:06 UTC
$ gs brochure_e301.pdf
ESP Ghostscript 815.04 (2007-03-14)
Copyright (C) 2004 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 4.
Page 1
%%BoundingBox: 0 13 421 596
%%HiResBoundingBox: 0.000000 13.410000 420.947987 595.277982
>>showpage, press <return> to continue<<

Page 2
%%BoundingBox: 0 30 421 596
%%HiResBoundingBox: 0.000000 30.419999 420.947987 595.277982
>>showpage, press <return> to continue<<

Page 3

%%BoundingBox: 0 0 421 552
%%HiResBoundingBox: 0.000000 0.000000 420.947987 551.519983
>>showpage, press <return> to continue<<
Page 4
%%BoundingBox: 0 41 421 596
%%HiResBoundingBox: 0.000000 41.197007 420.947987 595.277982
>>showpage, press <return> to continue<<

GS>
Comment 8 Yann Forget 2008-08-28 18:29:15 UTC
kghostview opens it, but the first page is not displayed correctly.
Comment 9 Timo Gurr (RETIRED) gentoo-dev 2008-08-28 22:15:04 UTC
Please use ghostscript-gpl instead, ghostscript-esp is heavily outdated and no longer developed (actually it has been merged with/into ghostscript-gpl upstream). 

emerge -C ghostscript-esp && emerge ghostscript-gpl --oneshot && revdep-rebuild
Comment 10 Yann Forget 2008-08-28 22:44:01 UTC
$ gs brochure_e301.pdf
GPL Ghostscript 8.62 (2008-02-29)
Copyright (C) 2008 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 4.
Page 1
>>showpage, press <return> to continue<<

Page 2
>>showpage, press <return> to continue<<

Page 3
>>showpage, press <return> to continue<<

Page 4
>>showpage, press <return> to continue<<

GS>

I upgraded GS. The document is now displayed like in kghostscript. Kpdf still crashes.
Comment 11 Timo Gurr (RETIRED) gentoo-dev 2008-08-28 22:57:00 UTC
Ok, you could try ghostscript 8.63 (and revdep-rebuild again). If 8.63 also doesn't solve your problem I'd suggest to wait a few days until KDE 3.5.10 hits the tree.
Comment 12 Carsten Lohrke (RETIRED) gentoo-dev 2008-08-29 00:12:26 UTC
Would you please provide `emerge --info` output, Yann!?
Comment 13 Yann Forget 2008-08-29 09:20:32 UTC
$ emerge --info
Portage 2.1.4.4 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-3-amd64 x86_64)
=================================================================
System uname: 2.6.22-3-amd64 x86_64 AMD Opteron(tm) Processor 242
Timestamp of tree: Thu, 28 Aug 2008 12:18:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.3.6-r3, 2.4.4-r13, 2.5.2-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -pipe -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -pipe -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr hi gu"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl alsa amd64 arts avi bash-completion berkdb bittorrent bzip2 cdr cjk cli cracklib crypt css cups dbus djvu doc dri dv dvb dvd dvdr dvdread enca encode exif fbcon ffmpeg foomaticdb fortran ftp gdbm gif gimp gimpprint gphoto2 gpm iconv imlib innodb java jpeg kde kdeenablefinal logrotate maildir mbox midi mime mozilla mozsvg mp3 mpeg mplayer mudflap multilib ncurses network nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png posix postfix pppd print python qt qt3 qt4 quicktime readline realmedia recode reflection replytolist rtc rtsp scanner sdl serial session smp spl sse sse2 ssl stream svg sysfs tcpd tetex theora threads tiff transcode truetype unicode usb userlocales v4l v4l2 vcd vdr vim-syntax vorbis wma xine xml xorg xpm xprint xvid xvmc zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr hi gu" USERLAND="GNU" VIDEO_CARDS="ati vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 14 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 14:51:40 UTC
crashes should be reported upstream, but since kde3 development is frozen you can't. Try to upgrade to 3.5.10 and update all deps. We can't do anything so closing