Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250683 - kde 3.5: unable to unmount flash drive - no entry in hal-mtab
Summary: kde 3.5: unable to unmount flash drive - no entry in hal-mtab
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-12-12 09:41 UTC by Paul Hewlett
Modified: 2009-05-29 18:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Hewlett 2008-12-12 09:41:06 UTC
Inserting a flash drive in a USB socket causes /dev/sdb1 to be mounted as /media/sdb1. When selecting 'Safely remove' on the icon on the kde desktop a dialog appears stating that hal cannot unmount the drive because there is no corresponding entry in /media/.hal-mtab.  

Reproducible: Always

Steps to Reproduce:
1.Insert flash drive in USB socket
2.Open drive by clicking on icon on desktop
3.Close window that opens 
4.Select 'Safely remove' - dialog appears with error message. The only way to unmount the drive is to revert to the commandline and type 'umount /media/sdb1'.




Expected Results:  
Firstly a dialog should have appeared when the flash drive was inserted asking what to do with the mounted directory ('Do nothing'/'open folder'/....). Secondly the drive should be safely unmounted when 'Safely remove' was selected instead of having to revert to the command line.

I found a solution that works. I have kde 3.5 installed but also openoffice etc. Also the 'hal' USE flag is set in /etc/make.conf. This causes gnome-vfs to be compiled with the 'hal' USE flag which in turn emerges gnome-mount. Googling reveals that on other distros gnome-mount seems to misbehave when unmounting USB drives (distros mentioned are Ubuntu,Arch...). I added the line 'gnome-base/gnome-vfs -hal' to /etc/portage/package.use, re-emerged update and depclean (which removed gnome-mount) and now all is well. Plugging the USB drive mounts the drive and prompts with the correct dialog window, clicking 'Safely Remove' works correctly.
Comment 1 Paul Hewlett 2008-12-12 09:44:44 UTC
dirac ~ # emerge --info
Portage 2.1.4.5 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.26-gentoo-r4 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
Timestamp of tree: Wed, 10 Dec 2008 13:15:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7-r1, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona -mno-tls-direct-seg-refs"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.qubenet.net/mirror/gentoo/ http://mirror.bytemark.co.uk/gentoo/ http://ftp.heanet.ie/pub/gentoo/ http://gentoo.tiscali.nl/"
LC_ALL="en_ZA.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US af_ZA en_ZA st_ZA xh_ZA zu_ZA en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X X509 aac ace acl acm acpi activefilter administrator afs akode alac alias alsa amarok amavis amd64 amr amrnb amrr amrwb analogtv apache2 apm berkdb blender-game bluetooth bzip2 caps cdaudio cdda cddb cdio cdparanoia cdr cgi cjk clamav clamd cli console cpudetection cracklib crypt cups cvs cvsgraph dba dbm dbus dovecot-sasl dri dts dv dvb dvd dvdr dvdread emovix emulation encode expat firefox firefox3 flac fortran gdbm gif gmail gpg gpm gsm hal httpd hvm icecast iconv ilbc imap ipod ipv6 ipw4965 isdnlog java java6 javascript jbig jpeg kde kdm kerberos kexi kig-scripting ktts kvm laptop lcms libwww lm_sensors loop-aes lzma lzo maildir memcache midi mmx mng mp3 mp4 mp4live mpd mpeg mudflap multilib mysql mysqli ncurses netboot network network-cron nfs nls nptl nptlonly opengl openmp oss pam pcre pdf perl pg-hier pg-intdatetime pg-vacuumdelay php plotutils pmu png portaudio posix postfix postgis postgres ppds pppd procmail python qt3 qt3support quotas rar raw rdesktop readline realmedia reflection reiserfs resolvconf rpm rss samba sasl sdl session slp smp sms spamassassin speex spl sql sqlite sse sse2 ssl startup-notification stream subversion svg swat sysfs tcpd theora threads tiff truetype unicode unzip usb utempter uuencode v4l2 valgrind video vim-pager vim-syntax vim-with-x vistafree visualization vnc vncviewer voice vorbis vorbis-psy webdav webdav-neon webdav-serf webpresence wifi winbind wininst winpopup wma wmf wmp wordperfect xattr xcomposite xft xine xinerama xorg xosd xpm xprint xrandr xrender xscreensaver xulrunner xv xvid xvmc xvnc zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US af_ZA en_ZA st_ZA xh_ZA zu_ZA en_GB" USERLAND="GNU" VIDEO_CARDS="fbdev vesa intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 2 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 18:43:37 UTC
Is your user in groups plugdev usb? Also make sure hald is started, and also take a look at various documentations for auto-mounting. Since this is a problem with your system and not something wrong with kde3, i'll have to close this. If you need any help, step by #gentoo-kde in IRC (freenode)