Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256055 - kde-base/konqueror stucks when trying to open / via konqueror
Summary: kde-base/konqueror stucks when trying to open / via konqueror
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2009-01-23 00:46 UTC by Alex
Modified: 2009-05-27 21:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
debug output (core.zip,206.77 KB, application/octet-stream)
2009-01-23 00:51 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2009-01-23 00:46:17 UTC
Faced this problem yesterday. Problem appears to present both in in kde-3.5 and kde-4.1
when trying to enter path starting with / (or just /) konqueror doesn't respond and the only way is to kill him
right after rebooting it appears to open / correctly but in several minutes it will not response as well

Reproducible: Always

Steps to Reproduce:
1.open konqueror
2.start typing path to local folder (/home/~username/ for ex., it doesn't matter, it should start with / - this is general requirement)
3.

Actual Results:  
konqueror doesn't response after first slash entered

Expected Results:  
path should be entered correctly and open after it :)

vulzscht@mad_tux ~ $ eix konqueror
[I] kde-base/konqueror
     Available versions:
        (3.5)   3.5.9 (~)3.5.10
        (4.1)   (~)4.1.4!t
        {arts branding debug elibc_FreeBSD htmlhandbook java kdeenablefinal kdehiddenvisibility kdeprefix xinerama}
     Installed versions:  3.5.10(3.5)(08:35:18 21.01.2009)(debug -branding -elibc_FreeBSD -java -kdehiddenvisibility)
                          4.1.4(4.1)!t(05:34:10 16.01.2009)(kdeprefix -debug -htmlhandbook)
     Homepage:            http://www.kde.org/
     Description:         KDE: Web browser, file manager, ...


vulzscht@mad_tux ~ $ emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r1, 2.6.25-gentoo-r9 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r9-i686-Intel-R-_Pentium-R-_4_CPU_2.00GHz-with-glibc2.0
Timestamp of tree: Thu, 22 Jan 2009 19:45:02 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.4-r11, 2.5.4
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-apps/sandbox:    1.3.2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="ru en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/vmware /usr/portage/local/layman/sunrise /usr/portage/local/layman/games /usr/portage/local/layman/openrc /usr/portage/local/layman/verlihub /usr/portage/local/layman/zugaina /usr/portage/local/layman/desktop-effects"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi agent ahavi alsa apache2 arts atm bash-completion bluetooth branding bzip2 cairo caps cddb cdparanoia cdr cli cracklib crypt cscope css cups curl dbus dri dts dvb dvd dvdr dvdread eds embedded encode enscript esd examples exif fam ffmpeg flac foomaticdb fortran frontend ftp fuse gdbm gif glitz glut gnutls gpm gsl gstreamer gtk hal hddtemp iconv ide ieee1394 imagemagick imlib ipv6 isdnlog jabber jack java javascript jbig jpeg jpeg2k kde kde4 kdeprefix kerberos kpathsea ladspa lame lcms ldap libcaca lirc lm_sensors lua mad matroska midi mikmod mng modplug mono mp3 mpeg mplayer mudflap musepack musicbrainz mysql nas ncurces ncurses netboot nls nntp nptl nptlonly ntl ogg openal openexr opengl openmp oracle pam pcre pdf perl php png pppd python qt qt3 qt4 quicktime readline reflection samba scanner sdl session slang snmp source spell spl sse sse2 ssl subversion svg svga sysfs syslog tcl tcpd tiff truetype unicode usb v4l v4l2 vcd vhosts vnc vorbis wavpack webdav websvccommon wifi win32codecs x264 x86 xattr xcb xinerama xinetd xml xorg xulrunner xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="nvidia v4l vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

after rebuilding konqueror with debug flag files core.???? appeared in the / folder, so i will attach one to see if it can help

i suppose it is a local issue, however any feedback will be greatly appreciated

feel free to ask any additional information
Comment 1 Alex 2009-01-23 00:51:28 UTC
Created attachment 179400 [details]
debug output

debug output (seem for me..)
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-01-23 00:58:58 UTC
Bad news, i really cant reproduce on 4.1.4 and 4.2.0. (2 various pcs)
So something is borked localy, but i have no clue what.
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 21:31:57 UTC
I can't reproduce in 3.5 either, i'll agree with Tomas, something is b0rked with your system