Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 185283 - Errors in KDE session if environment variable TMPDIR is set up
Summary: Errors in KDE session if environment variable TMPDIR is set up
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2007-07-14 10:07 UTC by Michalis Giannakidis
Modified: 2009-05-27 08:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
output of emerge --info (emerge__info,3.17 KB, text/plain)
2007-08-26 09:16 UTC, Michalis Giannakidis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michalis Giannakidis 2007-07-14 10:07:40 UTC
I set up the TMPDIR in my environment, so that temporary files go in ~/tmp instead of /tmp. This causes some errors and strange behavior in the KDE session.

From the  .xsession-errors:

kbuildsycoca running...
Error: "/home/mgiann/.kde/socket-makis" points to "/home/mgiann/tmp/ksocket-mgiann" instead of "/tmp/ksocket-mgiann".

Error: "/home/mgiann/.kde/socket-makis" points to "/home/mgiann/tmp/ksocket-mgiann" instead of "/tmp/ksocket-mgiann".
Warning: connect() failed: : No such file or directory
There are already artsd objects registered, looking if they are active...

Error: Can't add object reference (probably artsd is already running).
       If you are sure it is not already running, remove the relevant files:

       /tmp/ksocket-mgiann/Arts_SoundServerV2
       /tmp/ksocket-mgiann/Arts_SoundServer
       /tmp/ksocket-mgiann/Arts_SimpleSoundServer
       /tmp/ksocket-mgiann/Arts_PlayObjectFactory
       /tmp/ksocket-mgiann/Arts_AudioManager

See errors about wrong paths to tmp directories.

The TMPDIR variable has as a result that the first KDE session I start has no knotify running. The next session i start, finds that the last knotity execution failed and starts it up with a warning. Later, when I try to close such session, it takes longer than expected (close to 1min instead of 2-3 seconds). Finally, the temporary data seem to be shared among my ~/tmp (where I want them) and /tmp. 

KDE: 3.5.5
kdelibs version installed: 3.5.5-r9
kdebase version installed: 3.5.5-r3


Reproducible: Always

Steps to Reproduce:
1.in .tcshrc: setenv TMPDIR /home/mgiann/tmp
2.
3.
Comment 1 Wulf Krueger (RETIRED) gentoo-dev 2007-07-21 23:23:53 UTC
Please try to reproduce this problem in KDE 3.5.7 if you can. 3.5.7 is scheduled to go to stable soon anyway.
Comment 2 Wulf Krueger (RETIRED) gentoo-dev 2007-08-22 15:13:50 UTC
Please test with 3.5.7 which is now stable and provide your emerge --info if the problem persists.
Comment 3 Michalis Giannakidis 2007-08-26 09:16:25 UTC
Created attachment 129205 [details]
output of emerge --info
Comment 4 Michalis Giannakidis 2007-08-26 09:19:00 UTC
Comment on attachment 129205 [details]
output of emerge --info

I updated the complete system( emerge -N --deep world), not without problems... 

The problem still persists, as it was describe in the initial report.
Comment 5 Michalis Giannakidis 2007-08-29 10:43:26 UTC
provide the information requested.
Comment 6 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-26 12:15:18 UTC
Please see if this bug still persists in kde-3.5.10
Comment 7 Michalis Giannakidis 2009-05-26 16:18:19 UTC
(In reply to comment #6)
> Please see if this bug still persists in kde-3.5.10
> 

Unable to upgrade to kde-3.5.10 and test. Sorry.
Comment 8 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-26 16:21:41 UTC
OK, since there was no other user with similar problem and given the state of kde3.5, i'll have to close this. Euxaristo :)