Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 232649 - kwin does not maximize windows correctly when using multihead (but not xinerama)
Summary: kwin does not maximize windows correctly when using multihead (but not xinerama)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: http://bugs.kde.org/show_bug.cgi?id=9...
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-07-22 13:35 UTC by David Flogeras
Modified: 2009-06-02 12:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Flogeras 2008-07-22 13:35:40 UTC
Since kwin-3.5.9 (it worked fine in 3.5.8) the attached upstream bug is back (see url attached).  I believe it is due to the gentoo specific kdebase-kwin-only-seli-xinerama.patch since it seems to revert the changes that were discussed in the upstream bug report.

Reproducible: Always

Steps to Reproduce:
1. Use multihead displays with two different vertical resolutions, with a separate kwin on both screens (no xinerama)
2. Open a window on the screen with lower vertical resolution
3. Maximize the window.

Actual Results:  
The window will be partially hidden by the panel at the bottom of the screen

Expected Results:  
The window should stop at the panel when maximized, not be hidden under it.
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 12:48:06 UTC
Does this still happen in 3.5.10?
Comment 2 David Flogeras 2009-06-01 23:51:42 UTC
Nope, can't seem to reproduce it with kwin-3.5.10, will close when 3.5.10 goes stable?
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-02 12:24:05 UTC
3.5.10 is about to be stable, i opened the bug and we are waiting for the ARCH teams to do it. More info bug 271889. Thanks