Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260837 - emerge kde-base/ksvg-3.5.10 fail with undefined reference to `fribidi_log2vis'
Summary: emerge kde-base/ksvg-3.5.10 fail with undefined reference to `fribidi_log2vis'
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 257024 (view as bug list)
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2009-03-02 09:29 UTC by RomanVRE
Modified: 2009-05-27 10:53 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild (ksvg-3.5.10.ebuild,614 bytes, text/plain)
2009-03-13 22:33 UTC, Dmitry Halturin
Details
patch (001-fribidi.diff,2.12 KB, patch)
2009-03-13 22:35 UTC, Dmitry Halturin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description RomanVRE 2009-03-02 09:29:40 UTC
Emerging kde-meta:3.5 in for ~x86 (install latest environment in chroot from stage3) will fail on kde-base/ksvg-3.5.10 with error:
======================================================================
/var/tmp/portage/kde-base/ksvg-3.5.10/work/ksvg-3.5.10/ksvg/impl/libs/libtext2path/src/.libs/libtext2path.so: undefined reference to `fribidi_log2vis'
collect2: ld returned 1 exit status
make[2]: *** [svgdisplay] Error 1
make[2]: Leaving directory `/var/tmp/portage/kde-base/ksvg-3.5.10/work/ksvg-3.5.10/ksvg/test/external'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kde-base/ksvg-3.5.10/work/ksvg-3.5.10/ksvg/test'
make: *** [install-recursive] Error 1
========================================================================
gcc version is i686-pc-linux-gnu-4.3.3
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-02 11:03:10 UTC
Please post your "emerge --info" and the output of
  emerge -qpv fribidi
Comment 2 RomanVRE 2009-03-02 14:22:49 UTC
(In reply to comment #1)
> Please post your "emerge --info" and the output of
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-i686-AMD_Sempron-tm-_Processor_3400+-with-glibc2.0
Timestamp of tree: Fri, 27 Feb 2009 19:30:14 +0000
app-shells/bash:     3.2_p48-r1
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.3.8
sys-devel/autoconf:  2.63
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -fomit-frame-pointer -pipe -O2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=i686 -fomit-frame-pointer -pipe -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://toto.tomsk.ru                 ftp://ftp.ggf.tsu.ru/                 ftp://79.136.132.145/gentoo/                 ftp://ftp-tsk-01.gentoo.tonet.ru                 ftp://ftp-tsk-05.gentoo.tonet.ru"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/portage-ggergely-overlay /usr/portage/local/my-overlay /usr/portage/local/layman/sunrise /usr/portage/local/layman/rusxmms /usr/portage/local/layman/synce"
SYNC="rsync://toto.tomsk.ru/gentoo-portage/"
USE="X acl alsa apm arts berkdb bzip2 cli cracklib crypt cups dri encode flac fortran gdbm gpm hal iconv ipv6 isdnlog jpeg2k lm_sensors lua midi mp3 mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl pppd python qt3 readline reflection session spl ssl sysfs tcpd theora unicode vorbis wifi x86 xcomposite xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
=================================================================
>   emerge -qpv fribidi
[ebuild   R   ] dev-libs/fribidi-0.19.1
/etc/make.conf ========================================
CFLAGS="-march=i686 -fomit-frame-pointer -pipe -O2"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j1"

USE="hal X apm lm_sensors opengl wifi encode flac mp3 vorbis xcomposite arts theora alsa jpeg2k lua qt3 -qt4 "

ACCEPT_KEYWORDS="~x86"

LANGUAGE="ru"
LINGUAS="ru"
LC_ALL="ru_RU.UTF-8"

VIDEO_CARDS="intel"
INPUT_DEVICES="evdev synaptics mouse keyboard"

SYNC="rsync://toto.tomsk.ru/gentoo-portage/"

GENTOO_MIRRORS="ftp://toto.tomsk.ru \
                ftp://ftp.ggf.tsu.ru/ \
                ftp://79.136.132.145/gentoo/ \
                ftp://ftp-tsk-01.gentoo.tonet.ru \
                ftp://ftp-tsk-05.gentoo.tonet.ru"
FEATURES="sandbox ccache buildpkg parallel-fetch"

#overlays
source /usr/portage/local/layman/make.conf
PORTDIR_OVERLAY="/usr/portage/local/my-overlay $PORTDIR_OVERLAY"
PORTDIR_OVERLAY="/usr/portage/local/portage-ggergely-overlay ${PORTDIR_OVERLAY}"
=======================================================================================
only 2 package used from overlay (emerge -evp system world | grep -e "\[[1-3]\]"):
app-arch/unzip-5.52-r5 from rusxmms and app-office/openoffice-infra-3.0.1 from sunrise
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-02 16:17:01 UTC
Reassigning to kde herd.
Comment 4 emerald 2009-03-02 19:14:17 UTC
As a workaround downgrade to fribidi < 0.19 will let you merge ksvg and a 
fribidi upgrade afterwards will not keep ksvg from working. Nevertheless, this 
is still a bug.
Comment 5 RomanVRE 2009-03-04 16:39:48 UTC
(In reply to comment #4)
> As a workaround downgrade to fribidi < 0.19 will let you merge ksvg and a 
> fribidi upgrade afterwards will not keep ksvg from working. Nevertheless, this 
> is still a bug.
echo =dev-libs/fribidi-0.19.1> /usr/portage/profiles/package.mask
and reemerge dev-libs/fribidi
it resolve this bug
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-04 23:08:45 UTC
(In reply to comment #5)
> echo =dev-libs/fribidi-0.19.1> /usr/portage/profiles/package.mask
> and reemerge dev-libs/fribidi
> it resolve this bug

Like emerald said, this is a workaround, no real fix. Please keep this bug open and leave it to the devs to change the resolution.
Comment 7 Dmitry Halturin 2009-03-13 22:33:18 UTC
Created attachment 184923 [details]
ebuild

fixing ksvg-3.5.10.ebuild
Comment 8 Dmitry Halturin 2009-03-13 22:35:56 UTC
Created attachment 184924 [details, diff]
patch

fix undefined reference to `fribidi_log2vis' and wrong fribidi/fribidi_types.h
Comment 9 404 Error 2009-03-17 21:13:06 UTC
*** Bug 257024 has been marked as a duplicate of this bug. ***
Comment 10 Roby 2009-04-03 16:11:14 UTC
Dmitry Halturin's patch and ebuild work for me.
Comment 11 Tomáš Klimek 2009-04-16 18:48:39 UTC
Dmitry Halturin's patch and ebuild work for me too.
Comment 12 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-30 12:01:09 UTC
In CVS, thanks for the patch :)
Comment 13 Hanno Böck gentoo-dev 2009-05-04 10:14:06 UTC
Still fails for me, I assume due to LDFLAGS --as-needed. CC-ing flameeyes, as he's the as-needed expert.

(sidenote: also throws QA warnings about configure options)

tWidget.cc
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../.. -I/usr/include/freetype2 -I../../../ksvg -I../../../ksvg/dom -I../../../ksvg/impl -I../../../ksvg/ecma -I../../../ksvg/core -I../../../ksvg/impl/libs/libtext2path/src -I/usr/kde/3.5/include -I/usr/qt/3/include -I.   -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -march=core2 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -fexceptions -c -o svgdisplay.o svgdisplay.cc
In file included from /usr/kde/3.5/include/kaboutdata.h:25,
                 from svgdisplay.cc:5:
/usr/qt/3/include/qimage.h: In member function 'bool QImageTextKeyLang::operator<(const QImageTextKeyLang&) const':
/usr/qt/3/include/qimage.h:61: warning: suggest parentheses around && within ||
/usr/qt/3/include/qptrlist.h: In member function 'void QPtrList<type>::deleteItem(void*) [with type = KSVG::CanvasItem]':
svgdisplay.cc:32:   instantiated from here
/usr/qt/3/include/qptrlist.h:153: warning: possible problem detected in invocation of delete operator:
/usr/qt/3/include/qptrlist.h:153: warning: invalid use of incomplete type 'struct KSVG::CanvasItem'
../../../ksvg/core/KSVGCanvas.h:52: warning: forward declaration of 'struct KSVG::CanvasItem'
/usr/qt/3/include/qptrlist.h:153: note: neither the destructor nor the class-specific operator delete will be called, even if they are declared when the class is defined.
/usr/qt/3/include/qdict.h: In member function 'void QDict<type>::deleteItem(void*) [with type = KSVG::CanvasChunk]':
svgdisplay.cc:32:   instantiated from here
/usr/qt/3/include/qdict.h:100: warning: possible problem detected in invocation of delete operator:
/usr/qt/3/include/qdict.h:100: warning: invalid use of incomplete type 'struct KSVG::CanvasChunk'
../../../ksvg/core/KSVGCanvas.h:53: warning: forward declaration of 'struct KSVG::CanvasChunk'
/usr/qt/3/include/qdict.h:100: note: neither the destructor nor the class-specific operator delete will be called, even if they are declared when the class is defined.
/bin/sh ../../../libtool --silent --tag=CXX --mode=link x86_64-pc-linux-gnu-g++  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -march=core2 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -fexceptions  -Wl,-O1,--as-needed,--sort-common,--hash-style=gnu -o svgdisplay -R /usr/kde/3.5/lib64 -R /usr/kde/3.5/lib64 -R /usr/qt/3/lib64 -R /usr/lib64 -L/usr/kde/3.5/lib64 -L/usr/qt/3/lib64 -L/usr/lib64    SVGTestWidget.o svgdisplay.o -lkdecore -lfribidi ../../libksvg.la
/var/tmp/portage/kde-base/ksvg-3.5.10/work/ksvg-3.5.10/ksvg/impl/libs/libtext2path/src/.libs/libtext2path.so: undefined reference to `fribidi_log2vis'
collect2: ld returned 1 exit status
make[2]: *** [svgdisplay] Error 1
make[2]: Leaving directory `/var/tmp/portage/kde-base/ksvg-3.5.10/work/ksvg-3.5.10/ksvg/test/external'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kde-base/ksvg-3.5.10/work/ksvg-3.5.10/ksvg/test'
make: *** [install-recursive] Error 1
 *
 * ERROR: kde-base/ksvg-3.5.10 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 4485:  Called kde-meta_src_install
 *             environment, line 3123:  Called kde-meta_src_install 'make' 'dodoc'
 *             environment, line 3132:  Called die
 * The specific snippet of code:
 *                           emake DESTDIR="${D}" destdir="${D}" install || die "emake install failed.";
 *  The die message:
 *   emake install failed.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/kde-base:ksvg-3.5.10:20090504-100218.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/ksvg-3.5.10/temp/environment'.
 *
 * QA Notice: Unrecognized configure options:
 *
 *      configure: WARNING: unrecognized options: --without-debug
 *      configure: WARNING: unrecognized options: --without-debug
Comment 14 Oschtan 2009-05-23 17:08:57 UTC
Hmm. kde-base/ksvg-3.5.10 from portage-tree compile successfully!
dev-libs/fribidi-0.19.1
Comment 15 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-26 12:00:37 UTC
@Hanno: looking at other ebuilds, i want you to try either:
append-ldflags -Wl,--no-as-needed
or filter-ldflags -Wl,--as-needed --as-needed
Comment 16 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 10:53:07 UTC
fixed now