Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263454 - =kde-base/kgpg-3.5* fails to parse gpg keyring listing when using >=app-crypt/gnupg-2.0.10
Summary: =kde-base/kgpg-3.5* fails to parse gpg keyring listing when using >=app-crypt...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/188473
Whiteboard:
Keywords:
: 274249 274915 (view as bug list)
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2009-03-23 08:50 UTC by Toralf Förster
Modified: 2009-11-07 18:33 UTC (History)
23 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
screen shot (screenshot.jpg,283.55 KB, image/jpeg)
2009-03-23 08:50 UTC, Toralf Förster
Details
Fixes parsing of gnupg’s output. (kgpg-3.5.10-gnupg-fixed-list-mode.patch,10.93 KB, patch)
2009-07-09 14:49 UTC, David 'Bombe' Roden
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2009-03-23 08:50:09 UTC
Upgrading gnupg yields kgpg during start to put our tons of lines like this :
tfoerste@n22 ~ $ kgpg
QDate::setYMD: Invalid date 1092-18-78
QDate::setYMD: Invalid date 9722-45-09
QDate::setYMD: Invalid date 9762-26-04
QDate::setYMD: Invalid date 1047-11-05
QDate::setYMD: Invalid date 9918-98-08
QDate::setYMD: Invalid date 1040-67-70
QDate::setYMD: Invalid date 8996-37-09
QDate::setYMD: Invalid date 1000-25-89
QDate::setYMD: Invalid date 1173-45-59
QDate::setYMD: Invalid date 1394-97-59
QDate::setYMD: Invalid date 7776-33-03
QDate::setYMD: Invalid date 9788-93-01


Furthermore kgpg column entries are missing (see screen shot)

Reproducible: Always
Comment 1 Toralf Förster gentoo-dev 2009-03-23 08:50:26 UTC
Created attachment 185966 [details]
screen shot
Comment 2 Andreas K. Hüttel archtester gentoo-dev 2009-03-23 15:36:27 UTC
Confirmed, same here. (Mostly stable) amd64, problem occurs since gnupg update.

app-crypt/gnupg-2.0.10
kde-base/kgpg-3.5.9
Comment 3 Toralf Förster gentoo-dev 2009-03-23 15:54:07 UTC
Ah yes, stable Gentoo x86, 2.6.27-gentoo-r10, KDE 3.5.10
Comment 4 Stephan Karacson 2009-03-23 17:34:28 UTC
Here too, amd64:
sys-kernel/gentoo-sources-2.6.27-r8
app-crypt/gnupg-2.0.10
kde-base/kdeutils-3.5.9-r1
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-23 20:52:19 UTC
And I thought I did something wrong with my GPG keys...

# qlist -CIve kgpg gnupg
app-crypt/gnupg-2.0.11
kde-base/kgpg-3.5.10
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2009-03-23 22:02:05 UTC
I think it would make sense to change the bug summary to 

>=app-crypt/gnupg-2.0.10 : kgpg:3.5 fails to parse gpg keyring listing

Cannot do it myself though... Toralf, what do you think?
Comment 7 Toralf Förster gentoo-dev 2009-03-23 22:15:27 UTC
(In reply to comment #6)
> I think it would make sense to change the bug summary to ....
> Toralf, what do you think?
Feel free to do that :-) 

Comment 8 Paolo Pedroni 2009-03-24 14:29:05 UTC
I tried to recompile kgpg but I had no luck. The problem persisted.
Comment 9 Sebastian L. 2009-03-26 15:42:23 UTC
I'm also not able to select GPG-Keys in Kopetes Cryptography-Plugin, could this have the same reason?
Comment 10 Jim Cunning 2009-03-27 17:27:42 UTC
(In reply to comment #8)
> I tried to recompile kgpg but I had no luck. The problem persisted.
> 
Downgrading to gnupg-2.0.9 seems to be a workaround:
$ qlist -CIv kdeutils gnupg
app-crypt/gnupg-2.0.9
kde-base/kdeutils-3.5.9-r1
$ kgpg --version
Qt: 3.3.8b
KDE: 3.5.9
KGpg: 1.2.2
$ uname -a
Linux jlc64 2.6.25-gentoo-r7 #1 SMP Thu Mar 19 21:40:09 PDT 2009 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ AuthenticAMD GNU/Linux
Comment 11 Michele Caini 2009-03-30 12:11:55 UTC
arch x86, kgpg 3.5.9, gnupg 2.0.10, same problem here.
using right click in konqueror and choosing action -> encrypt file (of course, encrypt with kgpg), I've not available public keys!
it seems that recompile kgpg and gnupg doesn't help, same as moving out .gnupg directory, starting kgpg and then import public/private keys.

gnupg (or better, gpg executable) works fine.
Comment 12 Andreas K. Hüttel archtester gentoo-dev 2009-03-30 13:03:04 UTC
Reported upstream (gnupg developer mailing list and kde bugzilla).

See also 
http://bugs.kde.org/show_bug.cgi?id=188473
Comment 13 Joseph 2009-03-31 00:00:26 UTC
I've got the same problem on amd64; in addition all the keys are gone when I open kgpg.  When I hit "restore" key keys appear but the names, emails beside the keys are gone. 

The only stable version are the bone the has bugs: kgpg-3.5.9
Anybody knows how restore it to previous working version. 
Comment 14 Joseph 2009-03-31 00:09:12 UTC
Indeed as gnupg-2.0.10 is buggy it has nothing to do with kgpg.
downgrading to gnupg-2.0.9 solves the problem. 

Is anybody testing these applications before making them stable?
Comment 15 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-03-31 01:03:26 UTC
kgpg is not parsing the fixed-list/colon mode of gnupg correctly. In >=app-crypt/gnupg-2.0.10, --fixed-list-mode became the default when --with-colons was used, as the output otherwise was not well defined. If you used --fixed-list-mode already, then the output did NOT change. If you didn't then the output DID change.

I direct you to gnupg-2.0.9/doc/DETAILS for the output format of fixed-list-mode.

gnupg is not broken. kgpg just fails at parsing because it never used fixed-list-mode, and now it needs to. It's not limited to kgpg:3.5 either, I see kgpg-4.2* is broken as well.

Of specific note to whomever goes to fix kgpg:
1. Check the format of timestamps before you try to parse them. There are _3_ valid formats. Unix epoch seconds ("192388500"), ISO8601 full ("19760205T091500") ISO8601 short date ("1976-02-05").
2. The name for the key is not available on the pub record, it must be obtained from the uid record.

As for testing, we run the gnupg testsuite with each release. We don't go and test every app that simply uses gnupg.
Comment 16 Rolf Eike Beer archtester 2009-04-11 11:50:17 UTC
Yes, I can as KGpg maintainer confirm that this is a problem that needs to be fixed in KGpg. Please track the KDE bugtracker for this problem, the commits with the fixes will be noted there.
Comment 17 Toralf Förster gentoo-dev 2009-04-24 07:56:28 UTC
Unfortunately it will only be fixed in KDE-4.x or ?
Comment 18 Sylvain Demers 2009-04-28 18:05:52 UTC
(In reply to comment #17)
> Unfortunately it will only be fixed in KDE-4.x or ?

Well, the current patch is for KDE 4, but in the KDE Bugzilla, the comment says "Please test if this gives the same results as before and report back so I can backport this".

So if someone manages to test the patch, it should get backported to KDE-3.
Comment 19 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-28 00:46:30 UTC
There is no patch for kde3 version, since upstream didn't care, and we can't do anything, so closing
Comment 20 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-05-28 15:54:28 UTC
It should be fixed at least in kde-base/kgpg:4.
Comment 21 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-05-28 16:00:57 UTC
Fixed in kde-base/kgpg-4.2.3-r1.
Comment 22 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-28 16:35:39 UTC
I was also trying to upload the patch, got weird CVS errors until i got a mail that the bug is fixed :P
Thanks for the commit and sorry for the closing, i thought that the upstream commit was included in 4.2.3
Comment 23 Toralf Förster gentoo-dev 2009-05-31 08:36:28 UTC
BTW what's about people running 3.5.10 and 4.2. in parallel. Those should have sth like this, or ?

/etc/portage/package.mask/misc:>app-crypt/gnupg-2.0.9
Comment 24 Mike Auty (RETIRED) gentoo-dev 2009-06-25 12:41:13 UTC
*** Bug 274915 has been marked as a duplicate of this bug. ***
Comment 25 Mike Auty (RETIRED) gentoo-dev 2009-06-25 12:42:27 UTC
Reopening as per the duplicate bug 274915.
Comment 26 Sebastian Luther (few) 2009-06-28 15:10:47 UTC
*** Bug 274249 has been marked as a duplicate of this bug. ***
Comment 27 David 'Bombe' Roden 2009-07-09 14:49:23 UTC
Created attachment 197345 [details, diff]
Fixes parsing of gnupg’s output.

I have created a patch for kgpg-3.5.10 that at least shows name and email of a key in the main window. No further testing has been done, also I can’t get it integrated into an ebuild (because of all that eclass stuff).
Comment 28 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-09 14:52:45 UTC
(In reply to comment #27)

Please attach this patch also in upstream bug at:
https://bugs.kde.org/show_bug.cgi?id=188473
Comment 29 David 'Bombe' Roden 2009-07-10 07:01:29 UTC
(In reply to comment #28)
> (In reply to comment #27)
> 
> Please attach this patch also in upstream bug at:
> https://bugs.kde.org/show_bug.cgi?id=188473

Done.
Comment 30 Toralf Förster gentoo-dev 2009-07-21 09:34:35 UTC
BTW b/c 3.5.10 depends on <=gnupg-2.0.9 I'm wondering why that was removed from the portage tree ...
Comment 31 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-11-07 18:33:29 UTC
=kde-base/kgpg-3.5* has been masked for removal.
This bug won't be fixed.