Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225691 - zwnj character causes the cursor jump in kde
Summary: zwnj character causes the cursor jump in kde
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-06-09 23:10 UTC by Ali Yazdi
Modified: 2009-05-27 22:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ali Yazdi 2008-06-09 23:10:00 UTC
zwnj(SHIFT+SPACE) is zero-width character that is used in Persian(Farsi) keyboard. It causes  two parts of a word do not join together. for example:
می‌رویم
if the zwnj is not used the word would be like this:
میرویم
which is gramatically incorrect.

The problem is that when typing zwnj in kde applications like kate, kedit , kwite, kbabel and etc. the cursor will jump from correct position in the text to another place in the line, which makes editing and selecting nearly impossible.

 



Reproducible: Always

Steps to Reproduce:
1.open kedit
2.switch to persian keyboard 
3.write something with zwnj(SHIFT+space) between them
4.try to edit or select some part.

Actual Results:  
cursor jumps to from current place to another part of the line. which makes editing text impossible.

Expected Results:  
cursor should stay in it place like any other text editors.

This bug exists in almost all of KDE text editing applications.
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 22:41:34 UTC
Since you mentioned kbabel, i suppose you use kde3 and i'll have to close this, as it is a pure upstream bug and since development of kde3 is frozen you can't report upstream and we can't do anything.