Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245509 - kde-base/konsole-4.3.0: Paragraph selection with mouse followed by vertical scroll down truncates first paragraph
Summary: kde-base/konsole-4.3.0: Paragraph selection with mouse followed by vertical s...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-11-04 13:22 UTC by Jeremy Murphy
Modified: 2009-09-15 08:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Murphy 2008-11-04 13:22:50 UTC
Triple-click-and-hold on a multi-line (ie: wrapped) row of text in the history followed by scrolling downwards results in loss of all but the last row of the multi-line text that was initially selected.

Reproducible: Always

Steps to Reproduce:
1. start Konsole
2. set the size to 80x25 and font to Monospace, 9 point
3. emerge --info
4. scroll back to the start
5. triple-click-and-hold on the first line of output "Portage ...", which will almost certainly be multi-line (figure it out otherwise)
6. scroll back down so that all the output is selected
7. let go of your mouse button
*** That's sufficient to create the bug, the next steps are to verify it only.
8. scroll back up to the top - do not disturb the selected text
9. see that only the second line of the multi-line row is selected
10. copy the selected text and paste it somewhere to verify
Actual Results:  
6.25-gentoo-r8 i686)
=================================================================
System uname: 2.6.25-gentoo-r8 i686 Intel(R) Pentium(R) M processor 1.86GHz
etc, etc

Expected Results:  
Portage 2.1.4.5 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r8 i686)
=================================================================
System uname: 2.6.25-gentoo-r8 i686 Intel(R) Pentium(R) M processor 1.86GHz
etc, etc

This also happens on my ~amd64 system.  This bug is not a big deal, but I thought it was kind of interesting.

Portage 2.1.4.5 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r8 i686)
=================================================================
System uname: 2.6.25-gentoo-r8 i686 Intel(R) Pentium(R) M processor 1.86GHz
Timestamp of tree: Tue, 04 Nov 2008 06:15:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distcc distlocks fixpackages metadata-transfer parallel-fetch prelink sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.iinet.net.au/pub/Gentoo "
LC_ALL="en_AU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_AU en_AU.UTF-8 en_GB en_GB.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa bash-completion berkdb bluetooth branding bzip2 cairo cddb cdr cli cracklib crypt curl dbus dga dri dts dv dvb dvd dvdr dvdread emboss encode evo expat fam ffmpeg fftw firefox flac fontconfig fortran gdbm gif gnome gnutls gpm graphviz gstreamer gtk hal iconv ieee1394 imlib ipv6 isdnlog java java6 javascript jpeg kde kqemu laptop libnotify lirc lzo mad matroska midi mikmod mmap mmx mng mp3 mpeg mplayer mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session sharedmem spell spl sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs syslog tcpd theora tiff truetype unicode usb vorbis wifi win32codecs wmf wxwindows x86 xcomposite xml xorg xpm xscreensaver xv xvid xvmc zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_AU en_AU.UTF-8 en_GB en_GB.UTF-8" USERLAND="GNU" VIDEO_CARDS="fglrx radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 13:51:00 UTC
We can't do anything about this, try to upgrade to 3.5.10 if you haven't already, upstream stopped development of kde3 so closing
Comment 2 Jeremy Murphy 2009-08-18 07:44:37 UTC
Turns out that this bug still exists in 4.3.0, so that's what I'm refocusing it on.
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2009-08-18 08:44:34 UTC
In that case report it into upstream bugzilla :]
http://bugs.kde.org/
because they are the one supposed to write patches on feature requests :]