Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 212412 - kde-base/kdegraphics-3.5.9: kdvi can't produce eps pictures. xdvi works fine
Summary: kde-base/kdegraphics-3.5.9: kdvi can't produce eps pictures. xdvi works fine
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-03-05 19:21 UTC by Bartosz Marek
Modified: 2009-05-29 12:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
test-kdvi-3.5.9_texlive.tar.bz2 (test-kdvi-3.5.9_texlive.tar.bz2,81.63 KB, application/octet-stream)
2008-04-25 18:17 UTC, Wulf Krueger (RETIRED)
Details
Testcase where kdvi does not display correctly (test_kdvi_livetex.tar.bz2,10.35 KB, application/octet-stream)
2009-01-03 17:27 UTC, glowwormy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Marek 2008-03-05 19:21:41 UTC
I've changed tetex with texlive as latex compiler.
Now I can't view eps pictures in dvi files with kdvi (kdegraphics-3.5.9). kdvi says:
QApplication::notify: Unexpected null receiver
kdvi (kdegraphics): ERROR: GS did not produce output.
Text is ok, but pictures are white areas. The xdvi works fine.

Reproducible: Always

Steps to Reproduce:
1.kdvi some_dvi_with_eps_picture.dvi
2.
3.

Actual Results:  
I've recompiled different versions of ghostscript (ghostscript-gnu, ghostscript-esp, ghostscript-gpl). I've recompiled kdegraphics. Then I did revdep-rebuild and emerge -DN world. Nothing changes.

Expected Results:  
The software should work perfectly and show the pictures inside dvi files.

Attention: I've 32 bit system, not amd64

Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-4.2.3, glibc-2.7-r1, 2.6.24-gentoo-r2 i686)
=================================================================
System uname: 2.6.24-gentoo-r2 i686 AMD Athlon(tm) 64 Processor 3000+
Timestamp of tree: Tue, 04 Mar 2008 08:16:02 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.4.4-r4, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0_rc6-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe "
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/service"
CONFIG_PROTECT_MASK="/etc/conf.d/clock /etc/conf.d/consolefont /etc/conf.d/hostname /etc/conf.d/keymaps /etc/conf.d/net /etc/cups /etc/cups/cupsd.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/hosts /etc/man.conf /etc/portage /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d /etc/vsftpd/"
CXXFLAGS="-O2 -march=athlon-xp -pipe "
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache collision-protect distlocks keepwork metadata-transfer parallel-fetch prelink sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="pl_PL"
LC_ALL="pl_PL"
LINGUAS="pl en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="# & 3dnow 3dnowex 3dnowext KDE X Xaw3d a52 aac acl acpi ada aim alsa amd amr and applications artworkextra asf asm audio audiofile bash-completion bcmath bdf beagle bidi binfilter bl blender-game bluetooth burner bzip2 bzlib cairo cdparanoia cdr cle266 cli codecs communicators compilers compression cpdflib cracklib crypt cscope css ctype cups curl cvs cvsgraph d daemons dbus desired devices dga divx4linux djvu dlloader dmi dri dts dv dvb dvd dvdr dvdread dvi dxr3 edl emboss encode etc examples exif expat extensions external f77 fam fat fbcon features ffmpeg fftw firefox flac flash font-server fonts fortran ftp fuse gaim gb gcj gd gdb gdbm gg ggi gif gimp gimpprint ginac glade glibc-compat20 glibc-omitfp glitz glx gmp gnokii gnuplot gnutls gphoto2 gpm graph/video graphics gs gtk gtk2 gui gvim gzip hal hfs iconv icq icu id3 idea idn ieee1394 iksemel image imagemagick imap innodb iodbc iproute2 ipv6 ipv6arpa irc irda irmc irssi isdnlog j2ee jabber java javacomm javascript jbig jfs john jp2 jpeg jpeg2k kde kdeenablefinal kdegraphics kdehiddenvisibility kdepim kdexdeltas lame language latex lcms ldap lesstif libcaca libedit libs libsamplerate live lm_sensors lua lzo lzw mad maildir matroska md5sum midi mikmod mime mimencode mjpeg mmap mmx mmx2 mmxext mng mnogosearch mod mouse mozdevelop mozsvg mp3 mp4 mp4live mpd-mad mpeg mpeg2 mpeg4 mplayer mpx msn mudflap musepack nautilus ncurses neXt net network nforce2 nfs nls nntp nodrm not nptl nptlonly nsplugin ntfs ntlm nvidia nvtv objc objc++ octave offensive ogg openal openexr opengl openmp openssh osc other pango pascal pcntl pcre pdf pdfkit peech perl pheaders plotutils png posix povray ppds pppd print processor programming protocols python qt qt3 qt3support qt4 quicktime rar real realmedia reflection reiser4 reiserfs rle sasl scanner scp screen sdk sdl seamonkey security sendfile serial session setup sftp sftplogging shaper shorten simplexml skey slang slp smime sms sndfile sockets socks5 sound sourceview sox speedo speex spell spl sql sse sse2 sse3 ssh ssl subp subtitles subversion support svg svga swf sysfs system sysvipc szip t1lib tcl tcltk tcpd tex tga theora threads tiff tk tlen transcode truetype type1 ucs2 udev unicode unknown usb useful userlocales utf8 v4l v4l2 valgrind vcd vdr vfat video vidix vim vim-with-x voice vorbis win32codecs wma wma123 wmf wxwindows x264 x86 xanim xcomposite xfs xine xinerama xml xml2 xmlreader xmlrpc xmlwriter xorg xpm xprint xv xvid xvmc yahoo yp yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Wulf Krueger (RETIRED) gentoo-dev 2008-04-25 18:17:32 UTC
Created attachment 150962 [details]
test-kdvi-3.5.9_texlive.tar.bz2

I'm sorry but I can't reproduce this. Inside the archive I attached you'll find test.tex, avatar.eps (which is an old avatar of mine :-) ) and test.dvi. My kdvi from 3.5.9 displays the picture just fine as does xdvi.

Can you provide me with a test that fails for you?
Comment 2 glowwormy 2009-01-03 17:27:16 UTC
Created attachment 177233 [details]
Testcase where kdvi does not display correctly

I have the same problem and created a minimal test file. It contains test.tex which uses asymptote to generate an eps file and include this one. The resulting file is test.dvi. It is displayed correctly with xdvi 22.84.14 from texlive 2007 and without the eps file by kdvi 3.5.10.
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 12:06:55 UTC
I think this is an upstream problem and we can't do anything. Unless there is a patch available please reopen