Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240560 - kde-base/kdelibs-3.5.10-r1 wipes off kde-misc/kima-0.7.4 from the kicker applet list
Summary: kde-base/kdelibs-3.5.10-r1 wipes off kde-misc/kima-0.7.4 from the kicker app...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-10-08 18:52 UTC by Konstantinos Tzanis
Modified: 2009-05-27 22:47 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantinos Tzanis 2008-10-08 18:52:02 UTC
When upgrading to kdelibs-3.5.10-r1 and restarting kde session, kima disappears from the kicker and from the applet list as well. Another issue with kdelibs-3.5.10-r1 is with 
x11-themes/polyester-1.0.3
http://www.kde-look.org/content/show.php?content=27968

which I added it throught local overlay and it disappeared as well from the Control Center/Appearence & Themes/Style

Reproducible: Always

Steps to Reproduce:
1.upgrade to kdelibs-3.5.10-r1
2.restart kde
3.kima disappears from kicker and applet list




emerge --info
Portage 2.1.4.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r8 i686)
=================================================================
System uname: 2.6.25-gentoo-r8 i686 AMD Athlon(tm) XP 3200+
Timestamp of tree: Wed, 08 Oct 2008 13:30:09 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -pipe -funit-at-a-time"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -pipe -funit-at-a-time"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy ccache collision-protect distlocks fixpackages metadata-transfer nostrip parallel-fetch sandbox sfperms strict too unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo "
LDFLAGS="-Wl,-O1"
LINGUAS="en el"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=30"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa aom apache2 asf avi bash-completion berkdb bluetooth browserplugin bzip2 cairo calendar cddb cdparanoia cdr chm cli cracklib crypt cups dbus dio divx4linux doc dri dts dvd dvdr dvdread encode ethereal examples exif fbcon ffmpeg flash fortran ftp gcj gd gdbm gif gimpprint gnutls gpm gtk2 hal icc iconv id3 ieee1394 imagemagick imlib ipv6 isdnlog java javascript jikes jpeg jpeg2k junit kde kdepim kdexdeltas kipi lame lcms lirc lm_sensors mbox memlimit mhash midi mime ming mmx mozilla mp3 mpeg mpeg2 mplayer msn mudflap musicbrainz mysql mysqli nas ncurses network nfs nls nocd nptl nptlonly nsplugin nvidia obex ogg opengl openmp oss pam pcre pda pdf pdflib perl php plotutils png posix ppds pppd prelude python qt qt4 quicktime readline real recode reflection samba scanner sdl session slp smp snmp sockets socks5 spell spl sql sqlite sse sse2 ssl svg svga sysfs tcpd theora threads tiff truetype unicode usb v4l v4l2 vhosts vorbis win32codecs x86 xcomposite xlib xml xml2 xorg xprint xv xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en el" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Yar Odin 2008-10-09 12:47:22 UTC
Remoivng KDEDIRS="/usr/kde/3.5:/usr:/usr/local" from /etc/env.d/45kdepaths-3.5
on kdelibs 3.5.10-r1 wipes off kde-misc/kima-0.7.4 from the kicker applet list.

I think problems with some themes deals with removing KDELIBS too.
Comment 2 Andrew Gaydenko 2008-10-10 09:02:41 UTC
the same (wrt kima) on ~amd64.
Comment 3 Konstantinos Tzanis 2008-10-15 18:57:04 UTC
Kima-0.7.4 is wipped off from the kicker and the kicker applet list with kdelibs-3.5.10-r2 as well
Comment 4 Yar Odin 2008-10-16 15:33:00 UTC
(In reply to comment #3)
> Kima-0.7.4 is wipped off from the kicker and the kicker applet list with
> kdelibs-3.5.10-r2 as well
> 

same ;)
Comment 5 Johannes H. 2008-10-24 22:00:51 UTC
Same with  net-wireless/kwlaninfo  and  net-misc/knetload. Kima vanished here, too.
Comment 6 tzopik 2008-10-31 00:07:06 UTC
(In reply to comment #5)
> Same with  net-wireless/kwlaninfo  and  net-misc/knetload. Kima vanished here,
> too.
> 

i confirm net-wireless/kwlaninfo-0.9.5 has disaper, because this is installed in
>>> /usr/lib/libkwlaninfo.so
>>> /usr/lib/libkwlaninfo.la

i think the real place is /usr/kde/3.5/lib/
Comment 7 Jan Kundrát (RETIRED) gentoo-dev 2008-11-07 15:48:38 UTC
What happens when you reinstall the packages that have "disappeared"?
Comment 8 Konstantinos Tzanis 2008-11-08 10:51:52 UTC
(In reply to comment #7)
> What happens when you reinstall the packages that have "disappeared"?
> 

No change at least for kima and polyester
Comment 9 Tobias Roeser 2008-11-16 15:47:54 UTC
It seems, this happens to almost every package that installes a Kicker Applet but ist not a "kde-meta" package.

I think, the kde-3.5.10 release has a changed place for it's applets to avoid conflicts with kde 4.x installations. 

Unfortunatelly, the maintainer forgot to update packages with provider "external" kicker applets like: kthinkbat, kblogger, kshutdown, kima, ...

A simple workaround might be to symlink the *.desktop files from /usr/share/apps/kicker/applets to /usr/kde/3.5/share/apps/kicker/applects and bug the package maintainers.

Don't know, what the best ebuild snippet should looks like, which does exactly that without hardcoding the path.
Comment 10 jijo 2009-01-19 13:17:02 UTC
> A simple workaround might be to symlink the *.desktop files from
> /usr/share/apps/kicker/applets to /usr/kde/3.5/share/apps/kicker/applects and
> bug the package maintainers.

That worked. Thanks. :)
Comment 11 Boian Berberov 2009-01-26 12:56:18 UTC
What about making an exception for this package through set-kdedir in the kde-functions.eclass?
Comment 12 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 22:47:01 UTC
fixed with new eclasses, recompile your packages, now prefix is /usr/kde/3.5 in eclasses