Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 241782 - Konqueror, Kate 3.5.10 toolbar items missing after KDE4 installation
Summary: Konqueror, Kate 3.5.10 toolbar items missing after KDE4 installation
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 242900 (view as bug list)
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-10-13 15:08 UTC by MarisN
Modified: 2009-05-27 09:46 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Konqueror-3.5.10 when logged-in as new user for first time (konqueror_toolbar.png,160.32 KB, text/plain)
2008-10-14 12:53 UTC, MarisN
Details
Konqueror-3.5.10 when logged-in as new user for first time (konqueror_toolbar.png,160.32 KB, image/png)
2008-10-14 12:56 UTC, MarisN
Details
kdeartwork-iconthemes-4.1.2.ebuild (kdeartwork-iconthemes-4.1.2.ebuild,634 bytes, text/plain)
2008-11-02 02:54 UTC, Rick Harris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MarisN 2008-10-13 15:08:29 UTC
After emerging KDE4 Konqueror and it's dependencies KDE3 Konqueror (3.5.10) is missing most of toolbar icons. Main tolbar contains only "reload" and "stop" action icons. Kate is also missing some icons (cut, copy, paste, print, zoom etc.).

Changing toolbar look from icons only to text only does NOT fix problem.

Running `kbuildsycoca --noincremental` and rebooting also does not fix problem.

When using toolbar editor in Konqueror all icons are there. Also using "reset to default" button does not help at all.

Reproducible: Always
Comment 1 Patrizio Bassi 2008-10-13 16:58:37 UTC
ack, same issue here.
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2008-10-14 11:00:48 UTC
I guess kiconfinder find the correct icons...?
Could you make screenshot how does it look like?
Does this occur if you try to login into kde3 as new user?
Comment 3 MarisN 2008-10-14 12:53:57 UTC
Created attachment 168414 [details]
Konqueror-3.5.10 when logged-in as new user for first time
Comment 4 MarisN 2008-10-14 12:56:06 UTC
Created attachment 168416 [details]
Konqueror-3.5.10 when logged-in as new user for first time
Comment 5 DiG 2008-10-19 10:21:02 UTC
same here...

moving (or removing) "/usr/share/apps/konqueror/konqueror.rc", owned by kde-base/konqueror-4.1.2, and reseting toolbars to default solves the problem in kde-3.5.10.

ACCEPT_KEYWORDS="~x86"
USE="-kdeprefix"
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2008-10-20 16:07:08 UTC
For some wierd reasons with strace it searches in /usr/kde/3.5 and in /usr for its .rc files. So it loads both and in the end it ends up not usable too much. You can try this behavior with strace. I was not much sucessful about forcing it looking into /usr/kde/3.5 so if anyone else wants to try...
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2008-10-21 19:56:46 UTC
*** Bug 242900 has been marked as a duplicate of this bug. ***
Comment 8 Nickolay Kolchin-Semyonov 2008-10-22 04:19:02 UTC
It sounds like adding "kdeprefix" should solve this problem. Can anybody confirm that?

Comment 9 Tomáš Chvátal (RETIRED) gentoo-dev 2008-10-22 17:49:40 UTC
(In reply to comment #8)
> It sounds like adding "kdeprefix" should solve this problem. Can anybody
> confirm that?
> 

Dont even try that if you dont think about it. Kdeprefix will mean that when we introduce 4.2 your 4.1 will be kept around and 4.2 will be installed as new slot... and so on.
So kdeprefix is not fixer.
Comment 10 Duncan 2008-10-22 20:57:41 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > It sounds like adding "kdeprefix" should solve this problem. Can anybody
> > confirm that?
> > 
> Dont even try that if you dont think about it. Kdeprefix will mean that
> when we introduce 4.2 your 4.1 will be kept around and 4.2 will be
> installed as new slot... and so on. So kdeprefix is not fixer.

But that's no big deal for Gentooer-KDEers who've been around for awhile, as it's always been the case.  When you install a new KDE minor version (3.4 > 3.5 for instance), you still have the old one around, just in case you need it, until you're sure everything's working with the new one, after which you can remove the old one.  So really, if that behavior continues for 4.1 > 4.2, no big deal, it's the same as it has always been.  When you think you don't need the old one any more, you simply remove it.

And that would seem less hassle than having /this/ sort of thing happen, particularly since we're already used to that, and don't have to worry about it, while this is a continuing problem we're /not/ used to yet and with no real current solution.

OTOH I at least, never needed the old version anyway.  Major version change (3.x to 4.x), sure, but not minor.  And that's why I went -kdeprefix here.  If it works, which it doesn't right now, it'd mean not having to worry about unmerging the old version, used to it as we may already be.  So it's worth continuing to work on, but yeah, kdeprefix would probably solve the current problem.  (What others it may bring, however, particularly as non-kde-base kde apps get upgraded to 4.x versions and installed, I'm not sure.)

Duncan
Comment 11 Rick Harris 2008-11-02 02:48:19 UTC
This bug applies to most KDE3 applications running under KDE4, not just Kate/Konqueror.

Caused by /usr/kde/4.2/share/icons/crystalsvg/index.theme file not correctly inheriting the hicolor/index.theme to be able to find the needed PNGs.

The solution is to add the following routine at the bottom of the
kde-base/kdeartwork-iconthemes-4.1.2.ebuild

src_install () {
        kde4-meta_src_install

        # Fix broken/missing icons for KDE3 applications in KDE4 #
        if [[ -z "`grep "Inherits=hicolor" ${D}${KDEDIR}/share/icons/crystalsvg/index.theme`" ]]; then
                sed -i -e '/Example=folder/i\Inherits=hicolor' ${D}${KDEDIR}/share/icons/crystalsvg/index.theme || \
                        die "Sed failed for ${D}${KDEDIR}/share/icons/crystalsvg/index.theme"
        fi
}
Comment 12 Rick Harris 2008-11-02 02:54:40 UTC
Created attachment 170499 [details]
kdeartwork-iconthemes-4.1.2.ebuild

Text wrapped oddly in previous post so here is the modified ebuild.
Comment 13 Nickolay Kolchin-Semyonov 2008-11-02 08:37:27 UTC
Didn't work for me.

I doubt that the problem is in theme file. Icons are correctly displayed in Toolbar Configuration Dialog.
Comment 14 Rick Harris 2008-11-02 20:50:52 UTC
Hmm, my mistake. Looks like this bug is *only* relevant to Kate and Konqueror.

My post was to do with a more generic breakage of icons in any KDE3 apps. being run in a KDE4 session (encompassing Kate and Konqueror).

Another grey area is whether or not the original poster is running Kate/Konq. in a KDE3 or KDE4 session (*shrugs*).

I'll file another bug with the fix elsewhere, thanks Nickolay :)
Comment 15 MarisN 2008-11-03 08:56:29 UTC
(In reply to comment #14)
> Another grey area is whether or not the original poster is running Kate/Konq.
> in a KDE3 or KDE4 session (*shrugs*).

It's not a "grey area". As can be seen from comment #4 it affects KDE 3.5.10 session. Toolbar icon/tool breakage isn't only one issue. I.e. Kolourpaint has menus from KDE4(?) -> it displays "DO NOT TRANSLATE" menu, still KDE3 doesn't have such string in POT file (and Kolourpaint from KDE3 isn't translated to Latvian language) -> menu is coming from KDE4 Kolourpaint version.
Comment 16 Vladimir Berezhnoy 2008-11-05 21:56:34 UTC
This affects all kde3 apps which are installed not in $KDEPREFIX (i.e ktorrent amarok kdebluetooth k3b filelight). Those which are installed in $KDEPREFIX seem to be normal. And also this is only related to icons, but not to applications plugins.

If it matters, i'm using @kde-live with USE=kdeprefix
Comment 17 Nickolay Kolchin-Semyonov 2008-11-06 07:56:56 UTC
On "standard" kde-meta-3.* installation, this affects many KDE3 applications: konqueror, kopete. Even when KDE4 applications were never run under user account.
Comment 18 Peter Alfredsen (RETIRED) gentoo-dev 2008-11-18 23:42:34 UTC
Regarding the original issue in #0, does deleting (or #commenting) the line containing dir_data from /usr/kde/3.5/share/config/kdeglobals solve the problem ?
Comment 19 MarisN 2008-11-20 10:34:08 UTC
Can't test it anymore, as due to this bug I unmerged all KDE4 related things.
(In reply to comment #18)
> Regarding the original issue in #0, does deleting (or #commenting) the line
> containing dir_data from /usr/kde/3.5/share/config/kdeglobals solve the problem
> ?
> 

Comment 20 Hubert Faulhaber 2009-01-11 20:23:50 UTC
(In reply to comment #18)
> Regarding the original issue in #0, does deleting (or #commenting) the line
> containing dir_data from /usr/kde/3.5/share/config/kdeglobals solve the problem
> ?
> 
The suggested solution solved it for me.

Comment 21 César Fernández 2009-01-15 22:56:56 UTC
(In reply to comment #18)
> Regarding the original issue in #0, does deleting (or #commenting) the line
> containing dir_data from /usr/kde/3.5/share/config/kdeglobals solve the problem
> ?
> 

Works for me.
Comment 22 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-26 13:47:22 UTC
fixed, after hardcoding paths in kdelibs-3.5