Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225213 - kde-base/konq-plugins-3.5.9 : Invalid dirfilterplugin.desktop service
Summary: kde-base/konq-plugins-3.5.9 : Invalid dirfilterplugin.desktop service
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Low minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2008-06-07 12:35 UTC by Greisberger Christophe
Modified: 2009-05-29 20:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greisberger Christophe 2008-06-07 12:35:36 UTC
I was inspecting my .xsession-errors for another reason, and I saw the following lines :
kio (KService*): WARNING: The desktop entry file .hidden/dirfilterplugin.desktop has Type=Service but is located under "apps" instead of "services"
kio (KService*): WARNING: Invalid Service : .hidden/dirfilterplugin.desktop

I checked, and it's seems to be indeed in the wrong directory :
$ locate dirfilterplugin.desktop
/usr/kde/3.5/share/apps/konqlistview/kpartplugins/dirfilterplugin.desktop
/usr/kde/3.5/share/apps/konqiconview/kpartplugins/dirfilterplugin.desktop
/usr/kde/3.5/share/applnk/.hidden/dirfilterplugin.desktop


Reproducible: Always
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-07 14:22:27 UTC
There is far more of this legacy crap - partly worked around via kde.eclass - to be cleaned up, when looking at the KDE desktop entry mess - even in KDE 4. But, beside the message, this is a non-issue from the user point of view. I'm not even sure right now, if there isn't a special case, where replacing the .hidden/ path with NoDisplay=true in the desktop entry might not work.
Comment 2 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 20:16:40 UTC
closing with same explanation as bug 224265