Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271372 - konqueror-3.5.10 crashes on specific sites
Summary: konqueror-3.5.10 crashes on specific sites
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2009-05-27 07:21 UTC by Roman v. Gemmeren
Modified: 2009-10-05 13:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
applied to kdelibs-3.5.10-r6 (63_fixed-layout-table.diff,1.01 KB, patch)
2009-10-05 13:18 UTC, Roman v. Gemmeren
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Roman v. Gemmeren 2009-05-27 07:21:54 UTC
hi,

ever since i installed konqueror-3.5.10 it crashes if i try to open some websites, the  most famous probably ebay.
If i login, it loads the site, but crashes before displaying, destroying every instance of konqueror.
This happens on x86 and x86_64 default installations and worked fine in 3.5.9.

kde-base/konqueror-3.5.10  USE="branding java kdehiddenvisibility -debug"
kde-base/kdelibs-3.5.10-r5  USE="acl alsa branding fam jpeg2k kdehiddenvisibility tiff -arts -avahi -bindist -cups -debug -doc -kerberos -legacyssl -lua -openexr -spell -utempter"


Reproducible: Always

Actual Results:  
Konqueror crashes

Expected Results:  
Display ebay-website.
Comment 1 Robert Förster 2009-05-27 08:36:10 UTC
emerge --info please
Comment 2 Roman v. Gemmeren 2009-05-27 08:50:24 UTC
(In reply to comment #1)
> emerge --info please
sry!
root@Sleipnir /home/strowi> emerge --info
Portage 2.2_rc33 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-zen12 x86_64)
=================================================================
System uname: Linux-2.6.28-zen12-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_3800+-with-gentoo-2.0.0
Timestamp of tree: Fri, 22 May 2009 06:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.7
dev-lang/python:     2.6.2
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0-r2
sys-apps/openrc:     0.4.2-r1
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -mtune=k8 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8 -mtune=k8 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" #              http://de-mirror.org/distro/gentoo/             http://ftp.uni-erlangen.de/pub/mirrors/gentoo           http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/               http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/            http://gentoo.mneisen.org/              ftp://de-mirror.org/distro/gentoo/"
INSTALL_MASK="TODO.bz2 THANKS.bz2 AUTHORS.bz2 NEWS.bz2 CHANGES.bz2 CHANGELOG.bz2 ChangeLog.bz2 ChangeLog*"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages-sleipnir"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/devnull"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 acl acpi alsa amd64 berkdb branding bzip2 cairo ccache cdr cleartype cli consolekit cracklib crypt custom-cflags custom-cpuopts custom-optimization dar64 dbus divx djvu dri dts dv dvb dvd dvdr dvdread encode exif fam fbcondecor ffmpeg firefox flac fontconfig fortran gif git glitz gpm gs hal iconv imagemagick isdnlog ithreads java jbig jpeg jpeg2k kde kdehiddenvisibility kdeprefix lame logitech-mouse logrotate loop-aes lzma lzo mad midi mjpeg mmx mmxext mp3 mp4 mpeg mtp mudflap multilib musepack ncurses network-cron nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp pam pcre pdf perl png policykit pppd pthreads python qt3 quicktime rar rdesktop readline realmedia reflection resolvconf samba sdl session slp smp spl srt sse sse2 sse3 ssl ssse ssse2 ssse3 subversion svg sysfs syslog tcpd teletext threads tiff truetype truetype-fonts type1-fonts unicode urandom usb userlocales v4l2 vcd vorbis webkit wma wmf wmp x264 xcb xcomposite xinerama xml xmp xorg xscreensaver xv xvid zlib zsh-completion" ALSA_CARDS="snd_hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon fuji ptp2" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="radeon nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-29 20:10:29 UTC
I'm sorry but i'll have to close this. Crashes should be reported upstream, we can't do anything about it, but since the development of kde3 is frozen, i doubt it will be fixed. If you have a patch please reopen. thanks
Comment 4 Yann Forget 2009-10-05 09:23:43 UTC
Since Konqueror 4.x is not available on Gentoo x86_64, it is the responsibility of Gentoo that the most recent stable version works fine.

So either resolve this bug or make Konqueror 4.x available.
Konqueror crashes for this page
http://googleblog.blogspot.com/2009/09/jump-to-information-you-want-right-from.html
which is completely following W3C standards, and this is not acceptable.
Comment 5 Roman v. Gemmeren 2009-10-05 10:27:12 UTC
(In reply to comment #4)
> Since Konqueror 4.x is not available on Gentoo x86_64, it is the responsibility
> of Gentoo that the most recent stable version works fine.
Hm.. I am not really sure about  that..since this problem happened to me with EVERY distribution i tested (Arch/(K)ubuntu/Debian/Mandriva), so it really is an upstream problem, meaning the kde-devs should fix it (but probably won't since kde4 has arrived).
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-10-05 11:24:33 UTC
This is an upstream issue and the KDE team (upstream and Gentoo) no longer cares about KDE3 - if anyone has a patch, we'll apply.
Comment 7 Roman v. Gemmeren 2009-10-05 13:15:04 UTC
ok, i couldn't let it rest... after applying the attached patch manually to kdelibs-3.5.10-r6 repacking && emerging it, i am able to visit my.ebay.de.
Still the table-layout is a little different from how it should look, but at least no crash anymore...
Found it somewhere debian-related...
Comment 8 Roman v. Gemmeren 2009-10-05 13:18:29 UTC
Created attachment 206082 [details, diff]
applied to kdelibs-3.5.10-r6