Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268049 - kde.eclass not working with bibletime. Trying to arts with no arts use flag set.
Summary: kde.eclass not working with bibletime. Trying to arts with no arts use flag set.
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: kde-3.5.10
  Show dependency tree
 
Reported: 2009-04-30 22:42 UTC by Karl Hakimian
Modified: 2009-05-28 02:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (einfo,4.14 KB, text/plain)
2009-04-30 22:43 UTC, Karl Hakimian
Details
build log file (build.log,12.37 KB, text/plain)
2009-04-30 22:43 UTC, Karl Hakimian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Hakimian 2009-04-30 22:42:41 UTC
Emerging bibletime fails with the message

Please check whether you installed aRts correctly or use
--without-arts to compile without aRts support

I'm pretty sure that bibletime does not have any audio options, so I'm not sure what functionality would be lost.


Reproducible: Always

Steps to Reproduce:
1. Make sure you have -arts use flag set.
2. emerge bibletime


Actual Results:  
configure: error: The important program mcopidl was not found!
Please check whether you installed aRts correctly or use
--without-arts to compile without aRts support (this will remove functionality).


Expected Results:  
emerge should complete correctly

By running configure by hand and adding the --without-arts option, things compile fine.
Comment 1 Karl Hakimian 2009-04-30 22:43:16 UTC
Created attachment 190005 [details]
emerge --info
Comment 2 Karl Hakimian 2009-04-30 22:43:46 UTC
Created attachment 190007 [details]
build log file
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-27 23:55:42 UTC
I couldn't reproduce. kde3 eclasses have changed, upgrade to 3.5.10 and try again. reopen if you get the same error again, thanks
Comment 4 Karl Hakimian 2009-05-28 00:17:37 UTC
I assume you mean get kdelibs to 3.5.10 since that is the only kde thing on my system and nothing else related to this bug is close to that version.

I just did another emerge sync and there is no 3.5.10. There is rc1-rc5, should I try any particular one?
Comment 5 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-28 00:24:29 UTC
i tried kde-3.5.10 and bibletime-1.0.5-r1 and -arts, and ./configure showed --without-arts with no problem
Comment 6 Karl Hakimian 2009-05-28 01:32:09 UTC
I'm sure I'm being a bit thick, but there is no kde-3.5.10 in portage. There is kdelibs-3.5.10-rc1-5. Which of those would you suggest I try or am I missing something?
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-28 01:36:05 UTC
yeah with kde-3.5.10 i mean the whole kde. You need only kdelibs-3.5.10-r5 (the latest the better). Try it and report back
Comment 8 Karl Hakimian 2009-05-28 02:32:28 UTC
Looks like kdelibs-3.5.10-rc5 does the trick. Thanks.